aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-apd
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-08 02:50:42 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-08 02:50:42 +0000
commit3934a3fd1555330e70cf7838fd20da39dfe412a4 (patch)
tree2a8ab01bc9ec4e6fa46d139a726579f4d8d25fcc /devel/pear-apd
parent0b4e9a56292e383d2d2c41496b6922dc9a31cc75 (diff)
downloadports-3934a3fd1555330e70cf7838fd20da39dfe412a4.tar.gz
ports-3934a3fd1555330e70cf7838fd20da39dfe412a4.zip
New port: devel/pear-apd - Advanced PHP Debugger (APD).
Adding APD, a full-featured PHP profiler/debugger loaded as a zend_extension. PR: ports/56555 Submitted by: Thierry Thomas <thierry@pompo.net>
Notes
Notes: svn path=/head/; revision=88730
Diffstat (limited to 'devel/pear-apd')
-rw-r--r--devel/pear-apd/Makefile63
-rw-r--r--devel/pear-apd/distinfo1
-rw-r--r--devel/pear-apd/pkg-descr6
-rw-r--r--devel/pear-apd/pkg-message12
-rw-r--r--devel/pear-apd/pkg-plist6
5 files changed, 88 insertions, 0 deletions
diff --git a/devel/pear-apd/Makefile b/devel/pear-apd/Makefile
new file mode 100644
index 000000000000..36d168f27117
--- /dev/null
+++ b/devel/pear-apd/Makefile
@@ -0,0 +1,63 @@
+# Ports collection makefile for: pear-apd
+# Date created: 06 Septemeber 2003
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= apd
+PORTVERSION= 0.4p2
+CATEGORIES= devel
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A full-featured engine-level PHP profiler/debugger
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PHPIZE= yes
+
+CONFIGURE_ARGS= --enable-apd
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+
+.if exists(${LOCALBASE}/bin/php-config)
+EXT_DIR!= ${LOCALBASE}/bin/php-config --extension-dir | ${SED} -e \
+ "s:${PHP_BASE}/::"
+.endif
+PHP_DIR?= ${LOCALBASE}/etc
+DUMP_DIR?= /var/tmp/apd
+PHP_INI= ${PHP_DIR}/php.ini
+PLIST_SUB+= EXTDIR=${EXT_DIR}
+DOCS= README
+
+post-extract:
+ @${CHMOD} -R u+w ${WRKSRC}
+
+post-install-script:
+ @${STRIP_CMD} ${PHP_BASE}/${EXT_DIR}/apd.so
+ @${MKDIR} ${DUMP_DIR}
+ @${CHMOD} a+w ${DUMP_DIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/pprofp ${PREFIX}/bin
+ @if [ ! -f ${PHP_INI} ]; then \
+ ${ECHO_MSG} "===> Creating ${PHP_INI} for PHP" ; \
+ ${CP} -p ${PHP_INI}-dist ${PHP_INI} ; \
+ fi
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for FILE in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE} | \
+ ${SED} -e "s:/usr/local/etc/php.ini:${PHP_INI}:" \
+ -e "s:/usr/local:${LOCALBASE}:" \
+ -e "s:lib/php/20020429:${EXT_DIR}:" \
+ -e "s:/var/tmp/apd:${DUMP_DIR}:"
+ @${ECHO_MSG}
+
+.include <bsd.port.post.mk>
diff --git a/devel/pear-apd/distinfo b/devel/pear-apd/distinfo
new file mode 100644
index 000000000000..ac8fd09c0815
--- /dev/null
+++ b/devel/pear-apd/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/apd-0.4p2.tgz) = 7b13b405033e693e67ac8b9ff5ae93c2
diff --git a/devel/pear-apd/pkg-descr b/devel/pear-apd/pkg-descr
new file mode 100644
index 000000000000..6a5c55e01596
--- /dev/null
+++ b/devel/pear-apd/pkg-descr
@@ -0,0 +1,6 @@
+APD is a full-featured PHP profiler/debugger that is loaded as a
+zend_extension.
+
+It aims to be an analog of C's gprof or Perl's Devel::DProf.
+
+WWW: http://pear.php.net/package/apd
diff --git a/devel/pear-apd/pkg-message b/devel/pear-apd/pkg-message
new file mode 100644
index 000000000000..c3b17d72b2b5
--- /dev/null
+++ b/devel/pear-apd/pkg-message
@@ -0,0 +1,12 @@
+************************************************************************
+
+Do not forget to configure your /usr/local/etc/php.ini file:
+add the line:
+
+zend_extension = /usr/local/lib/php/20020429/apd.so
+apd.dumpdir = /var/tmp/apd
+
+in the section "Dynamic Extensions".
+
+************************************************************************
+
diff --git a/devel/pear-apd/pkg-plist b/devel/pear-apd/pkg-plist
new file mode 100644
index 000000000000..903acfb8107a
--- /dev/null
+++ b/devel/pear-apd/pkg-plist
@@ -0,0 +1,6 @@
+bin/pprofp
+%%EXTDIR%%/apd.so
+%%PKGREGDIR%%/package.xml
+%%PORTDOCS%%%%DOCSDIR%%/README
+@dirrm %%PKGREGDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%