aboutsummaryrefslogtreecommitdiff
path: root/devel/pkgconfig
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-10-05 16:22:23 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-10-05 16:22:23 +0000
commitc296eea387aedf0d67018de5bf8b58b735eaf6d3 (patch)
tree48fcd11ef11e69a1739af04a0f0d6ef281fdc4a7 /devel/pkgconfig
parenta4167bdecee6b1bccd21f18f52612610d53c85ec (diff)
downloadports-c296eea387aedf0d67018de5bf8b58b735eaf6d3.tar.gz
ports-c296eea387aedf0d67018de5bf8b58b735eaf6d3.zip
Update to 0.13.0.
Notes
Notes: svn path=/head/; revision=67327
Diffstat (limited to 'devel/pkgconfig')
-rw-r--r--devel/pkgconfig/Makefile4
-rw-r--r--devel/pkgconfig/distinfo2
-rw-r--r--devel/pkgconfig/files/patch-pkg.c43
3 files changed, 3 insertions, 46 deletions
diff --git a/devel/pkgconfig/Makefile b/devel/pkgconfig/Makefile
index 33578d6fe1d1..5e7aa5bd9b1f 100644
--- a/devel/pkgconfig/Makefile
+++ b/devel/pkgconfig/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= pkgconfig
-PORTVERSION= 0.12.0
+PORTVERSION= 0.13.0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/pkgconfig/0.12
+MASTER_SITE_SUBDIR= sources/pkgconfig/0.13
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
diff --git a/devel/pkgconfig/distinfo b/devel/pkgconfig/distinfo
index f84738360254..188a06cc36e8 100644
--- a/devel/pkgconfig/distinfo
+++ b/devel/pkgconfig/distinfo
@@ -1 +1 @@
-MD5 (gnome2/pkgconfig-0.12.0.tar.bz2) = f539fb0988eae2002bfad8dfe78cd3f3
+MD5 (gnome2/pkgconfig-0.13.0.tar.bz2) = 3883647db644bf791d9ff31c544cf53d
diff --git a/devel/pkgconfig/files/patch-pkg.c b/devel/pkgconfig/files/patch-pkg.c
index 1284af1949e2..4fa85372148d 100644
--- a/devel/pkgconfig/files/patch-pkg.c
+++ b/devel/pkgconfig/files/patch-pkg.c
@@ -29,46 +29,3 @@
+ scan_dir (LPKGLIBDIR, (void *)1);
}
}
-
-@@ -901,6 +904,13 @@
- while (tmp != NULL)
- {
- Package *pkg = tmp->data;
-+ GSList *reqs = pkg->requires;
-+
-+ if (reqs)
-+ {
-+ g_string_append (str, packages_get_other_libs(reqs));
-+ g_string_append (str, " ");
-+ }
-
- if (pkg->other_libs)
- {
-@@ -924,10 +934,13 @@
- char *L_libs;
- char *other_libs;
- GString *str;
-+ GSList *tmp;
- char *retval;
-
- str = g_string_new ("");
-
-+ tmp = pkgs;
-+
- other_libs = packages_get_other_libs (pkgs);
- L_libs = packages_get_L_libs (pkgs);
- l_libs = packages_get_l_libs (pkgs);
-@@ -986,6 +999,13 @@
- while (tmp != NULL)
- {
- Package *pkg = tmp->data;
-+ GSList *reqs = pkg->requires;
-+
-+ if (reqs)
-+ {
-+ g_string_append (str, packages_get_other_cflags(reqs));
-+ g_string_append (str, " ");
-+ }
-
- if (pkg->other_cflags)
- {