aboutsummaryrefslogtreecommitdiff
path: root/devel/popt/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-07-11 13:23:29 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-07-11 13:23:29 +0000
commitcdf0f8628fdbdc5f66f05db535549878a6c787ff (patch)
treef9babaa05c0d390a2c26a2959d814eed88f8edf9 /devel/popt/Makefile
parent50693bb759e729c1e9ab76dfde9d59febfb36e53 (diff)
downloadports-cdf0f8628fdbdc5f66f05db535549878a6c787ff.tar.gz
ports-cdf0f8628fdbdc5f66f05db535549878a6c787ff.zip
o Update to 1.6.4
o Fix libtool .la files installation and potential conflict with libiconv [1] o Take over maintainership [2] Submitted by: marcus [1] Reviewed by: anders, marcus, will, FreeBSD-Ports mailing list Requested by: Yuan-Chen Cheng <ycheng@sinica.edu.tw> (previous maintainer) [2] Approved by: Yuan-Chen Cheng <ycheng@sinica.edu.tw> (previous maintainer)
Notes
Notes: svn path=/head/; revision=62810
Diffstat (limited to 'devel/popt/Makefile')
-rw-r--r--devel/popt/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/devel/popt/Makefile b/devel/popt/Makefile
index 5531c1c7fb30..31c0583cdeed 100644
--- a/devel/popt/Makefile
+++ b/devel/popt/Makefile
@@ -6,23 +6,28 @@
#
PORTNAME= popt
-PORTVERSION= 1.5.1
-PORTREVISION= 1
+PORTVERSION= 1.6.4
CATEGORIES= devel
-MASTER_SITES= ftp://ftp.rpm.org/pub/rpm/dist/rpm-3.0.x/ \
- ftp://ftp.mirror.ac.uk/sites/ftp.rpm.org/pub/rpm/dist/rpm-3.0.x/
+MASTER_SITES= ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/ \
+ ftp://ftp.mirror.ac.uk/sites/ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/
-MAINTAINER= ycheng@sinica.edu.tw
+MAINTAINER= lioux@FreeBSD.org
LIB_DEPENDS= intl.2:${PORTSDIR}/devel/gettext
-WRKSRC= ${WRKDIR}/${PORTNAME}-1.5
-
USE_LIBTOOL= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
MAN3= popt.3
+post-patch:
+# avoid installing both charset.alias and locale.alias which conflict
+# with libiconv
+ @${REINPLACE_CMD} -E -e 's|(SUBDIRS[[:space:]]+=.*)intl|\1|' \
+ ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>