aboutsummaryrefslogtreecommitdiff
path: root/devel/portlint
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-27 00:45:20 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-27 00:45:20 +0000
commite02168c9a67124862cf8febab2164a60a54b38f4 (patch)
tree07382a33ce7d243501c49ea088bfc047bb634f08 /devel/portlint
parentcad561d693be20272861725c7bef63628eecdfbd (diff)
downloadports-e02168c9a67124862cf8febab2164a60a54b38f4.tar.gz
ports-e02168c9a67124862cf8febab2164a60a54b38f4.zip
* Update to 2.5.4
* Correct a typo (-n should be -N) [1] * Don't check comments for direct command use [2] Submitted by: pav [1] Sascha Holzleiter <sascha@root-login.org> [2]
Notes
Notes: svn path=/head/; revision=96659
Diffstat (limited to 'devel/portlint')
-rw-r--r--devel/portlint/Makefile2
-rw-r--r--devel/portlint/src/portlint.pl10
2 files changed, 7 insertions, 5 deletions
diff --git a/devel/portlint/Makefile b/devel/portlint/Makefile
index 8d13998b66fa..581986661cc7 100644
--- a/devel/portlint/Makefile
+++ b/devel/portlint/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= portlint
-PORTVERSION= 2.5.3
+PORTVERSION= 2.5.4
CATEGORIES= devel
MASTER_SITES= # none
DISTFILES= # none
diff --git a/devel/portlint/src/portlint.pl b/devel/portlint/src/portlint.pl
index 5fe3cc1236ab..51668e15bc5c 100644
--- a/devel/portlint/src/portlint.pl
+++ b/devel/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $Id: portlint.pl,v 1.30 2003/11/22 20:37:23 marcus Exp $
+# $Id: portlint.pl,v 1.32 2003/12/27 00:43:00 marcus Exp $
#
use vars qw/ $opt_a $opt_A $opt_b $opt_c $opt_h $opt_t $opt_v $opt_M $opt_N $opt_B $opt_V /;
@@ -40,7 +40,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 5;
-my $micro = 3;
+my $micro = 4;
sub l { '[{(]'; }
sub r { '[)}]'; }
@@ -379,7 +379,7 @@ if ($committer) {
}
close ENTRIES;
} else {
- &perror("WARN: no CVS directories. Use -n to check a new port.");
+ &perror("WARN: no CVS directories. Use -N to check a new port.");
return;
}
@@ -1150,6 +1150,7 @@ ldconfig ln md5 mkdir mv patch perl rm rmdir ruby sed sh touch tr which xargs xm
&& $curline !~ /^NO_PACKAGE(.)?=[^\n]+$i/m
&& $curline !~ /^NO_CDROM(.)?=[^\n]+$i/m
&& $curline !~ /^CATEGORIES(.)?=[^\n]+$i/m
+ && $curline !~ /^#.+$/m
&& $curline !~ /^COMMENT(.)?=[^\n]+$i/m) {
&perror("WARN: $file [$lineno]: possible direct use of ".
"command \"$i\" found. use ".
@@ -1172,6 +1173,7 @@ ldconfig ln md5 mkdir mv patch perl rm rmdir ruby sed sh touch tr which xargs xm
&& $lm !~ /^NO_PACKAGE(.)?=[^\n]+($i\d*)/m
&& $lm !~ /^NO_CDROM(.)?=[^\n]+($i\d*)/m
&& $lm !~ /^CATEGORIES(.)?=[^\n]+($i\d*)/m
+ && $lm !~ /^#.+$/m
&& $lm !~ /^COMMENT(.)?=[^\n]+($i\d*)/m) {
&perror("WARN: $file [$lineno]: possible direct use of ".
"command \"$sm\" found. Use $autocmdnames{$i} ".
@@ -1535,7 +1537,7 @@ DISTFILES DIST_SUBDIR EXTRACT_ONLY
&perror("FATAL: $file: PORTVERSION must be specified");
}
if ($portversion =~ /^pl[0-9]*$/
- || $portversion =~ /^[0-9]*[A-Za-z]?[0-9]*(\.[0-9]*[A-Za-z]?[0-9]*)*$/) {
+ || $portversion =~ /^[0-9]*[A-Za-z]?[0-9]*(\.[0-9]*[A-Za-z]?[0-9+]*)*$/) {
print "OK: PORTVERSION \"$portversion\" looks fine.\n" if ($verbose);
} elsif ($portversion =~ /^[^\-]*\$[{\(].+[\)}][^\-]*$/) {
&perror("WARN: $file: using variable, \"$portversion\", as version ".