aboutsummaryrefslogtreecommitdiff
path: root/devel/poslib/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-06 17:58:51 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-06 17:58:51 +0000
commit140f18025de4fd270eb30afd13467f6a707e5117 (patch)
tree88f57847bac25bd7f0e525d33a4b33bbd24ba284 /devel/poslib/Makefile
parent746cb37fab510b6f96fe969bfe277da53bb87cbc (diff)
downloadports-140f18025de4fd270eb30afd13467f6a707e5117.tar.gz
ports-140f18025de4fd270eb30afd13467f6a707e5117.zip
- Update to 1.0.1
- Disable any optimizations as it causes problems under FreeBSD, according to the author - Install examples PR: 57649 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=90462
Diffstat (limited to 'devel/poslib/Makefile')
-rw-r--r--devel/poslib/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/devel/poslib/Makefile b/devel/poslib/Makefile
index a140491a83fa..52bf415f7aef 100644
--- a/devel/poslib/Makefile
+++ b/devel/poslib/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= poslib
-PORTVERSION= 1.0
+PORTVERSION= 1.0.1
CATEGORIES= devel dns
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= posadis
@@ -15,14 +15,21 @@ MAINTAINER= sergei@kolobov.com
COMMENT= Posadis C++ DNS library
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-cxxflags="${CXXFLAGS} -D_REENTRANT"
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
+CONFIGURE_ARGS= --with-cxxflags="${CXXFLAGS:C/-O.*/-O0 /} ${PTHREAD_CFLAGS}"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
+PLIST_SUB= VERSION="${PORTVERSION}"
+
DOCS= AUTHORS ChangeLog NEWS README TODO
+EXAMPLES= examples/*.cpp
-.if !defined(NOPORTDOCS)
post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif