aboutsummaryrefslogtreecommitdiff
path: root/devel/poslib
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-30 00:56:20 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-30 00:56:20 +0000
commit3618543557de774d94cff2569660ee6bd1094133 (patch)
treec68414bb4a18c1a05e7cd725c723fa141f943722 /devel/poslib
parent1ce967df6236c1c289d1ed6ff8ebf7a9e67aa398 (diff)
downloadports-3618543557de774d94cff2569660ee6bd1094133.tar.gz
ports-3618543557de774d94cff2569660ee6bd1094133.zip
[NEW PORT] devel/poslib: Posadis C++ DNS library
Poslib is a portable C++ DNS library, a part of Posadis project. It consists of two parts: a client library and a server library. Using the client library, you can simply develop applications that use the Domain Name System (DNS). It includes many functions for resolving, domain-name manipulation and Resource Record (RR) creation. The server library, based on the client core, can be used to develop DNS servers. By implementing a query entry-point function using the Poslib library of functions, you can easily create DNS servers, without worrying about low-level details such as DNS message compilation, domain-name compression and UDP/TCP transmission. Author: Meilof Veeningen <meilof@users.sourceforge.net> WWW: http://posadis.sourceforge.net/projects/poslib.php PR: ports/55195 Submitted by: Sergei Kolobov <sergei@kolobov.com>
Notes
Notes: svn path=/head/; revision=88025
Diffstat (limited to 'devel/poslib')
-rw-r--r--devel/poslib/Makefile30
-rw-r--r--devel/poslib/distinfo1
-rw-r--r--devel/poslib/pkg-descr15
-rw-r--r--devel/poslib/pkg-plist50
4 files changed, 96 insertions, 0 deletions
diff --git a/devel/poslib/Makefile b/devel/poslib/Makefile
new file mode 100644
index 000000000000..a140491a83fa
--- /dev/null
+++ b/devel/poslib/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: poslib
+# Date created: 2003-08-03
+# Whom: Sergei Kolobov <sergei@kolobov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= poslib
+PORTVERSION= 1.0
+CATEGORIES= devel dns
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= posadis
+
+MAINTAINER= sergei@kolobov.com
+COMMENT= Posadis C++ DNS library
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-cxxflags="${CXXFLAGS} -D_REENTRANT"
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+
+DOCS= AUTHORS ChangeLog NEWS README TODO
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/poslib/distinfo b/devel/poslib/distinfo
new file mode 100644
index 000000000000..f55341ca9081
--- /dev/null
+++ b/devel/poslib/distinfo
@@ -0,0 +1 @@
+MD5 (poslib-1.0.tar.gz) = c87a9fa5eeca7465ede03d3196cb4277
diff --git a/devel/poslib/pkg-descr b/devel/poslib/pkg-descr
new file mode 100644
index 000000000000..0da0cca0064d
--- /dev/null
+++ b/devel/poslib/pkg-descr
@@ -0,0 +1,15 @@
+Poslib is a portable C++ DNS library, a part of Posadis project.
+It consists of two parts: a client library and a server library.
+
+Using the client library, you can simply develop applications that use
+the Domain Name System (DNS). It includes many functions for resolving,
+domain-name manipulation and Resource Record (RR) creation.
+
+The server library, based on the client core, can be used to develop
+DNS servers. By implementing a query entry-point function using the
+Poslib library of functions, you can easily create DNS servers,
+without worrying about low-level details such as DNS message compilation,
+domain-name compression and UDP/TCP transmission.
+
+Author: Meilof Veeningen <meilof@users.sourceforge.net>
+WWW: http://posadis.sourceforge.net/projects/poslib.php
diff --git a/devel/poslib/pkg-plist b/devel/poslib/pkg-plist
new file mode 100644
index 000000000000..82e54ddc5649
--- /dev/null
+++ b/devel/poslib/pkg-plist
@@ -0,0 +1,50 @@
+@comment $FreeBSD$
+bin/poslib-config
+include/poslib-1.0/poslib/bits.h
+include/poslib-1.0/poslib/dnsdefs.h
+include/poslib-1.0/poslib/dnsmessage.h
+include/poslib-1.0/poslib/domainfn.h
+include/poslib-1.0/poslib/exception.h
+include/poslib-1.0/poslib/lexfn.h
+include/poslib-1.0/poslib/masterfile.h
+include/poslib-1.0/poslib/poslib.h
+include/poslib-1.0/poslib/postime.h
+include/poslib-1.0/poslib/random.h
+include/poslib-1.0/poslib/resolver.h
+include/poslib-1.0/poslib/rr.h
+include/poslib-1.0/poslib/server/configuration.h
+include/poslib-1.0/poslib/server/handlequery.h
+include/poslib-1.0/poslib/server/log.h
+include/poslib-1.0/poslib/server/pending.h
+include/poslib-1.0/poslib/server/posthreads.h
+include/poslib-1.0/poslib/server/requestid.h
+include/poslib-1.0/poslib/server/server.h
+include/poslib-1.0/poslib/server/serverthread.h
+include/poslib-1.0/poslib/server/srvresolver.h
+@dirrm include/poslib-1.0/poslib/server
+include/poslib-1.0/poslib/socket.h
+include/poslib-1.0/poslib/syssocket.h
+include/poslib-1.0/poslib/sysstl.h
+include/poslib-1.0/poslib/sysstring.h
+include/poslib-1.0/poslib/types.h
+include/poslib-1.0/poslib/vsnprintf.h
+include/poslib-1.0/poslib/w32poll.h
+@dirrm include/poslib-1.0/poslib
+@dirrm include/poslib-1.0
+lib/libposlib.a
+lib/libposlib.la
+lib/libposlib.so
+lib/libposlib.so.0
+lib/libposserver.a
+lib/libposserver.la
+lib/libposserver.so
+lib/libposserver.so.0
+lib/poslib-1.0/include/poslib-config.h
+@dirrm lib/poslib-1.0/include
+@dirrm lib/poslib-1.0
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%