aboutsummaryrefslogtreecommitdiff
path: root/devel/ppl/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-05-31 18:35:58 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-05-31 18:35:58 +0000
commit85cd7dc2b5ba779165a06657ad5cb244ef090911 (patch)
tree912690b607e3467d7401b11256bb7f3815a478e8 /devel/ppl/Makefile
parentd82d584b934c2f9ef0c4522ca497eccfb4cc17af (diff)
downloadports-85cd7dc2b5ba779165a06657ad5cb244ef090911.tar.gz
ports-85cd7dc2b5ba779165a06657ad5cb244ef090911.zip
- Update to 0.10.2
- Pass maintainership to submitter - Mark MAKE_JOBS_SAFE PR: 134921 Submitetd by: Tobias Grosser <grosser@fim.uni-passau.de>
Notes
Notes: svn path=/head/; revision=234933
Diffstat (limited to 'devel/ppl/Makefile')
-rw-r--r--devel/ppl/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/devel/ppl/Makefile b/devel/ppl/Makefile
index 45cdeb4b40bd..6c5246e81996 100644
--- a/devel/ppl/Makefile
+++ b/devel/ppl/Makefile
@@ -7,16 +7,16 @@
#
PORTNAME= ppl
-PORTVERSION= 0.9
-PORTREVISION= 2
+PORTVERSION= 0.10.2
CATEGORIES= devel
MASTER_SITES= ftp://ftp.cs.unipr.it/pub/ppl/releases/%SUBDIR%/ \
http://www.cs.unipr.it/ppl/Download/ftp/releases/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= grosser@fim.uni-passau.de
COMMENT= The Parma Polyhedra Library
+BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
USE_GMAKE= yes
@@ -24,20 +24,28 @@ USE_GNOME= gnometarget
USE_PERL5_BUILD=yes
USE_AUTOTOOLS= libtool:15
LIBTOOLFILES= configure Watchdog/configure
+
+# Only enable C and C++ interfaces. Checks for java, prolog and ocaml
+# have to be added.
+INTERFACES= c,cxx
+
CONFIGURE_ARGS= --disable-debugging \
--enable-optimization \
--with-cflags="${CFLAGS}" \
--with-cxxflags="${CXXFLAGS}" \
--with-libgmp-prefix="${LOCALBASE}" \
- --with-libgmpxx-prefix="${LOCALBASE}"
+ --with-libgmpxx-prefix="${LOCALBASE}" \
+ --enable-interfaces="${INTERFACES}"
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
-MAN1= ppl-config.1 ppl_lcdd.1 ppl_lpsol.1
+MAN1= ppl-config.1 ppl_lcdd.1
+MAN3= libppl.3 libppl_c.3
.if defined(NOPORTDOCS)
post-patch:
${REINPLACE_CMD} -e '/^install-data-am:/ s|install-data-local||g' \
- ${WRKSRC}/doc/Makefile.in
+ ${WRKSRC}/doc/Makefile.in ${WRKSRC}/Watchdog/doc/Makefile.in
.endif
.include <bsd.port.mk>