aboutsummaryrefslogtreecommitdiff
path: root/devel/pth
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2006-06-19 09:06:13 +0000
committerVasil Dimov <vd@FreeBSD.org>2006-06-19 09:06:13 +0000
commit2e279978a3c86c552b0285db5eeff0f66c380a77 (patch)
tree8b74274a3188dd58cbb9e7502683a25ce63978aa /devel/pth
parent9d5bcd343f6263cf3c3c51ef86bc9c8928dbcc62 (diff)
downloadports-2e279978a3c86c552b0285db5eeff0f66c380a77.tar.gz
ports-2e279978a3c86c552b0285db5eeff0f66c380a77.zip
Switch to USE_LDCONFIG
Notes
Notes: svn path=/head/; revision=165756
Diffstat (limited to 'devel/pth')
-rw-r--r--devel/pth/Makefile6
-rw-r--r--devel/pth/files/pth.sh20
-rw-r--r--devel/pth/pkg-plist1
3 files changed, 1 insertions, 26 deletions
diff --git a/devel/pth/Makefile b/devel/pth/Makefile
index 90208a56b21a..a6acf944c168 100644
--- a/devel/pth/Makefile
+++ b/devel/pth/Makefile
@@ -14,8 +14,7 @@ MASTER_SITE_SUBDIR= pth
MAINTAINER= vd@FreeBSD.org
COMMENT= GNU Portable Threads
-INSTALLS_SHLIB= yes
-LDCONFIG_DIRS= %%PREFIX%%/lib/pth
+USE_LDCONFIG= ${PREFIX}/lib/pth
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-optimize \
@@ -51,9 +50,6 @@ post-patch:
post-build:
@${ECHO_MSG} "===> Use 'make test' to run a quick test suite."
-post-install:
- ${INSTALL_SCRIPT} ${FILESDIR}/pth.sh ${PREFIX}/etc/rc.d/000.pth.sh
-
test: build
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test
diff --git a/devel/pth/files/pth.sh b/devel/pth/files/pth.sh
deleted file mode 100644
index f3004c3281e8..000000000000
--- a/devel/pth/files/pth.sh
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh
-
-if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
- echo "$0: Cannot determine the PREFIX" >&2
- exit 1
-fi
-
-case "$1" in
- start)
- /sbin/ldconfig -m ${PREFIX}/lib/pth
- ;;
- stop)
- ;;
- *)
- echo ""
- echo "Usage: `basename $0` { start | stop }"
- echo ""
- exit 64
- ;;
-esac
diff --git a/devel/pth/pkg-plist b/devel/pth/pkg-plist
index decf32103019..7dd2bdc07302 100644
--- a/devel/pth/pkg-plist
+++ b/devel/pth/pkg-plist
@@ -1,6 +1,5 @@
bin/pth-config
%%PTHREAD%%bin/pthread-config
-etc/rc.d/000.pth.sh
include/pth/pth.h
%%PTHREAD%%include/pth/pthread.h
lib/pth/libpth.a