aboutsummaryrefslogtreecommitdiff
path: root/devel/pushmi
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-01-11 02:09:58 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-01-11 02:09:58 +0000
commit74b1311aec892dd156d2f41f65d77afcfeda1b92 (patch)
tree616b8065ea22981d2b1a50051a191951535b4a31 /devel/pushmi
parentfc89022389deac1e6511bcb856a76a1d60f53fab (diff)
downloadports-74b1311aec892dd156d2f41f65d77afcfeda1b92.tar.gz
ports-74b1311aec892dd156d2f41f65d77afcfeda1b92.zip
Add pushmi, a subversion repository replication tool.
Notes
Notes: svn path=/head/; revision=182052
Diffstat (limited to 'devel/pushmi')
-rw-r--r--devel/pushmi/Makefile36
-rw-r--r--devel/pushmi/distinfo3
-rw-r--r--devel/pushmi/pkg-descr6
-rw-r--r--devel/pushmi/pkg-plist21
4 files changed, 66 insertions, 0 deletions
diff --git a/devel/pushmi/Makefile b/devel/pushmi/Makefile
new file mode 100644
index 000000000000..f9aa0105c0c3
--- /dev/null
+++ b/devel/pushmi/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: pushmi
+# Date created: Dec 29 2006
+# Whom: Rong-En Fan <rafan@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pushmi
+PORTVERSION= 0.991.0
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/C/CL/CLKAO
+DISTNAME= Pushmi-v${PORTVERSION}
+
+MAINTAINER= rafan@FreeBSD.org
+COMMENT= Subversion repository replication tool
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/SVN/Core.pm:${PORTSDIR}/devel/subversion-perl \
+ p5-App-CLI>=0.06:${PORTSDIR}/devel/p5-App-CLI \
+ p5-Cache-Memcached>=0:${PORTSDIR}/databases/p5-Cache-Memcached \
+ p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl \
+ p5-YAML-Syck>=0:${PORTSDIR}/textproc/p5-YAML-Syck \
+ p5-version>=0:${PORTSDIR}/devel/p5-version \
+ svk>=2.0.0:${PORTSDIR}/devel/svk
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ p5-IPC-Run3>=0:${PORTSDIR}/devel/p5-IPC-Run3 \
+ p5-RunApp>=0.13:${PORTSDIR}/devel/p5-RunApp \
+ p5-Test-Output>=0:${PORTSDIR}/devel/p5-Test-Output \
+ mod_perl2>=0:${PORTSDIR}/www/mod_perl2
+
+PERL_CONFIGURE= yes
+
+MAN3= Pushmi.3 \
+ Pushmi::Command::Mirror.3
+
+.include <bsd.port.mk>
diff --git a/devel/pushmi/distinfo b/devel/pushmi/distinfo
new file mode 100644
index 000000000000..a627da911b76
--- /dev/null
+++ b/devel/pushmi/distinfo
@@ -0,0 +1,3 @@
+MD5 (Pushmi-v0.991.0.tar.gz) = abeffc100ced43e6d4087e238b4af9fe
+SHA256 (Pushmi-v0.991.0.tar.gz) = 18e2235958bfb024269b8a7f2e91dd588d91030757f312edb35846c1b1ecbe2b
+SIZE (Pushmi-v0.991.0.tar.gz) = 39543
diff --git a/devel/pushmi/pkg-descr b/devel/pushmi/pkg-descr
new file mode 100644
index 000000000000..c1112a189b88
--- /dev/null
+++ b/devel/pushmi/pkg-descr
@@ -0,0 +1,6 @@
+Pushmi provides a mechanism for bidirectionally synchronizing Subversion
+repositories. The main difference between Pushmi and other replication
+tools is that Pushmi makes the "slave" repositories writable by normal
+Subversion clients.
+
+WWW: http://search.cpan.org/dist/Pushmi/
diff --git a/devel/pushmi/pkg-plist b/devel/pushmi/pkg-plist
new file mode 100644
index 000000000000..976ac1f53e8d
--- /dev/null
+++ b/devel/pushmi/pkg-plist
@@ -0,0 +1,21 @@
+bin/pushmi
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pushmi/.packlist
+%%SITE_PERL%%/Pushmi.pm
+%%SITE_PERL%%/Pushmi/Command.pm
+%%SITE_PERL%%/Pushmi/Config.pm
+%%SITE_PERL%%/Pushmi/Mirror.pm
+%%SITE_PERL%%/Pushmi/Test.pm
+%%SITE_PERL%%/Pushmi/Apache/AuthCache.pm
+%%SITE_PERL%%/Pushmi/Apache/AuthCommit.pm
+%%SITE_PERL%%/Pushmi/Command/Help.pm
+%%SITE_PERL%%/Pushmi/Command/Mirror.pm
+%%SITE_PERL%%/Pushmi/Command/Runhook.pm
+%%SITE_PERL%%/Pushmi/Command/Sync.pm
+%%SITE_PERL%%/Pushmi/Command/Tryauth.pm
+%%SITE_PERL%%/Pushmi/Command/Unlock.pm
+%%SITE_PERL%%/Pushmi/Editor/Locker.pm
+@dirrm %%SITE_PERL%%/Pushmi/Editor
+@dirrm %%SITE_PERL%%/Pushmi/Command
+@dirrm %%SITE_PERL%%/Pushmi/Apache
+@dirrm %%SITE_PERL%%/Pushmi
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Pushmi