aboutsummaryrefslogtreecommitdiff
path: root/devel/pwlib/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-05-04 05:31:16 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-05-04 05:31:16 +0000
commit1f5aba4ca00416e755d1f6df94c3b4d9520413e9 (patch)
tree499dfb139961cf4965255fda09bb2ffb5a8728d5 /devel/pwlib/Makefile
parenta37eb53c6e0359f42d9f847e6a1ec05280858732 (diff)
downloadports-1f5aba4ca00416e755d1f6df94c3b4d9520413e9.tar.gz
ports-1f5aba4ca00416e755d1f6df94c3b4d9520413e9.zip
- Disable ODBC by default. When ODBC is installed, it breaks build and seems
nothing actually use it. - While I'm here, use TAB after variable assignment. PR: ports/123378 Submitted by: Steve Ames <steve at energistic.com> (maintainer)
Notes
Notes: svn path=/head/; revision=212576
Diffstat (limited to 'devel/pwlib/Makefile')
-rw-r--r--devel/pwlib/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/devel/pwlib/Makefile b/devel/pwlib/Makefile
index 2601a1782b0f..aebb23a900da 100644
--- a/devel/pwlib/Makefile
+++ b/devel/pwlib/Makefile
@@ -7,10 +7,10 @@
PORTNAME= pwlib
PORTVERSION= 1.12.0
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
DISTNAME= openh323/ptlib-v${PORTVERSION:S/./_/g}-src.
EXTRACT_SUFX= tar.gz
@@ -46,6 +46,7 @@ CONFIGURE_ENV+= ATOMICITY_H="<ext/atomicity.h>"
.else
CONFIGURE_ENV+= ATOMICITY_H="<bits/atomicity.h>"
.endif
+
# if explicitely asked for, depend upon it
.if defined(WITH_SDL)
USE_SDL+= sdl
@@ -85,6 +86,11 @@ CONFIGURE_ENV+= OPENLDAPLIBDIR="${LOCALBASE}/lib"
MAKE_ENV+= OPENLDAPLIBDIR="${LOCALBASE}/lib"
.endif
+#disable OBDC support... it doesn't compile and nothing _seems_ to
+#actually use it. If you do have something that requires this please
+#send patches!
+CONFIGURE_ARGS+= --disable-odbc
+
#enable esound support
.if defined(WITH_ESOUND) && ${HAVE_GNOME:Mesound}!=""
USE_GNOME+= esound