aboutsummaryrefslogtreecommitdiff
path: root/devel/pwlib
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-09-21 09:40:53 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-09-21 09:40:53 +0000
commite3e93cf1c21ae95c2e5b1329b01508fd0ec97bb7 (patch)
treeaa5fb7dc1f5daae01138a23d80914f46d3dfb59a /devel/pwlib
parent7ecbc68934a47d699b7c453e3a5ee8e51d9e1f7c (diff)
downloadports-e3e93cf1c21ae95c2e5b1329b01508fd0ec97bb7.tar.gz
ports-e3e93cf1c21ae95c2e5b1329b01508fd0ec97bb7.zip
- Fix the port to work with the updated SDL version (1.2.11)
PR: ports/103448 Submitted by: Diane Bruce <db@db.net> Approved by: krion (portmgr), sem (mentor)
Notes
Notes: svn path=/head/; revision=173517
Diffstat (limited to 'devel/pwlib')
-rw-r--r--devel/pwlib/files/patch-configureac11
-rw-r--r--devel/pwlib/files/patch-include_ptclib_vsdl.h14
-rw-r--r--devel/pwlib/files/patch-src_ptclib_vsdl.cxx14
3 files changed, 35 insertions, 4 deletions
diff --git a/devel/pwlib/files/patch-configureac b/devel/pwlib/files/patch-configureac
index 72d7c495d27b..b1d797ed3621 100644
--- a/devel/pwlib/files/patch-configureac
+++ b/devel/pwlib/files/patch-configureac
@@ -1,5 +1,5 @@
---- configure.ac.orig Wed Feb 22 12:53:28 2006
-+++ configure.ac Sun May 7 14:19:18 2006
+--- configure.ac.orig Wed Feb 22 06:53:28 2006
++++ configure.ac Thu Sep 21 01:33:15 2006
@@ -136,7 +136,7 @@
x86 | i686 | i586 | i486 | i386 ) MACHTYPE=x86
;;
@@ -116,7 +116,7 @@
else
dnl SDL checks
if test "${SDLLIB:-unset}" = "unset" ; then
-@@ -1501,9 +1502,9 @@
+@@ -1501,11 +1502,11 @@
AC_CHECK_LIB(SDL, SDL_CreateYUVOverlay, HAS_SDL=1, HAS_SDL=, -L${X11LIBDIR} -lpthread -lX11 -lXext)
fi
@@ -126,8 +126,11 @@
- AC_CHECK_FILE(/usr/local/include/SDL11/SDL.h, HAS_SDL=1)
+ AC_CHECK_HEADER(SDL/SDL.h, HAS_SDL=1)
if test "${HAS_SDL:-unset}" != "unset" ; then
- SDLLIB=SDL-1.1
+- SDLLIB=SDL-1.1
++ SDLLIB=SDL
fi
+ fi
+
@@ -1527,7 +1528,7 @@
dnl ########################################################################
dnl check for video capture support.
diff --git a/devel/pwlib/files/patch-include_ptclib_vsdl.h b/devel/pwlib/files/patch-include_ptclib_vsdl.h
new file mode 100644
index 000000000000..30c7da32315e
--- /dev/null
+++ b/devel/pwlib/files/patch-include_ptclib_vsdl.h
@@ -0,0 +1,14 @@
+--- include/ptclib/vsdl.h.orig Thu Sep 21 00:49:29 2006
++++ include/ptclib/vsdl.h Thu Sep 21 00:49:53 2006
+@@ -98,11 +98,7 @@
+ #if P_SDL
+
+ #include <ptlib.h>
+-#if defined(P_FREEBSD)
+-#include <SDL11/SDL.h>
+-#else
+ #include <SDL/SDL.h>
+-#endif
+
+ #undef main
+
diff --git a/devel/pwlib/files/patch-src_ptclib_vsdl.cxx b/devel/pwlib/files/patch-src_ptclib_vsdl.cxx
new file mode 100644
index 000000000000..0ab00eec7ad0
--- /dev/null
+++ b/devel/pwlib/files/patch-src_ptclib_vsdl.cxx
@@ -0,0 +1,14 @@
+--- src/ptclib/vsdl.cxx.orig Thu Sep 21 00:50:56 2006
++++ src/ptclib/vsdl.cxx Thu Sep 21 00:51:11 2006
+@@ -102,11 +102,7 @@
+
+ extern "C" {
+
+-#if defined(P_FREEBSD)
+-#include <SDL11/SDL.h>
+-#else
+ #include <SDL/SDL.h>
+-#endif
+
+ };
+