aboutsummaryrefslogtreecommitdiff
path: root/devel/py-dbus
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-07-27 00:18:49 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-07-27 00:18:49 +0000
commit5a2d9fe864d7c6b36e883db375359a52141ed901 (patch)
tree9827372ac0a148ea3a37b46d54529207b7d0ea01 /devel/py-dbus
parentd5f5b95f33148df6d92b5e56e146d20a8664eacf (diff)
downloadports-5a2d9fe864d7c6b36e883db375359a52141ed901.tar.gz
ports-5a2d9fe864d7c6b36e883db375359a52141ed901.zip
Add py-dbus, Python bindings for the D-BUS messaging system.
Notes
Notes: svn path=/head/; revision=114827
Diffstat (limited to 'devel/py-dbus')
-rw-r--r--devel/py-dbus/Makefile41
-rw-r--r--devel/py-dbus/pkg-descr3
-rw-r--r--devel/py-dbus/pkg-plist4
3 files changed, 48 insertions, 0 deletions
diff --git a/devel/py-dbus/Makefile b/devel/py-dbus/Makefile
new file mode 100644
index 000000000000..a3bcd2f6142d
--- /dev/null
+++ b/devel/py-dbus/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: py-dbus
+# Date Created: 25 July 2004
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= devel gnome python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Python interface to the D-BUS messaging system
+
+LIB_DEPENDS= dbus-1.0:${PORTSDIR}/devel/dbus
+RUN_DEPENDS= pyrexc:${PORTSDIR}/devel/pyrex
+
+MASTERDIR= ${.CURDIR}/../dbus
+BUILD_WRKSRC= ${WRKSRC}/python
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+DBUS_SLAVE= yes
+
+USE_GNOME= gnomehack gnometarget
+USE_PYTHON= yes
+CONFIGURE_ARGS= --enable-python \
+ --disable-gcj \
+ --disable-mono \
+ --disable-gtk \
+ --with-system-pid-file=/var/run/dbus.pid \
+ --with-system-socket=/var/run/dbus \
+ --with-session-socket-dir=/var/tmp \
+ --disable-doxygen-docs \
+ --disable-xml-docs
+
+post-install:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/py-dbus/pkg-descr b/devel/py-dbus/pkg-descr
new file mode 100644
index 000000000000..059c9a3ed457
--- /dev/null
+++ b/devel/py-dbus/pkg-descr
@@ -0,0 +1,3 @@
+Python interface to the D-BUS messaging system.
+
+WWW: http://www.freedesktop.org/Software/dbus
diff --git a/devel/py-dbus/pkg-plist b/devel/py-dbus/pkg-plist
new file mode 100644
index 000000000000..0b654b1fe25c
--- /dev/null
+++ b/devel/py-dbus/pkg-plist
@@ -0,0 +1,4 @@
+lib/%%PYTHON_VERSION%%/site-packages/dbus.py
+lib/%%PYTHON_VERSION%%/site-packages/dbus.pyc
+lib/%%PYTHON_VERSION%%/site-packages/dbus.pyo
+lib/%%PYTHON_VERSION%%/site-packages/dbus_bindings.so