aboutsummaryrefslogtreecommitdiff
path: root/devel/py-ez_xml
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-27 15:47:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-27 15:47:48 +0000
commit9fdb2b8a4b9646cf19652282a1135fafd8b62a8a (patch)
tree1450bf7e3657e812b0ae2f0440c85c4de4942bec /devel/py-ez_xml
parent1d28d005400ee2c12932f2bc76b61961f4b201ef (diff)
downloadports-9fdb2b8a4b9646cf19652282a1135fafd8b62a8a.tar.gz
ports-9fdb2b8a4b9646cf19652282a1135fafd8b62a8a.zip
ez_xml is a XML template generator that compiles a XML template file into a
Python module. Programmers feed data to a template module to generate a respective XML document. ez_xml provides concise functions, no complex flow-control instructions. WWW: https://opensvn.csie.org/traccgi/PumperWeb/wiki/ez_xml PR: ports/110927 Submitted by: Thinker K.F. Li <thinker at branda.to>
Notes
Notes: svn path=/head/; revision=188562
Diffstat (limited to 'devel/py-ez_xml')
-rw-r--r--devel/py-ez_xml/Makefile22
-rw-r--r--devel/py-ez_xml/distinfo3
-rw-r--r--devel/py-ez_xml/pkg-descr6
-rw-r--r--devel/py-ez_xml/pkg-plist11
4 files changed, 42 insertions, 0 deletions
diff --git a/devel/py-ez_xml/Makefile b/devel/py-ez_xml/Makefile
new file mode 100644
index 000000000000..df3dc23c7329
--- /dev/null
+++ b/devel/py-ez_xml/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: py-ez_xml
+# Date created: 2007-03-27
+# Whom: Thinker K.F. Li <thinker@branda.to>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ez_xml
+PORTVERSION= 0.1.3
+CATEGORIES= devel textproc
+MASTER_SITES= http://master.branda.to/downloads/ez_xml/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= thinker@seeker.branda.to
+COMMENT= Ez_xml compiles a XML template file into a Python module
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pythk/__init__.py:${PORTSDIR}/devel/pythk
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-ez_xml/distinfo b/devel/py-ez_xml/distinfo
new file mode 100644
index 000000000000..4a8d2b3976f7
--- /dev/null
+++ b/devel/py-ez_xml/distinfo
@@ -0,0 +1,3 @@
+MD5 (ez_xml-0.1.3.tar.gz) = 12813684ac9047e237a2e8b6035079c1
+SHA256 (ez_xml-0.1.3.tar.gz) = a6592e08348877969adf43a1a3e29173580ecf56ad966250754dd9b3f90cd74a
+SIZE (ez_xml-0.1.3.tar.gz) = 4144
diff --git a/devel/py-ez_xml/pkg-descr b/devel/py-ez_xml/pkg-descr
new file mode 100644
index 000000000000..2fbe53c97715
--- /dev/null
+++ b/devel/py-ez_xml/pkg-descr
@@ -0,0 +1,6 @@
+ez_xml is a XML template generator that compiles a XML template file into a
+Python module. Programmers feed data to a template module to generate a
+respective XML document. ez_xml provides concise functions, no complex
+flow-control instructions.
+
+WWW: https://opensvn.csie.org/traccgi/PumperWeb/wiki/ez_xml
diff --git a/devel/py-ez_xml/pkg-plist b/devel/py-ez_xml/pkg-plist
new file mode 100644
index 000000000000..18772e833861
--- /dev/null
+++ b/devel/py-ez_xml/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+%%PYTHON_SITELIBDIR%%/ez_xml/__init__.py
+%%PYTHON_SITELIBDIR%%/ez_xml/compiler.py
+%%PYTHON_SITELIBDIR%%/ez_xml/tools.py
+%%PYTHON_SITELIBDIR%%/ez_xml/__init__.pyc
+%%PYTHON_SITELIBDIR%%/ez_xml/compiler.pyc
+%%PYTHON_SITELIBDIR%%/ez_xml/tools.pyc
+%%PYTHON_SITELIBDIR%%/ez_xml/__init__.pyo
+%%PYTHON_SITELIBDIR%%/ez_xml/compiler.pyo
+%%PYTHON_SITELIBDIR%%/ez_xml/tools.pyo
+@dirrmtry %%PYTHON_SITELIBDIR%%/ez_xml