aboutsummaryrefslogtreecommitdiff
path: root/devel/py-game
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-12-19 12:58:28 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-12-19 12:58:28 +0000
commitdf3f356e9b4f771d74491750bde0255738b3d2c3 (patch)
tree985f6378255ecada4a6e1a3a7b7fb3355e7f8ab4 /devel/py-game
parent60b2d682d2dfa252262512c71703af5b7b3c16c9 (diff)
downloadports-df3f356e9b4f771d74491750bde0255738b3d2c3.tar.gz
ports-df3f356e9b4f771d74491750bde0255738b3d2c3.zip
Update to 1.3.
Notes
Notes: svn path=/head/; revision=51835
Diffstat (limited to 'devel/py-game')
-rw-r--r--devel/py-game/Makefile2
-rw-r--r--devel/py-game/distinfo2
-rw-r--r--devel/py-game/files/patch-config_unix.py15
-rw-r--r--devel/py-game/pkg-plist8
4 files changed, 21 insertions, 6 deletions
diff --git a/devel/py-game/Makefile b/devel/py-game/Makefile
index 79b7199415b4..728795a1301e 100644
--- a/devel/py-game/Makefile
+++ b/devel/py-game/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= py-game
-PORTVERSION= 1.2
+PORTVERSION= 1.3
CATEGORIES= devel python
MASTER_SITES= http://pygame.seul.org/ftp/
DISTNAME= ${PORTNAME:S/-//}-${PORTVERSION}
diff --git a/devel/py-game/distinfo b/devel/py-game/distinfo
index ef10998674cd..3e7671760786 100644
--- a/devel/py-game/distinfo
+++ b/devel/py-game/distinfo
@@ -1 +1 @@
-MD5 (pygame-1.2.tar.gz) = 8b7aa16f9dbee0c8cdc064a28bd9b3d3
+MD5 (pygame-1.3.tar.gz) = c6da3e5a4c44a7b126d3ff5fd713e71f
diff --git a/devel/py-game/files/patch-config_unix.py b/devel/py-game/files/patch-config_unix.py
index dc31d853c444..79f55695b0a4 100644
--- a/devel/py-game/files/patch-config_unix.py
+++ b/devel/py-game/files/patch-config_unix.py
@@ -1,9 +1,9 @@
$FreeBSD$
---- config_unix.py 2001/09/03 13:07:39 1.1
-+++ config_unix.py 2001/09/03 13:10:16
-@@ -41,7 +41,7 @@
+--- config_unix.py.orig Sat Nov 3 19:27:56 2001
++++ config_unix.py Wed Dec 19 14:49:24 2001
+@@ -43,7 +43,7 @@
sdl_lib_name = 'SDL'
if sys.platform.find('bsd') != -1:
@@ -12,3 +12,12 @@ $FreeBSD$
DEPS = [
Dependency('SDL', 'SDL.h', 'lib'+sdl_lib_name+'.so', sdl_lib_name),
+@@ -74,7 +74,7 @@
+
+ print 'Hunting dependencies...'
+ if localbase:
+- incdirs = [localbase + '/include/SDL']
++ incdirs = [localbase + '/include/SDL11', localbase + '/include/smpeg']
+ libdirs = [localbase + '/lib']
+ else:
+ incdirs = []
diff --git a/devel/py-game/pkg-plist b/devel/py-game/pkg-plist
index 0995c584fee5..123f31308808 100644
--- a/devel/py-game/pkg-plist
+++ b/devel/py-game/pkg-plist
@@ -28,6 +28,8 @@ lib/%%PYTHON_VERSION%%/site-packages/pygame/mouse.so
lib/%%PYTHON_VERSION%%/site-packages/pygame/movie.so
lib/%%PYTHON_VERSION%%/site-packages/pygame/rect.so
lib/%%PYTHON_VERSION%%/site-packages/pygame/rwobject.so
+lib/%%PYTHON_VERSION%%/site-packages/pygame/sprite.py
+lib/%%PYTHON_VERSION%%/site-packages/pygame/sprite.pyc
lib/%%PYTHON_VERSION%%/site-packages/pygame/surface.so
lib/%%PYTHON_VERSION%%/site-packages/pygame/surfarray.so
lib/%%PYTHON_VERSION%%/site-packages/pygame/surflock.so
@@ -46,6 +48,7 @@ lib/%%PYTHON_VERSION%%/site-packages/pygame/version.pyc
%%PORTDOCS%%share/doc/py-game/pygame_tiny.gif
%%PORTDOCS%%share/doc/py-game/ref/CD.html
%%PORTDOCS%%share/doc/py-game/ref/Channel.html
+%%PORTDOCS%%share/doc/py-game/ref/Clock.html
%%PORTDOCS%%share/doc/py-game/ref/Font.html
%%PORTDOCS%%share/doc/py-game/ref/Joystick.html
%%PORTDOCS%%share/doc/py-game/ref/Movie.html
@@ -68,6 +71,7 @@ lib/%%PYTHON_VERSION%%/site-packages/pygame/version.pyc
%%PORTDOCS%%share/doc/py-game/ref/pygame_mixer_music.html
%%PORTDOCS%%share/doc/py-game/ref/pygame_mouse.html
%%PORTDOCS%%share/doc/py-game/ref/pygame_movie.html
+%%PORTDOCS%%share/doc/py-game/ref/pygame_sprite.html
%%PORTDOCS%%share/doc/py-game/ref/pygame_surfarray.html
%%PORTDOCS%%share/doc/py-game/ref/pygame_time.html
%%PORTDOCS%%share/doc/py-game/ref/pygame_transform.html
@@ -75,6 +79,8 @@ lib/%%PYTHON_VERSION%%/site-packages/pygame/version.pyc
%%PORTDOCS%%share/doc/py-game/tut/ChimpLineByLine.html
%%PORTDOCS%%share/doc/py-game/tut/DisplayModes.html
%%PORTDOCS%%share/doc/py-game/tut/Executable.html
+%%PORTDOCS%%share/doc/py-game/tut/MoveIt.html
+%%PORTDOCS%%share/doc/py-game/tut/SpriteIntro.html
%%PORTDOCS%%share/doc/py-game/tut/SurfarrayIntro.html
%%PORTDOCS%%share/doc/py-game/tut/allblack.jpg
%%PORTDOCS%%share/doc/py-game/tut/chimp.py.html
@@ -119,12 +125,12 @@ lib/%%PYTHON_VERSION%%/site-packages/pygame/version.pyc
%%PORTDOCS%%share/examples/py-game/fonty.py
%%PORTDOCS%%share/examples/py-game/glcube.py
%%PORTDOCS%%share/examples/py-game/liquid.py
+%%PORTDOCS%%share/examples/py-game/moveit.py
%%PORTDOCS%%share/examples/py-game/oldalien.py
%%PORTDOCS%%share/examples/py-game/sdllogos.zip
%%PORTDOCS%%share/examples/py-game/sound.py
%%PORTDOCS%%share/examples/py-game/stars.py
%%PORTDOCS%%share/examples/py-game/vgrade.py
-%%PORTDOCS%%share/examples/py-game/winaliens.pyw
%%PORTDOCS%%share/examples/py-game/zipshow.py
%%PORTDOCS%%@dirrm share/examples/py-game/data
%%PORTDOCS%%@dirrm share/examples/py-game