aboutsummaryrefslogtreecommitdiff
path: root/devel/py-lock_file
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-06 13:28:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-06 13:28:20 +0000
commitcad484f4ce93d1f0a502263d53556c4612ee8fd4 (patch)
treeefba744a3a46b36d373188acfb63611cdbf0b7c0 /devel/py-lock_file
parent092556eb85d08b7849847e2d6a95d2d00af2417e (diff)
downloadports-cad484f4ce93d1f0a502263d53556c4612ee8fd4.tar.gz
ports-cad484f4ce93d1f0a502263d53556c4612ee8fd4.zip
Lock files are used on Unix-like systems as a means of synchronization among
processes. Only one process can hold a lock file. Other processes that want to acquire it have to wait until it is released by the holder. In this module the lock file is implemented as an empty regular file, exclusively locked using fcntl.flock. The file is removed when it is to be released. WWW: http://martin.horcicka.eu/python/lock_file/ PR: ports/113392 Submitted by: Martin Horcicka <martin at horcicka.eu>
Notes
Notes: svn path=/head/; revision=192919
Diffstat (limited to 'devel/py-lock_file')
-rw-r--r--devel/py-lock_file/Makefile20
-rw-r--r--devel/py-lock_file/distinfo3
-rw-r--r--devel/py-lock_file/pkg-descr9
-rw-r--r--devel/py-lock_file/pkg-plist3
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/py-lock_file/Makefile b/devel/py-lock_file/Makefile
new file mode 100644
index 000000000000..21503e847380
--- /dev/null
+++ b/devel/py-lock_file/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: lock_file
+# Date created: 5 June 2007
+# Whom: Martin Horcicka <martin@horcicka.eu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lock_file
+PORTVERSION= 1.0
+CATEGORIES= devel python
+MASTER_SITES= http://martin.horcicka.eu/python/lock_file/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= martin@horcicka.eu
+COMMENT= Lock file manipulation
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-lock_file/distinfo b/devel/py-lock_file/distinfo
new file mode 100644
index 000000000000..48ac2231e247
--- /dev/null
+++ b/devel/py-lock_file/distinfo
@@ -0,0 +1,3 @@
+MD5 (lock_file-1.0.tar.gz) = e22d72e9adc7b690954b40118b58b7cf
+SHA256 (lock_file-1.0.tar.gz) = 1bf525dfce21ad10c4f121e4ec5ade36da90c3d97a7336ed91c7f65ebaa576f8
+SIZE (lock_file-1.0.tar.gz) = 2162
diff --git a/devel/py-lock_file/pkg-descr b/devel/py-lock_file/pkg-descr
new file mode 100644
index 000000000000..e132b5493e8c
--- /dev/null
+++ b/devel/py-lock_file/pkg-descr
@@ -0,0 +1,9 @@
+Lock files are used on Unix-like systems as a means of synchronization among
+processes. Only one process can hold a lock file. Other processes that want to
+acquire it have to wait until it is released by the holder.
+
+In this module the lock file is implemented as an empty regular file,
+exclusively locked using fcntl.flock. The file is removed when it is to be
+released.
+
+WWW: http://martin.horcicka.eu/python/lock_file/
diff --git a/devel/py-lock_file/pkg-plist b/devel/py-lock_file/pkg-plist
new file mode 100644
index 000000000000..d305b421a5fe
--- /dev/null
+++ b/devel/py-lock_file/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/lock_file.py
+%%PYTHON_SITELIBDIR%%/lock_file.pyc
+%%PYTHON_SITELIBDIR%%/lock_file.pyo