aboutsummaryrefslogtreecommitdiff
path: root/devel/py-orbit
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2006-05-28 12:06:14 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2006-05-28 12:06:14 +0000
commit1b81383f058bc3c34ad7f569ddf59199593089c3 (patch)
tree8f103dca621b7ddf63eacb66373ac8863e83f119 /devel/py-orbit
parentdd9476cf3feee004388c604735e2096db42a5a44 (diff)
downloadports-1b81383f058bc3c34ad7f569ddf59199593089c3.tar.gz
ports-1b81383f058bc3c34ad7f569ddf59199593089c3.zip
devel/py-orbit2 -> devel/py-orbit
Rename this ports to use the real vendor package name. The advantage of this is to allow our users' keyword search works and easier for users to file the Bugzilla report when they use our name of ports. Debian, Gentoo, NetBSD and other OSs have the correct package name, but not in our ports tree. My team, FreeBSD GNOME Team, have agreed with it. As for x11-toolkits/py-gnome2, chase the rename.
Notes
Notes: svn path=/head/; revision=163687
Diffstat (limited to 'devel/py-orbit')
-rw-r--r--devel/py-orbit/Makefile29
-rw-r--r--devel/py-orbit/distinfo3
-rw-r--r--devel/py-orbit/pkg-descr9
-rw-r--r--devel/py-orbit/pkg-plist11
4 files changed, 52 insertions, 0 deletions
diff --git a/devel/py-orbit/Makefile b/devel/py-orbit/Makefile
new file mode 100644
index 000000000000..33ed83a1de10
--- /dev/null
+++ b/devel/py-orbit/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: py-orbit2
+# Date created: 04 March 2003
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/devel/py-orbit2/Makefile,v 1.11 2006/04/13 07:52:34 bland Exp $
+
+PORTNAME= orbit
+PORTVERSION= 2.14.0
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/pyorbit/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pyorbit-${PORTVERSION}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Python bindings for ORBit2
+
+CONFLICTS= py*-omniorb-[0-9]*
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack orbit2
+USE_PYTHON= yes
+GNU_CONFIGURE= yes
+ORBIT_CONFIG= ${LOCALBASE}/bin/orbit2-config
+
+.include <bsd.port.mk>
diff --git a/devel/py-orbit/distinfo b/devel/py-orbit/distinfo
new file mode 100644
index 000000000000..7338e67c233d
--- /dev/null
+++ b/devel/py-orbit/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnome2/pyorbit-2.14.0.tar.bz2) = ff62b983d5d9be164bd5a207d692eab5
+SHA256 (gnome2/pyorbit-2.14.0.tar.bz2) = 4963d045f92b5975c0a7df28e7915d7efaf4c6d6f79642ecb1e8121410add32f
+SIZE (gnome2/pyorbit-2.14.0.tar.bz2) = 275825
diff --git a/devel/py-orbit/pkg-descr b/devel/py-orbit/pkg-descr
new file mode 100644
index 000000000000..4e8e1ed8f22c
--- /dev/null
+++ b/devel/py-orbit/pkg-descr
@@ -0,0 +1,9 @@
+To paraphase the README:
+
+This is a Python language binding for the ORBit2 CORBA implementation.
+It aims to take advantage of new features found in ORBit2 to make
+language bindings more efficient. This includes:
+ - Use of ORBit2 type libraries to generate stubs
+ - use of the ORBit_small_invoke_stub() call for operation
+ invocation, which allows for short circuited invocation on local
+ objects.
diff --git a/devel/py-orbit/pkg-plist b/devel/py-orbit/pkg-plist
new file mode 100644
index 000000000000..4ca215c28715
--- /dev/null
+++ b/devel/py-orbit/pkg-plist
@@ -0,0 +1,11 @@
+include/pyorbit-2/pyorbit.h
+%%PYTHON_SITELIBDIR%%/CORBA.py
+%%PYTHON_SITELIBDIR%%/CORBA.pyc
+%%PYTHON_SITELIBDIR%%/CORBA.pyo
+%%PYTHON_SITELIBDIR%%/ORBit.la
+%%PYTHON_SITELIBDIR%%/ORBit.so
+%%PYTHON_SITELIBDIR%%/PortableServer.py
+%%PYTHON_SITELIBDIR%%/PortableServer.pyc
+%%PYTHON_SITELIBDIR%%/PortableServer.pyo
+libdata/pkgconfig/pyorbit-2.pc
+@dirrm include/pyorbit-2