aboutsummaryrefslogtreecommitdiff
path: root/devel/py-tables
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-19 03:41:34 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-19 03:41:34 +0000
commit2f1c532aaa440b2fe6f4611a37aaf9d876519af4 (patch)
tree8948bf7620cb404735394b49c2da179847cd42ac /devel/py-tables
parent7fafa757de69325c7fbfe12833cd666b7e5448c3 (diff)
downloadports-2f1c532aaa440b2fe6f4611a37aaf9d876519af4.tar.gz
ports-2f1c532aaa440b2fe6f4611a37aaf9d876519af4.zip
add pytables 0.7.2
A hierarchical database for Python
Notes
Notes: svn path=/head/; revision=96177
Diffstat (limited to 'devel/py-tables')
-rw-r--r--devel/py-tables/Makefile35
-rw-r--r--devel/py-tables/distinfo1
-rw-r--r--devel/py-tables/pkg-descr5
-rw-r--r--devel/py-tables/pkg-plist43
4 files changed, 84 insertions, 0 deletions
diff --git a/devel/py-tables/Makefile b/devel/py-tables/Makefile
new file mode 100644
index 000000000000..5f6476196f73
--- /dev/null
+++ b/devel/py-tables/Makefile
@@ -0,0 +1,35 @@
+# ex:ts=8
+# Ports collection makefile for: PyTables
+# Date created: Dec 19, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= tables
+PORTVERSION= 0.7.2
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pytables
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pytables-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A hierarchical database for Python
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numarray/__init__.py:${PORTSDIR}/math/py-numarray
+LIB_DEPENDS= hdf5.0:${PORTSDIR}/graphics/hdf5 \
+ lzo.1:${PORTSDIR}/archivers/lzo \
+ ucl.0:${PORTSDIR}/archivers/ucl
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numarray/__init__.py:${PORTSDIR}/math/py-numarray
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.py ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/py-tables/distinfo b/devel/py-tables/distinfo
new file mode 100644
index 000000000000..54aa4bb622dd
--- /dev/null
+++ b/devel/py-tables/distinfo
@@ -0,0 +1 @@
+MD5 (pytables-0.7.2.tar.gz) = b6b14895bbdb01020e66d7f18fe0373f
diff --git a/devel/py-tables/pkg-descr b/devel/py-tables/pkg-descr
new file mode 100644
index 000000000000..0d208e3bb804
--- /dev/null
+++ b/devel/py-tables/pkg-descr
@@ -0,0 +1,5 @@
+The goal of PyTables is to enable the end user to manipulate easily scientific
+data tables and Numerical Python objects in a persistent, disk-based
+hierarchical structure.
+
+WWW: http://pytables.sourceforge.net/
diff --git a/devel/py-tables/pkg-plist b/devel/py-tables/pkg-plist
new file mode 100644
index 000000000000..ff8cec7dfabc
--- /dev/null
+++ b/devel/py-tables/pkg-plist
@@ -0,0 +1,43 @@
+%%PYTHON_SITELIBDIR%%/tables/Array.py
+%%PYTHON_SITELIBDIR%%/tables/Array.pyc
+%%PYTHON_SITELIBDIR%%/tables/Array.pyo
+%%PYTHON_SITELIBDIR%%/tables/AttributeSet.py
+%%PYTHON_SITELIBDIR%%/tables/AttributeSet.pyc
+%%PYTHON_SITELIBDIR%%/tables/AttributeSet.pyo
+%%PYTHON_SITELIBDIR%%/tables/File.py
+%%PYTHON_SITELIBDIR%%/tables/File.pyc
+%%PYTHON_SITELIBDIR%%/tables/File.pyo
+%%PYTHON_SITELIBDIR%%/tables/Group.py
+%%PYTHON_SITELIBDIR%%/tables/Group.pyc
+%%PYTHON_SITELIBDIR%%/tables/Group.pyo
+%%PYTHON_SITELIBDIR%%/tables/IsDescription.py
+%%PYTHON_SITELIBDIR%%/tables/IsDescription.pyc
+%%PYTHON_SITELIBDIR%%/tables/IsDescription.pyo
+%%PYTHON_SITELIBDIR%%/tables/Leaf.py
+%%PYTHON_SITELIBDIR%%/tables/Leaf.pyc
+%%PYTHON_SITELIBDIR%%/tables/Leaf.pyo
+%%PYTHON_SITELIBDIR%%/tables/Table.py
+%%PYTHON_SITELIBDIR%%/tables/Table.pyc
+%%PYTHON_SITELIBDIR%%/tables/Table.pyo
+%%PYTHON_SITELIBDIR%%/tables/__init__.py
+%%PYTHON_SITELIBDIR%%/tables/__init__.pyc
+%%PYTHON_SITELIBDIR%%/tables/__init__.pyo
+%%PYTHON_SITELIBDIR%%/tables/hdf5Extension.so
+%%PYTHON_SITELIBDIR%%/tables/utils.py
+%%PYTHON_SITELIBDIR%%/tables/utils.pyc
+%%PYTHON_SITELIBDIR%%/tables/utils.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/tables
+%%PORTDOCS%%%%EXAMPLESDIR%%/array1.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/array2.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/array3.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/array4.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/attributes1.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/dumpFile.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/gl-test.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/objecttree.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/table-tree.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/table1.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial1-1.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial1-2.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial2.py
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%