aboutsummaryrefslogtreecommitdiff
path: root/devel/py-turbocheetah/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2007-01-21 14:15:38 +0000
committerNicola Vitale <nivit@FreeBSD.org>2007-01-21 14:15:38 +0000
commit13f08785fd56711cf764606572e595a6160e0e92 (patch)
tree91b034496642c3476a9d18aea66877ebbfb4c10e /devel/py-turbocheetah/Makefile
parenta9905cdafd258cf886b75e96dce0581c987a21af (diff)
downloadports-13f08785fd56711cf764606572e595a6160e0e92.tar.gz
ports-13f08785fd56711cf764606572e595a6160e0e92.zip
TurboGears plugin to support use of Cheetah templates.
Author: Kevin Dangoor WWW: http://www.turbogears.org/docs/plugins/template.html Approved by: alexbl (mentor, implicit)
Notes
Notes: svn path=/head/; revision=182907
Diffstat (limited to 'devel/py-turbocheetah/Makefile')
-rw-r--r--devel/py-turbocheetah/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/devel/py-turbocheetah/Makefile b/devel/py-turbocheetah/Makefile
new file mode 100644
index 000000000000..b31d6ff620e4
--- /dev/null
+++ b/devel/py-turbocheetah/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: py-turbocheetah
+# Date created: 2006-12-01
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= TurboCheetah
+PORTVERSION= 0.9.5
+CATEGORIES= devel python
+MASTER_SITES= http://files.turbogears.org/eggs/ \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${TURBOCHEETAH_EGG}
+EXTRACT_SUFX=
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= TurboGears plugin to support use of Cheetah templates
+
+BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS+= cheetah:${PORTSDIR}/devel/py-cheetah
+
+USE_PYTHON= 2.4
+
+NO_BUILD= yes
+
+SUB_FILES+= pkg-deinstall pkg-install
+SUB_LIST+= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR} \
+ EGG="${PORTNAME}==${PORTVERSION}"
+
+EASY_INSTALL= ${LOCALBASE}/bin/easy_install
+EASY_INSTALL_ARGS= -b ${WRKSRC} -N -d ${PYTHON_SITELIBDIR} -s ${PREFIX}/bin
+
+DATADIR= ${PYTHON_SITELIBDIR}/${TURBOCHEETAH_EGG}
+
+TURBOCHEETAH_EGG= ${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+
+do-install:
+ ${EASY_INSTALL} ${EASY_INSTALL_ARGS} ${DISTDIR}/${DISTFILES}
+
+.include <bsd.port.mk>