aboutsummaryrefslogtreecommitdiff
path: root/devel/py-xdg/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2004-06-26 00:41:43 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2004-06-26 00:41:43 +0000
commitf4a4ca3ce61cfce87afca2fccb4b79ef459e2846 (patch)
treea7ce355e8d05cdd8d833ad3ffe3116903b29413d /devel/py-xdg/Makefile
parent9c7b32a018ed69de54a58779030464794deddaa6 (diff)
downloadports-f4a4ca3ce61cfce87afca2fccb4b79ef459e2846.tar.gz
ports-f4a4ca3ce61cfce87afca2fccb4b79ef459e2846.zip
A python library to access freedesktop.org standards.
Currently supported are: o Base Directory Specification o Menu Specification o Desktop Entry Specification o Icon Theme Specification WWW: http://freedesktop.org/Software/pyxdg PR: ports/68332 Submitted by: michael johnson <ahze@ahze.net>
Notes
Notes: svn path=/head/; revision=112283
Diffstat (limited to 'devel/py-xdg/Makefile')
-rw-r--r--devel/py-xdg/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/devel/py-xdg/Makefile b/devel/py-xdg/Makefile
new file mode 100644
index 000000000000..96ba8be149ea
--- /dev/null
+++ b/devel/py-xdg/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: py-xdg
+# Date created: 2004-06-25
+# Whom: michael johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xdg
+PORTVERSION= 0.5
+CATEGORIES= devel python
+MASTER_SITES= http://freedesktop.org/Software/pyxdg/releases/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ahze@ahze.net
+COMMENT= A python library to access freedesktop.org standards
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|g ; \
+ s|/usr/share|/usr/share:${X11BASE}/share|g' \
+ ${WRKSRC}/xdg/BaseDirectory.py
+ @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g ; \
+ s|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/xdg/IconTheme.py
+
+.include <bsd.port.mk>