aboutsummaryrefslogtreecommitdiff
path: root/devel/qmake4
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-07-27 10:31:45 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2007-07-27 10:31:45 +0000
commit902b1b5d70c6590244badb51f35d1aa6c6507e42 (patch)
tree0b5bfe8bf4502787e096c50663b599d32cdcb29e /devel/qmake4
parentb04208149b7903346a6b3868bb42a5a693e5bf33 (diff)
downloadports-902b1b5d70c6590244badb51f35d1aa6c6507e42.tar.gz
ports-902b1b5d70c6590244badb51f35d1aa6c6507e42.zip
The bug that makes gcc 3.4 choke on some amd64 inline assembler does not
only affect the Qt4 core ports but ports depending on them as well, so try a more sweeping approach for a workaround.
Notes
Notes: svn path=/head/; revision=196381
Diffstat (limited to 'devel/qmake4')
-rw-r--r--devel/qmake4/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/devel/qmake4/Makefile b/devel/qmake4/Makefile
index c85fcc4335de..41f8788784b8 100644
--- a/devel/qmake4/Makefile
+++ b/devel/qmake4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qmake
PORTVERSION= ${QT4_VERSION}
-PORTREVISION=0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_QT}
DISTNAME= qt-x11-opensource-src-${PORTVERSION}
@@ -80,4 +80,8 @@ USE_GCC= 3.4+
CXXFLAGS+= -mieee
.endif
+.if ${OSVERSION} < 700042 && ${ARCH} == "amd64"
+CXXFLAGS+= -fno-gcse
+.endif
+
.include <bsd.port.post.mk>