aboutsummaryrefslogtreecommitdiff
path: root/devel/qmake4
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-05 00:20:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-05 00:20:35 +0000
commit098a2242e41fb0edc656835ec414e6911de3f34b (patch)
tree4e9018120ad76fa5c35fd4e2dd3c32d2f42acc15 /devel/qmake4
parent7e45300e38fd5feba84c6d4da0c94b81fe10df9a (diff)
downloadports-098a2242e41fb0edc656835ec414e6911de3f34b.tar.gz
ports-098a2242e41fb0edc656835ec414e6911de3f34b.zip
- Update to 4.4.1
Reported by: ionbot
Notes
Notes: svn path=/head/; revision=218047
Diffstat (limited to 'devel/qmake4')
-rw-r--r--devel/qmake4/Makefile18
-rw-r--r--devel/qmake4/distinfo6
-rw-r--r--devel/qmake4/files/qconfig.cpp10
-rw-r--r--devel/qmake4/pkg-descr2
-rw-r--r--devel/qmake4/pkg-plist146
5 files changed, 125 insertions, 57 deletions
diff --git a/devel/qmake4/Makefile b/devel/qmake4/Makefile
index 63257fa0ed38..8b708e7baa4e 100644
--- a/devel/qmake4/Makefile
+++ b/devel/qmake4/Makefile
@@ -28,7 +28,8 @@ EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
'${DISTNAME}/config.tests/unix/padstring' \
'${DISTNAME}/mkspecs' \
'${DISTNAME}/include/*/*' \
- '${DISTNAME}/src/*/*.h' '${DISTNAME}/qmake' \
+ '${DISTNAME}/src/*/*.h' \
+ '${DISTNAME}/qmake' \
'${DISTNAME}/src/corelib/tools' \
'${DISTNAME}/src/corelib/io' \
'${DISTNAME}/src/corelib/global' \
@@ -39,16 +40,7 @@ EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
'${DISTNAME}/src/3rdparty/md5' \
'${DISTNAME}/src/3rdparty/sha1'
-.if !defined(NOPORTDOCS)
-EXTRACT_AFTER_ARGS+='${DISTNAME}/doc/html/qmake*'
-DOCSDIR=${PREFIX}/share/doc/qt4
-post-install:
- ${MKDIR} '${DOCSDIR}'
- ${CP} -Rp '${WRKSRC:H}/doc/html' '${DOCSDIR}'
-.endif
-
post-patch:
- @${RM} -fr ${WRKSRC}/examples ${WRKSRC}/tutorial
@${REINPLACE_CMD} -e 's|-O2|${CXXFLAGS}|' \
-e 's|gcc.*|${CC}|' \
-e 's|g++.*|${CXX}|' \
@@ -59,8 +51,7 @@ post-patch:
-e 's|-pthread|${PTHREAD_LIBS}|' \
-e 's|uic|uic-qt4|' \
-e 's|moc|moc-qt4|' \
- ${WRKSRC}/../mkspecs/freebsd-g++/qmake.conf \
- ${WRKSRC}/../mkspecs/freebsd-g++34/qmake.conf
+ ${WRKSRC}/../mkspecs/freebsd-g++/qmake.conf
@${REINPLACE_CMD} -e 's|@QMAKE_QTOBJS@||g' ${WRKSRC}/Makefile.unix
do-configure:
@@ -81,4 +72,7 @@ CXXFLAGS+= -mieee
CXXFLAGS+= -fno-gcse
.endif
+post-install:
+ ${LN} -sf ${PREFIX}/share/qt4/mkspecs/freebsd-g++ ${PREFIX}/share/qt4/mkspecs/default
+
.include <bsd.port.post.mk>
diff --git a/devel/qmake4/distinfo b/devel/qmake4/distinfo
index 9451a68b5c02..0c630f09baf6 100644
--- a/devel/qmake4/distinfo
+++ b/devel/qmake4/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/qt-x11-opensource-src-4.3.4.tar.gz) = 9499101ec54eb7b0de195b3c5e3ffa93
-SHA256 (KDE/qt-x11-opensource-src-4.3.4.tar.gz) = 8864dd80f3456be70a3be60364502a0ca3f46125b2f156860ad880ff55fcabd2
-SIZE (KDE/qt-x11-opensource-src-4.3.4.tar.gz) = 43988710
+MD5 (KDE/qt-x11-opensource-src-4.4.1.tar.gz) = b09decad252b5181f300135e3122481d
+SHA256 (KDE/qt-x11-opensource-src-4.4.1.tar.gz) = 5aca7b784fc4de3db292666490ade84cfd1810f189c089c5c2810a710993f386
+SIZE (KDE/qt-x11-opensource-src-4.4.1.tar.gz) = 108774120
diff --git a/devel/qmake4/files/qconfig.cpp b/devel/qmake4/files/qconfig.cpp
index f7bc2b7e9d45..d662b424fce0 100644
--- a/devel/qmake4/files/qconfig.cpp
+++ b/devel/qmake4/files/qconfig.cpp
@@ -5,15 +5,15 @@
* at configure time.
*/
#define QT_CONFIGURE_LICENSEE "Open Source";
-#define QT_CONFIGURE_LICENSED_PRODUCTS "OpenSourceDesktop";
+#define QT_CONFIGURE_LICENSED_PRODUCTS "OpenSource";
#define QT_CONFIGURE_PREFIX_PATH "/usr/local";
#define QT_CONFIGURE_DOCUMENTATION_PATH "/usr/local/share/doc/qt4";
-#define QT_CONFIGURE_HEADERS_PATH "/usr/local/include";
-#define QT_CONFIGURE_LIBRARIES_PATH "/usr/local/lib";
+#define QT_CONFIGURE_HEADERS_PATH "/usr/local/include/qt4";
+#define QT_CONFIGURE_LIBRARIES_PATH "/usr/local/lib/qt4";
#define QT_CONFIGURE_BINARIES_PATH "/usr/local/bin";
#define QT_CONFIGURE_PLUGINS_PATH "/usr/local/lib/qt4/plugins";
#define QT_CONFIGURE_DATA_PATH "/usr/local/share/qt4";
#define QT_CONFIGURE_TRANSLATIONS_PATH "/usr/local/share/qt4/translations";
#define QT_CONFIGURE_SETTINGS_PATH "/usr/local/etc/xdg";
-#define QT_CONFIGURE_EXAMPLES_PATH "/usr/local/share/qt4/examples";
-#define QT_CONFIGURE_DEMOS_PATH "/usr/local/share/qt4/demos/";
+#define QT_CONFIGURE_EXAMPLES_PATH "/usr/local/share/examples/qt4/examples";
+#define QT_CONFIGURE_DEMOS_PATH "/usr/local/share/examples/qt4/demos/";
diff --git a/devel/qmake4/pkg-descr b/devel/qmake4/pkg-descr
index 9c1e694a6b71..eccbc5d9c1e0 100644
--- a/devel/qmake4/pkg-descr
+++ b/devel/qmake4/pkg-descr
@@ -3,6 +3,6 @@ developers target all major operating systems with a single application
source code.
Qmake is a project and makefile creating utility, that is part of Qt.
-For ease of maintenance it is split out into a port of its own.
+For ease of maintainance it is split out into a port of its own.
WWW: http://www.trolltech.com/products/qt/index.html
diff --git a/devel/qmake4/pkg-plist b/devel/qmake4/pkg-plist
index b4c4db434efa..df6f5a72677f 100644
--- a/devel/qmake4/pkg-plist
+++ b/devel/qmake4/pkg-plist
@@ -1,18 +1,4 @@
bin/qmake-qt4
-%%PORTDOCS%%%%DOCSDIR%%/html/qmake-advanced-usage.html
-%%PORTDOCS%%%%DOCSDIR%%/html/qmake-common-projects.html
-%%PORTDOCS%%%%DOCSDIR%%/html/qmake-environment-reference.html
-%%PORTDOCS%%%%DOCSDIR%%/html/qmake-function-reference.html
-%%PORTDOCS%%%%DOCSDIR%%/html/qmake-manual.html
-%%PORTDOCS%%%%DOCSDIR%%/html/qmake-platform-notes.html
-%%PORTDOCS%%%%DOCSDIR%%/html/qmake-precompiledheaders.html
-%%PORTDOCS%%%%DOCSDIR%%/html/qmake-project-files.html
-%%PORTDOCS%%%%DOCSDIR%%/html/qmake-reference.html
-%%PORTDOCS%%%%DOCSDIR%%/html/qmake-running.html
-%%PORTDOCS%%%%DOCSDIR%%/html/qmake-tutorial.html
-%%PORTDOCS%%%%DOCSDIR%%/html/qmake-using.html
-%%PORTDOCS%%%%DOCSDIR%%/html/qmake-variable-reference.html
-%%PORTDOCS%%%%DOCSDIR%%/html/qmake.dcf
share/qt4/mkspecs/aix-g++-64/qmake.conf
share/qt4/mkspecs/aix-g++-64/qplatformdefs.h
share/qt4/mkspecs/aix-g++/qmake.conf
@@ -23,13 +9,20 @@ share/qt4/mkspecs/aix-xlc/qmake.conf
share/qt4/mkspecs/aix-xlc/qplatformdefs.h
share/qt4/mkspecs/common/g++.conf
share/qt4/mkspecs/common/linux.conf
-share/qt4/mkspecs/common/mac.conf
+share/qt4/mkspecs/common/llvm.conf
share/qt4/mkspecs/common/mac-g++.conf
+share/qt4/mkspecs/common/mac-llvm.conf
+share/qt4/mkspecs/common/mac.conf
share/qt4/mkspecs/common/unix.conf
+share/qt4/mkspecs/cygwin-g++/qmake.conf
+share/qt4/mkspecs/cygwin-g++/qplatformdefs.h
share/qt4/mkspecs/darwin-g++/qmake.conf
share/qt4/mkspecs/darwin-g++/qplatformdefs.h
+share/qt4/mkspecs/default
share/qt4/mkspecs/features/assistant.prf
share/qt4/mkspecs/features/build_pass.prf
+share/qt4/mkspecs/features/dbusadaptors.prf
+share/qt4/mkspecs/features/dbusinterfaces.prf
share/qt4/mkspecs/features/debug.prf
share/qt4/mkspecs/features/debug_and_release.prf
share/qt4/mkspecs/features/default_post.prf
@@ -37,24 +30,25 @@ share/qt4/mkspecs/features/default_pre.prf
share/qt4/mkspecs/features/designer.prf
share/qt4/mkspecs/features/dll.prf
share/qt4/mkspecs/features/exclusive_builds.prf
+share/qt4/mkspecs/features/help.prf
share/qt4/mkspecs/features/incredibuild_xge.prf
share/qt4/mkspecs/features/lex.prf
share/qt4/mkspecs/features/link_pkgconfig.prf
-share/qt4/mkspecs/features/qdbus.prf
-share/qt4/mkspecs/features/qt_functions.prf
-share/qt4/mkspecs/features/mac/dwarf2.prf
-share/qt4/mkspecs/features/mac/ppc.prf
-share/qt4/mkspecs/features/mac/ppc64.prf
-share/qt4/mkspecs/features/mac/x86.prf
-share/qt4/mkspecs/features/mac/x86_64.prf
share/qt4/mkspecs/features/mac/default_post.prf
share/qt4/mkspecs/features/mac/default_pre.prf
+share/qt4/mkspecs/features/mac/dwarf2.prf
share/qt4/mkspecs/features/mac/objective_c.prf
+share/qt4/mkspecs/features/mac/ppc.prf
+share/qt4/mkspecs/features/mac/ppc64.prf
share/qt4/mkspecs/features/mac/rez.prf
share/qt4/mkspecs/features/mac/sdk.prf
+share/qt4/mkspecs/features/mac/x86.prf
+share/qt4/mkspecs/features/mac/x86_64.prf
share/qt4/mkspecs/features/moc.prf
+share/qt4/mkspecs/features/qdbus.prf
share/qt4/mkspecs/features/qt.prf
share/qt4/mkspecs/features/qt_config.prf
+share/qt4/mkspecs/features/qt_functions.prf
share/qt4/mkspecs/features/qtestlib.prf
share/qt4/mkspecs/features/qtopia.prf
share/qt4/mkspecs/features/qtopiainc.prf
@@ -89,6 +83,7 @@ share/qt4/mkspecs/features/win32/embed_manifest_exe.prf
share/qt4/mkspecs/features/win32/exceptions.prf
share/qt4/mkspecs/features/win32/exceptions_off.prf
share/qt4/mkspecs/features/win32/opengl.prf
+share/qt4/mkspecs/features/win32/profiling.prf
share/qt4/mkspecs/features/win32/qaxcontainer.prf
share/qt4/mkspecs/features/win32/qaxserver.prf
share/qt4/mkspecs/features/win32/qt_dll.prf
@@ -142,14 +137,16 @@ share/qt4/mkspecs/linux-g++-64/qmake.conf
share/qt4/mkspecs/linux-g++-64/qplatformdefs.h
share/qt4/mkspecs/linux-g++/qmake.conf
share/qt4/mkspecs/linux-g++/qplatformdefs.h
-share/qt4/mkspecs/linux-icc/qmake.conf
-share/qt4/mkspecs/linux-icc/qplatformdefs.h
share/qt4/mkspecs/linux-icc-32/qmake.conf
share/qt4/mkspecs/linux-icc-32/qplatformdefs.h
share/qt4/mkspecs/linux-icc-64/qmake.conf
share/qt4/mkspecs/linux-icc-64/qplatformdefs.h
+share/qt4/mkspecs/linux-icc/qmake.conf
+share/qt4/mkspecs/linux-icc/qplatformdefs.h
share/qt4/mkspecs/linux-kcc/qmake.conf
share/qt4/mkspecs/linux-kcc/qplatformdefs.h
+share/qt4/mkspecs/linux-llvm/qmake.conf
+share/qt4/mkspecs/linux-llvm/qplatformdefs.h
share/qt4/mkspecs/linux-lsb-g++/qmake.conf
share/qt4/mkspecs/linux-lsb-g++/qplatformdefs.h
share/qt4/mkspecs/linux-pgcc/qmake.conf
@@ -162,6 +159,10 @@ share/qt4/mkspecs/macx-g++/qmake.conf
share/qt4/mkspecs/macx-g++/qplatformdefs.h
share/qt4/mkspecs/macx-icc/qmake.conf
share/qt4/mkspecs/macx-icc/qplatformdefs.h
+share/qt4/mkspecs/macx-llvm/Info.plist.app
+share/qt4/mkspecs/macx-llvm/Info.plist.lib
+share/qt4/mkspecs/macx-llvm/qmake.conf
+share/qt4/mkspecs/macx-llvm/qplatformdefs.h
share/qt4/mkspecs/macx-pbuilder/Info.plist.app
share/qt4/mkspecs/macx-pbuilder/qmake.conf
share/qt4/mkspecs/macx-pbuilder/qplatformdefs.h
@@ -179,12 +180,16 @@ share/qt4/mkspecs/qws/freebsd-generic-g++/qmake.conf
share/qt4/mkspecs/qws/freebsd-generic-g++/qplatformdefs.h
share/qt4/mkspecs/qws/linux-arm-g++/qmake.conf
share/qt4/mkspecs/qws/linux-arm-g++/qplatformdefs.h
+share/qt4/mkspecs/qws/linux-avr32-g++/qmake.conf
+share/qt4/mkspecs/qws/linux-avr32-g++/qplatformdefs.h
share/qt4/mkspecs/qws/linux-cellon-g++/qmake.conf
share/qt4/mkspecs/qws/linux-cellon-g++/qplatformdefs.h
-share/qt4/mkspecs/qws/linux-generic-g++/qmake.conf
-share/qt4/mkspecs/qws/linux-generic-g++/qplatformdefs.h
+share/qt4/mkspecs/qws/linux-dm7000-g++/qmake.conf
+share/qt4/mkspecs/qws/linux-dm7000-g++/qplatformdefs.h
share/qt4/mkspecs/qws/linux-generic-g++-32/qmake.conf
share/qt4/mkspecs/qws/linux-generic-g++-32/qplatformdefs.h
+share/qt4/mkspecs/qws/linux-generic-g++/qmake.conf
+share/qt4/mkspecs/qws/linux-generic-g++/qplatformdefs.h
share/qt4/mkspecs/qws/linux-ipaq-g++/qmake.conf
share/qt4/mkspecs/qws/linux-ipaq-g++/qplatformdefs.h
share/qt4/mkspecs/qws/linux-lsb-g++/qmake.conf
@@ -227,17 +232,83 @@ share/qt4/mkspecs/win32-borland/qmake.conf
share/qt4/mkspecs/win32-borland/qplatformdefs.h
share/qt4/mkspecs/win32-g++/qmake.conf
share/qt4/mkspecs/win32-g++/qplatformdefs.h
+share/qt4/mkspecs/win32-msvc.net/qmake.conf
+share/qt4/mkspecs/win32-msvc.net/qplatformdefs.h
share/qt4/mkspecs/win32-msvc/features/incremental.prf
share/qt4/mkspecs/win32-msvc/features/incremental_off.prf
share/qt4/mkspecs/win32-msvc/qmake.conf
share/qt4/mkspecs/win32-msvc/qplatformdefs.h
+share/qt4/mkspecs/win32-msvc2002/qmake.conf
+share/qt4/mkspecs/win32-msvc2002/qplatformdefs.h
+share/qt4/mkspecs/win32-msvc2003/qmake.conf
+share/qt4/mkspecs/win32-msvc2003/qplatformdefs.h
share/qt4/mkspecs/win32-msvc2005/qmake.conf
share/qt4/mkspecs/win32-msvc2005/qplatformdefs.h
-share/qt4/mkspecs/win32-msvc.net/qmake.conf
-share/qt4/mkspecs/win32-msvc.net/qplatformdefs.h
-@dirrm share/qt4/mkspecs/win32-msvc.net
+share/qt4/mkspecs/win32-msvc2008/qmake.conf
+share/qt4/mkspecs/win32-msvc2008/qplatformdefs.h
+share/qt4/mkspecs/wince50standard-armv4i-msvc2005/qmake.conf
+share/qt4/mkspecs/wince50standard-armv4i-msvc2005/qplatformdefs.h
+share/qt4/mkspecs/wince50standard-armv4i-msvc2008/qmake.conf
+share/qt4/mkspecs/wince50standard-armv4i-msvc2008/qplatformdefs.h
+share/qt4/mkspecs/wince50standard-mipsii-msvc2005/qmake.conf
+share/qt4/mkspecs/wince50standard-mipsii-msvc2005/qplatformdefs.h
+share/qt4/mkspecs/wince50standard-mipsii-msvc2008/qmake.conf
+share/qt4/mkspecs/wince50standard-mipsii-msvc2008/qplatformdefs.h
+share/qt4/mkspecs/wince50standard-mipsiv-msvc2005/qmake.conf
+share/qt4/mkspecs/wince50standard-mipsiv-msvc2005/qplatformdefs.h
+share/qt4/mkspecs/wince50standard-mipsiv-msvc2008/qmake.conf
+share/qt4/mkspecs/wince50standard-mipsiv-msvc2008/qplatformdefs.h
+share/qt4/mkspecs/wince50standard-sh4-msvc2005/qmake.conf
+share/qt4/mkspecs/wince50standard-sh4-msvc2005/qplatformdefs.h
+share/qt4/mkspecs/wince50standard-sh4-msvc2008/qmake.conf
+share/qt4/mkspecs/wince50standard-sh4-msvc2008/qplatformdefs.h
+share/qt4/mkspecs/wince50standard-x86-msvc2005/qmake.conf
+share/qt4/mkspecs/wince50standard-x86-msvc2005/qplatformdefs.h
+share/qt4/mkspecs/wince50standard-x86-msvc2008/qmake.conf
+share/qt4/mkspecs/wince50standard-x86-msvc2008/qplatformdefs.h
+share/qt4/mkspecs/wince60standard-armv4i-msvc2005/qmake.conf
+share/qt4/mkspecs/wince60standard-armv4i-msvc2005/qplatformdefs.h
+share/qt4/mkspecs/wincewm50pocket-msvc2005/qmake.conf
+share/qt4/mkspecs/wincewm50pocket-msvc2005/qplatformdefs.h
+share/qt4/mkspecs/wincewm50pocket-msvc2008/qmake.conf
+share/qt4/mkspecs/wincewm50pocket-msvc2008/qplatformdefs.h
+share/qt4/mkspecs/wincewm50smart-msvc2005/qmake.conf
+share/qt4/mkspecs/wincewm50smart-msvc2005/qplatformdefs.h
+share/qt4/mkspecs/wincewm50smart-msvc2008/qmake.conf
+share/qt4/mkspecs/wincewm50smart-msvc2008/qplatformdefs.h
+share/qt4/mkspecs/wincewm60professional-msvc2005/qmake.conf
+share/qt4/mkspecs/wincewm60professional-msvc2005/qplatformdefs.h
+share/qt4/mkspecs/wincewm60professional-msvc2008/qmake.conf
+share/qt4/mkspecs/wincewm60professional-msvc2008/qplatformdefs.h
+share/qt4/mkspecs/wincewm60standard-msvc2005/qmake.conf
+share/qt4/mkspecs/wincewm60standard-msvc2005/qplatformdefs.h
+share/qt4/mkspecs/wincewm60standard-msvc2008/qmake.conf
+share/qt4/mkspecs/wincewm60standard-msvc2008/qplatformdefs.h
+@dirrm share/qt4/mkspecs/wincewm60standard-msvc2008
+@dirrm share/qt4/mkspecs/wincewm60standard-msvc2005
+@dirrm share/qt4/mkspecs/wincewm60professional-msvc2008
+@dirrm share/qt4/mkspecs/wincewm60professional-msvc2005
+@dirrm share/qt4/mkspecs/wincewm50smart-msvc2008
+@dirrm share/qt4/mkspecs/wincewm50smart-msvc2005
+@dirrm share/qt4/mkspecs/wincewm50pocket-msvc2008
+@dirrm share/qt4/mkspecs/wincewm50pocket-msvc2005
+@dirrm share/qt4/mkspecs/wince60standard-armv4i-msvc2005
+@dirrm share/qt4/mkspecs/wince50standard-x86-msvc2008
+@dirrm share/qt4/mkspecs/wince50standard-x86-msvc2005
+@dirrm share/qt4/mkspecs/wince50standard-sh4-msvc2008
+@dirrm share/qt4/mkspecs/wince50standard-sh4-msvc2005
+@dirrm share/qt4/mkspecs/wince50standard-mipsiv-msvc2008
+@dirrm share/qt4/mkspecs/wince50standard-mipsiv-msvc2005
+@dirrm share/qt4/mkspecs/wince50standard-mipsii-msvc2008
+@dirrm share/qt4/mkspecs/wince50standard-mipsii-msvc2005
+@dirrm share/qt4/mkspecs/wince50standard-armv4i-msvc2008
+@dirrm share/qt4/mkspecs/wince50standard-armv4i-msvc2005
+@dirrm share/qt4/mkspecs/win32-msvc2008
@dirrm share/qt4/mkspecs/win32-msvc2005
+@dirrm share/qt4/mkspecs/win32-msvc2003
+@dirrm share/qt4/mkspecs/win32-msvc2002
@dirrm share/qt4/mkspecs/win32-msvc/features
+@dirrm share/qt4/mkspecs/win32-msvc.net
@dirrm share/qt4/mkspecs/win32-msvc
@dirrm share/qt4/mkspecs/win32-g++
@dirrm share/qt4/mkspecs/win32-borland
@@ -260,9 +331,11 @@ share/qt4/mkspecs/win32-msvc.net/qplatformdefs.h
@dirrm share/qt4/mkspecs/qws/linux-mips-g++
@dirrm share/qt4/mkspecs/qws/linux-lsb-g++
@dirrm share/qt4/mkspecs/qws/linux-ipaq-g++
-@dirrm share/qt4/mkspecs/qws/linux-generic-g++
@dirrm share/qt4/mkspecs/qws/linux-generic-g++-32
+@dirrm share/qt4/mkspecs/qws/linux-generic-g++
+@dirrm share/qt4/mkspecs/qws/linux-dm7000-g++
@dirrm share/qt4/mkspecs/qws/linux-cellon-g++
+@dirrm share/qt4/mkspecs/qws/linux-avr32-g++
@dirrm share/qt4/mkspecs/qws/linux-arm-g++
@dirrm share/qt4/mkspecs/qws/freebsd-generic-g++
@dirrm share/qt4/mkspecs/qws
@@ -271,11 +344,13 @@ share/qt4/mkspecs/win32-msvc.net/qplatformdefs.h
@dirrm share/qt4/mkspecs/macx-xlc
@dirrm share/qt4/mkspecs/macx-xcode
@dirrm share/qt4/mkspecs/macx-pbuilder
-@dirrm share/qt4/mkspecs/macx-g++
+@dirrm share/qt4/mkspecs/macx-llvm
@dirrm share/qt4/mkspecs/macx-icc
+@dirrm share/qt4/mkspecs/macx-g++
@dirrm share/qt4/mkspecs/lynxos-g++
@dirrm share/qt4/mkspecs/linux-pgcc
@dirrm share/qt4/mkspecs/linux-lsb-g++
+@dirrm share/qt4/mkspecs/linux-llvm
@dirrm share/qt4/mkspecs/linux-kcc
@dirrm share/qt4/mkspecs/linux-icc-64
@dirrm share/qt4/mkspecs/linux-icc-32
@@ -290,8 +365,8 @@ share/qt4/mkspecs/win32-msvc.net/qplatformdefs.h
@dirrm share/qt4/mkspecs/irix-cc-64
@dirrm share/qt4/mkspecs/irix-cc
@dirrm share/qt4/mkspecs/hurd-g++
-@dirrm share/qt4/mkspecs/hpuxi-acc-32
@dirrm share/qt4/mkspecs/hpuxi-acc-64
+@dirrm share/qt4/mkspecs/hpuxi-acc-32
@dirrm share/qt4/mkspecs/hpux-g++-64
@dirrm share/qt4/mkspecs/hpux-g++
@dirrm share/qt4/mkspecs/hpux-acc-o64
@@ -306,12 +381,11 @@ share/qt4/mkspecs/win32-msvc.net/qplatformdefs.h
@dirrm share/qt4/mkspecs/features/mac
@dirrm share/qt4/mkspecs/features
@dirrm share/qt4/mkspecs/darwin-g++
+@dirrm share/qt4/mkspecs/cygwin-g++
@dirrm share/qt4/mkspecs/common
@dirrm share/qt4/mkspecs/aix-xlc-64
@dirrm share/qt4/mkspecs/aix-xlc
@dirrm share/qt4/mkspecs/aix-g++-64
@dirrm share/qt4/mkspecs/aix-g++
-@dirrm share/qt4/mkspecs
-@dirrm share/qt4
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry share/qt4/mkspecs
+@dirrmtry share/qt4