aboutsummaryrefslogtreecommitdiff
path: root/devel/qt-designer
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-02-04 04:43:14 +0000
committerWill Andrews <will@FreeBSD.org>2001-02-04 04:43:14 +0000
commita29b48245893af789aa5115dde514b19153785d8 (patch)
tree4074580f8ff1da41c8c581b6ed3f0751374ef1d1 /devel/qt-designer
parentf503cd9bcc28c62bcd161fa7829a8e368e0952fa (diff)
downloadports-a29b48245893af789aa5115dde514b19153785d8.tar.gz
ports-a29b48245893af789aa5115dde514b19153785d8.zip
Update QT2 to 2.2.4: Re-add USE_MESA, remove antialiasing patch, remove
default -j2 (but keep MAKE_JOBS var), restore old perl REs as soon as I'd learned how to do multiple ones, remove QPL license file from packaging, sync with newest KOI8-U/R stuff (not tested). The biggest bonus: split QT Designer into its own port, and make the qt22/qt-designer pair a member of the master-slave ports legion, hopefully to reduce redundancy as much as possible. This should also save roughly 20 minutes of compile time on a dual PIII-600 for those that don't need or want QT Designer. UIC is, however, still installed/compiled by the default Qt 2.2.4 (as it _is_ required for other things e.g. KDE2). USE_MESA may break KDE2. Hopefully, now that the port does install both the threaded and non-threaded versions of QT, it won't. But until the next release of KDE2, I'm not gonna bother testing to see. USE_MESA repeatedly requested by: sobomax
Notes
Notes: svn path=/head/; revision=37942
Diffstat (limited to 'devel/qt-designer')
-rw-r--r--devel/qt-designer/Makefile35
-rw-r--r--devel/qt-designer/files/patch-Makefile16
-rw-r--r--devel/qt-designer/files/patch-aa60
-rw-r--r--devel/qt-designer/files/patch-ag13
-rw-r--r--devel/qt-designer/files/patch-ah14
-rw-r--r--devel/qt-designer/files/patch-ai15
-rw-r--r--devel/qt-designer/files/patch-aj32
-rw-r--r--devel/qt-designer/files/patch-designer::Makefile.in11
-rw-r--r--devel/qt-designer/files/patch-designer:Makefile.in17
-rw-r--r--devel/qt-designer/pkg-comment1
-rw-r--r--devel/qt-designer/pkg-descr4
-rw-r--r--devel/qt-designer/pkg-plist165
12 files changed, 383 insertions, 0 deletions
diff --git a/devel/qt-designer/Makefile b/devel/qt-designer/Makefile
new file mode 100644
index 000000000000..2c0ea82188af
--- /dev/null
+++ b/devel/qt-designer/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Qt Designer
+# Date created: Sat Feb 3 23:04:41 EST 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+MASTERDIR= ${.CURDIR}/../../x11-toolkits/qt22
+
+PORTNAME= qt-designer
+CATEGORIES= devel
+
+.include "${MASTERDIR}/Makefile"
+
+WRKSRC= ${WRKDIR}/qt-${PORTVERSION}
+PATCHDIR= ${.CURDIR}/files
+PATCH_WRKSRC= ${WRKSRC}
+USE_QT2= yes
+PKGDIR= ${.CURDIR}
+MAKE_ENV= QTDIR=${PREFIX} LD_LIBRARY_PATH=${PREFIX}/lib PREFIX=${PREFIX}
+ALL_TARGET= sub-tools
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/qt2/designer/templates \
+ ${PREFIX}/share/doc/qt2/html/designer/arrows \
+ ${PREFIX}/share/doc/qt2/html/designer/figures
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/designer ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/tools/designer/templates/* \
+ ${PREFIX}/share/qt2/designer/templates
+ ${INSTALL_DATA} ${WRKSRC}/doc/html/designer/*.html \
+ ${PREFIX}/share/doc/qt2/html/designer
+.for IMGDIR in arrows figures
+ ${INSTALL_DATA} ${WRKSRC}/doc/html/designer/${IMGDIR}/*.png \
+ ${PREFIX}/share/doc/qt2/html/designer/${IMGDIR}
+.endfor
diff --git a/devel/qt-designer/files/patch-Makefile b/devel/qt-designer/files/patch-Makefile
new file mode 100644
index 000000000000..8b18a9fc7af7
--- /dev/null
+++ b/devel/qt-designer/files/patch-Makefile
@@ -0,0 +1,16 @@
+--- Makefile Wed Jan 31 21:29:35 2001
++++ Makefile.new Sat Feb 3 20:21:49 2001
+@@ -25,11 +25,11 @@
+ -rm -f bin/moc
+ cp src/moc/moc bin/moc
+
+-sub-tools: sub-src FORCE
++sub-tools: FORCE
+ cd tools; $(MAKE)
+
+ symlinks: .buildopts
+- @cd include; rm -f q*.h; ln -s $(QTDIR)/src/*/q*.h .; ln -s $(QTDIR)/extensions/*/src/q*.h .; rm -f q*_p.h
++ @cd include; rm -f q*.h; ln -s ../src/*/q*.h .; ln -s ../extensions/*/src/q*.h .; rm -f q*_p.h
+
+ sub-src: src-moc src-mt .buildopts FORCE
+ cd src; $(MAKE)
diff --git a/devel/qt-designer/files/patch-aa b/devel/qt-designer/files/patch-aa
new file mode 100644
index 000000000000..119251bcb772
--- /dev/null
+++ b/devel/qt-designer/files/patch-aa
@@ -0,0 +1,60 @@
+--- configs/freebsd-g++-shared Sun Dec 24 02:41:35 2000
++++ configs/freebsd-g++-shared.new Sun Dec 24 02:42:49 2000
+@@ -6,7 +6,7 @@
+
+ # Compiling with support libraries
+ SYSCONF_CXXFLAGS_X11 = -I/usr/X11R6/include
+-SYSCONF_CXXFLAGS_QT = -I$(QTDIR)/include
++SYSCONF_CXXFLAGS_QT= -I$(QTDIR)/include -I/usr/X11R6/include/qt2 $(SYSCONF_CXXFLAGS_THREAD)
+ SYSCONF_CXXFLAGS_OPENGL = -I/usr/X11R6/include
+
+ # Compiling YACC output
+@@ -23,7 +23,7 @@
+ SYSCONF_LIBS_X11 = -lXext -lX11 -lm
+ # Qt, Qt+OpenGL
+ SYSCONF_LFLAGS_QT = -L$(QTDIR)/lib
+-SYSCONF_LIBS_QT = -lqt$(QT_THREAD_SUFFIX)
++SYSCONF_LIBS_QT = -lqt2$(QT_THREAD_SUFFIX) $(SYSCONF_LFLAGS_THREAD)
+ SYSCONF_LIBS_QT_OPENGL =
+ # OpenGL
+ SYSCONF_LFLAGS_OPENGL = -L/usr/X11R6/lib
+@@ -46,7 +46,7 @@
+ SYSCONF_LIBS_THREAD =
+
+ # Meta-object compiler
+-SYSCONF_MOC = $(QTDIR)/bin/moc
++SYSCONF_MOC = $(QTDIR)/bin/moc2
+
+ # UI compiler
+ SYSCONF_UIC = $(QTDIR)/bin/uic
+@@ -57,16 +57,14 @@
+ # - Usually needs to incorporate $(VER_MAJ), $(VER_MIN) and $(VER_PATCH)
+ #
+ SYSCONF_LINK_SHLIB = g++
+-SYSCONF_LINK_TARGET_SHARED = lib$(TARGET).so.$(VER_MAJ).$(VER_MIN).$(VER_PATCH)
++SYSCONF_LINK_TARGET_SHARED = lib$(TARGET).so.$(VER_MAJ)
+ SYSCONF_LINK_LIB_SHARED = $(SYSCONF_LINK_SHLIB) -shared \
+ $(LFLAGS) -o $(SYSCONF_LINK_TARGET_SHARED) \
+ $(OBJECTS) $(OBJMOC) $(LIBS) && \
+ mv $(SYSCONF_LINK_TARGET_SHARED) $(DESTDIR); \
+ cd $(DESTDIR) && \
+- rm -f lib$(TARGET).so lib$(TARGET).so.$(VER_MAJ) lib$(TARGET).so.$(VER_MAJ).$(VER_MIN); \
+- ln -s $(SYSCONF_LINK_TARGET_SHARED) lib$(TARGET).so; \
+- ln -s $(SYSCONF_LINK_TARGET_SHARED) lib$(TARGET).so.$(VER_MAJ); \
+- ln -s $(SYSCONF_LINK_TARGET_SHARED) lib$(TARGET).so.$(VER_MAJ).$(VER_MIN)
++ rm -f lib$(TARGET).so;\
++ ln -s $(SYSCONF_LINK_TARGET_SHARED) lib$(TARGET).so
+
+ # Linking static libraries
+ # - Build the $(TARGET) library, eg. lib$(TARGET).a
+@@ -77,8 +75,8 @@
+ SYSCONF_LINK_LIB_STATIC = rm -f $(DESTDIR)$(SYSCONF_LINK_TARGET_STATIC) ; \
+ $(SYSCONF_AR) $(DESTDIR)$(SYSCONF_LINK_TARGET_STATIC) $(OBJECTS) $(OBJMOC)
+ # Compiling application source
+-SYSCONF_CXXFLAGS = -pipe -O2
+-SYSCONF_CFLAGS = -pipe -O2
++SYSCONF_CXXFLAGS = -DQT_PREFIX=\"${PREFIX}\" -pipe -O2
++SYSCONF_CFLAGS = -DQT_PREFIX=\"${PREFIX}\" -pipe -O2
+ # Default link type (static linking is still be used where required)
+ SYSCONF_LINK_LIB = $(SYSCONF_LINK_LIB_SHARED)
+ SYSCONF_LINK_TARGET = $(SYSCONF_LINK_TARGET_SHARED)
diff --git a/devel/qt-designer/files/patch-ag b/devel/qt-designer/files/patch-ag
new file mode 100644
index 000000000000..0347913d3a31
--- /dev/null
+++ b/devel/qt-designer/files/patch-ag
@@ -0,0 +1,13 @@
+--- tools/designer/designer/help.cpp 2000/11/18 17:43:54 1.1
++++ tools/designer/designer/help.cpp 2000/11/18 17:46:09
+@@ -84,8 +84,8 @@
+ browser = new TextBrowser( this );
+ browser->mimeSourceFactory()->setFilePath( home );
+ browser->setFrameStyle( QFrame::Panel | QFrame::Sunken );
+- browser->mimeSourceFactory()->addFilePath( QString( getenv( "QTDIR" ) ) + "/tools/designer/manual" );
+- browser->mimeSourceFactory()->addFilePath( QString( getenv( "QTDIR" ) ) + "/doc/html/designer" );
++ browser->mimeSourceFactory()->addFilePath( QT_PREFIX "/share/qt2/designer/manual" );
++ browser->mimeSourceFactory()->addFilePath( QT_PREFIX "/share/doc/qt2/html/designer" );
+ browser->mimeSourceFactory()->addFilePath( parent->documentationPath() );
+ connect( browser, SIGNAL( textChanged() ),
+ this, SLOT( textChanged() ) );
diff --git a/devel/qt-designer/files/patch-ah b/devel/qt-designer/files/patch-ah
new file mode 100644
index 000000000000..1bf90ba1c6f2
--- /dev/null
+++ b/devel/qt-designer/files/patch-ah
@@ -0,0 +1,14 @@
+--- tools/designer/designer/helpdialogimpl.cpp 2000/11/18 19:37:35 1.1
++++ tools/designer/designer/helpdialogimpl.cpp 2000/11/18 19:38:57
+@@ -569,9 +569,9 @@
+ delete lst;
+
+
+- QString manualdir = QString( getenv( "QTDIR" ) ) + "/tools/designer/manual/book1.html";
++ QString manualdir = QT_PREFIX "/share/qt2/designer/manual/book1.html";
+ if ( !QFile::exists( manualdir ) )
+- manualdir = QString( getenv( "QTDIR" ) ) + "/doc/html/designer/book1.html";
++ manualdir = QT_PREFIX "/share/doc/qt2/html/designer/book1.html";
+ QFile file( manualdir );
+ if ( !file.open( IO_ReadOnly ) )
+ return;
diff --git a/devel/qt-designer/files/patch-ai b/devel/qt-designer/files/patch-ai
new file mode 100644
index 000000000000..8ba1cf2ee470
--- /dev/null
+++ b/devel/qt-designer/files/patch-ai
@@ -0,0 +1,15 @@
+--- tools/designer/designer/newformimpl.cpp 2000/11/18 17:43:54 1.1
++++ tools/designer/designer/newformimpl.cpp 2000/11/18 17:48:49
+@@ -33,9 +33,9 @@
+ {
+ if ( QFileInfo( "../templates" ).exists() )
+ return "../templates";
+- QString qtdir = getenv( "QTDIR" );
+- if ( QFileInfo( qtdir + "/tools/designer/templates" ).exists() )
+- return qtdir + "/tools/designer/templates";
++ QString qtdir = QT_PREFIX;
++ if ( QFileInfo( qtdir + "/share/qt2/designer/templates" ).exists() )
++ return qtdir + "/share/qt2/designer/templates";
+ return t;
+ }
+
diff --git a/devel/qt-designer/files/patch-aj b/devel/qt-designer/files/patch-aj
new file mode 100644
index 000000000000..eddf54f011d9
--- /dev/null
+++ b/devel/qt-designer/files/patch-aj
@@ -0,0 +1,32 @@
+--- tools/designer/designer/mainwindow.cpp 2000/11/18 17:50:58 1.1
++++ tools/designer/designer/mainwindow.cpp 2000/11/18 17:53:21
+@@ -125,7 +125,7 @@
+ : QMainWindow( 0, "mainwindow", WType_TopLevel | WDestructiveClose ),
+ #endif
+ grd( 10, 10 ), sGrid( TRUE ), snGrid( TRUE ), restoreConfig( TRUE ), splashScreen( TRUE ),
+- docPath( "$QTDIR/doc/html" ), client( asClient )
++ docPath( QT_PREFIX "/share/doc/qt2/html" ), client( asClient )
+ {
+ self = this;
+ setIcon( PixmapChooser::loadPixmap( "logo" ) );
+@@ -3144,7 +3144,7 @@
+ QMessageBox::information( this, tr( "Create Template" ), tr( "Couldn't create the template" ) );
+ return;
+ }
+- fn.prepend( QString( getenv( "QTDIR" ) ) + "/tools/designer/templates/" );
++ fn.prepend( QT_PREFIX "/share/qt2/designer/templates/" );
+ fn.append( ".ui" );
+ QFile f( fn );
+ if ( !f.open( IO_WriteOnly ) ) {
+@@ -3236,9 +3236,9 @@
+
+ void MainWindow::openHelpForDialog( const QString &dia )
+ {
+- QString manualdir = QString( getenv( "QTDIR" ) ) + "/tools/designer/manual/book1.html";
++ QString manualdir = QT_PREFIX "/share/qt2/designer/manual/book1.html";
+ if ( !QFile::exists( manualdir ) )
+- manualdir = QString( getenv( "QTDIR" ) ) + "/doc/html/designer/book1.html";
++ manualdir = QT_PREFIX "/share/doc/qt2/html/designer/book1.html";
+ QFile file( manualdir );
+ if ( !file.open( IO_ReadOnly ) )
+ return;
diff --git a/devel/qt-designer/files/patch-designer::Makefile.in b/devel/qt-designer/files/patch-designer::Makefile.in
new file mode 100644
index 000000000000..52f3cca45258
--- /dev/null
+++ b/devel/qt-designer/files/patch-designer::Makefile.in
@@ -0,0 +1,11 @@
+--- tools/designer/designer/Makefile.in Wed Jan 31 21:29:50 2001
++++ tools/designer/designer/Makefile.in.new Sat Feb 3 20:41:04 2001
+@@ -14,7 +14,7 @@
+
+ ####### Target
+
+-DESTDIR = $(QTDIR)/bin/
++DESTDIR = ../../../bin/
+ VER_MAJ = 1
+ VER_MIN = 0
+ VER_PATCH = 0
diff --git a/devel/qt-designer/files/patch-designer:Makefile.in b/devel/qt-designer/files/patch-designer:Makefile.in
new file mode 100644
index 000000000000..498cff3955af
--- /dev/null
+++ b/devel/qt-designer/files/patch-designer:Makefile.in
@@ -0,0 +1,17 @@
+--- tools/designer/Makefile.in Wed Jan 31 21:29:47 2001
++++ tools/designer/Makefile.in.new Sat Feb 3 20:04:32 2001
+@@ -5,13 +5,9 @@
+ # Template: subdirs
+ #############################################################################
+
+-SUBDIRS = util \
+- uic \
+- designer
++SUBDIRS = designer
+
+ all:
+- $(MAKE) util
+- $(MAKE) uic
+ $(MAKE) designer
+
+
diff --git a/devel/qt-designer/pkg-comment b/devel/qt-designer/pkg-comment
new file mode 100644
index 000000000000..901225f07b1e
--- /dev/null
+++ b/devel/qt-designer/pkg-comment
@@ -0,0 +1 @@
+GUI C++ IDE based on QT
diff --git a/devel/qt-designer/pkg-descr b/devel/qt-designer/pkg-descr
new file mode 100644
index 000000000000..74664b302c3d
--- /dev/null
+++ b/devel/qt-designer/pkg-descr
@@ -0,0 +1,4 @@
+Qt Designer is a GUI IDE based on Qt 2.x made by
+the trolltech people.
+
+WWW: http://www.trolltech.com/products/qt/designer/
diff --git a/devel/qt-designer/pkg-plist b/devel/qt-designer/pkg-plist
new file mode 100644
index 000000000000..2e4183356173
--- /dev/null
+++ b/devel/qt-designer/pkg-plist
@@ -0,0 +1,165 @@
+bin/designer
+share/doc/qt2/html/designer/arrows/home.png
+share/doc/qt2/html/designer/arrows/left.png
+share/doc/qt2/html/designer/arrows/right.png
+share/doc/qt2/html/designer/arrows/up.png
+share/doc/qt2/html/designer/book1.html
+share/doc/qt2/html/designer/chap10_1.html
+share/doc/qt2/html/designer/chap1_1.html
+share/doc/qt2/html/designer/chap2_1.html
+share/doc/qt2/html/designer/chap2_2.html
+share/doc/qt2/html/designer/chap2_3.html
+share/doc/qt2/html/designer/chap2_4.html
+share/doc/qt2/html/designer/chap3_1.html
+share/doc/qt2/html/designer/chap3_2.html
+share/doc/qt2/html/designer/chap3_3.html
+share/doc/qt2/html/designer/chap3_4.html
+share/doc/qt2/html/designer/chap4_1.html
+share/doc/qt2/html/designer/chap4_2.html
+share/doc/qt2/html/designer/chap5_1.html
+share/doc/qt2/html/designer/chap5_2.html
+share/doc/qt2/html/designer/chap5_3.html
+share/doc/qt2/html/designer/chap5_4.html
+share/doc/qt2/html/designer/chap5_5.html
+share/doc/qt2/html/designer/chap5_6.html
+share/doc/qt2/html/designer/chap6_1.html
+share/doc/qt2/html/designer/chap6_2.html
+share/doc/qt2/html/designer/chap6_3.html
+share/doc/qt2/html/designer/chap6_4.html
+share/doc/qt2/html/designer/chap6_5.html
+share/doc/qt2/html/designer/chap6_6.html
+share/doc/qt2/html/designer/chap6_7.html
+share/doc/qt2/html/designer/chap7_1.html
+share/doc/qt2/html/designer/chap7_10.html
+share/doc/qt2/html/designer/chap7_11.html
+share/doc/qt2/html/designer/chap7_12.html
+share/doc/qt2/html/designer/chap7_13.html
+share/doc/qt2/html/designer/chap7_14.html
+share/doc/qt2/html/designer/chap7_15.html
+share/doc/qt2/html/designer/chap7_16.html
+share/doc/qt2/html/designer/chap7_2.html
+share/doc/qt2/html/designer/chap7_3.html
+share/doc/qt2/html/designer/chap7_4.html
+share/doc/qt2/html/designer/chap7_5.html
+share/doc/qt2/html/designer/chap7_6.html
+share/doc/qt2/html/designer/chap7_7.html
+share/doc/qt2/html/designer/chap7_8.html
+share/doc/qt2/html/designer/chap7_9.html
+share/doc/qt2/html/designer/chap8_1.html
+share/doc/qt2/html/designer/chap9_1.html
+share/doc/qt2/html/designer/chap9_2.html
+share/doc/qt2/html/designer/chap9_3.html
+share/doc/qt2/html/designer/chap9_4.html
+share/doc/qt2/html/designer/chap9_5.html
+share/doc/qt2/html/designer/chap9_6.html
+share/doc/qt2/html/designer/colophon.html
+share/doc/qt2/html/designer/feedback.html
+share/doc/qt2/html/designer/figures/aboutdialog.png
+share/doc/qt2/html/designer/figures/adjustsize.png
+share/doc/qt2/html/designer/figures/breaklayout.png
+share/doc/qt2/html/designer/figures/buttongroup.png
+share/doc/qt2/html/designer/figures/buttongroupovercheckboxes.png
+share/doc/qt2/html/designer/figures/checkbox.png
+share/doc/qt2/html/designer/figures/combobox.png
+share/doc/qt2/html/designer/figures/connectionedit.png
+share/doc/qt2/html/designer/figures/connections.png
+share/doc/qt2/html/designer/figures/connectionviewer.png
+share/doc/qt2/html/designer/figures/connecttool.png
+share/doc/qt2/html/designer/figures/customwidget.png
+share/doc/qt2/html/designer/figures/customwidgets.png
+share/doc/qt2/html/designer/figures/editcopy.png
+share/doc/qt2/html/designer/figures/editcustomwidgets.png
+share/doc/qt2/html/designer/figures/editcut.png
+share/doc/qt2/html/designer/figures/editdelete.png
+share/doc/qt2/html/designer/figures/editgrid.png
+share/doc/qt2/html/designer/figures/edithlayout.png
+share/doc/qt2/html/designer/figures/editiconview.png
+share/doc/qt2/html/designer/figures/editlistbox.png
+share/doc/qt2/html/designer/figures/editlistview.png
+share/doc/qt2/html/designer/figures/editlower.png
+share/doc/qt2/html/designer/figures/editmultiline.png
+share/doc/qt2/html/designer/figures/editpaste.png
+share/doc/qt2/html/designer/figures/editraise.png
+share/doc/qt2/html/designer/figures/editslots.png
+share/doc/qt2/html/designer/figures/emptydialog.png
+share/doc/qt2/html/designer/figures/f001.png
+share/doc/qt2/html/designer/figures/filenew.png
+share/doc/qt2/html/designer/figures/filesave.png
+share/doc/qt2/html/designer/figures/firstdialog.png
+share/doc/qt2/html/designer/figures/form.png
+share/doc/qt2/html/designer/figures/formsettings.png
+share/doc/qt2/html/designer/figures/fourcheckboxes.png
+share/doc/qt2/html/designer/figures/frame.png
+share/doc/qt2/html/designer/figures/groupbox.png
+share/doc/qt2/html/designer/figures/help.png
+share/doc/qt2/html/designer/figures/helpdialog.png
+share/doc/qt2/html/designer/figures/home.png
+share/doc/qt2/html/designer/figures/iconview.png
+share/doc/qt2/html/designer/figures/image.png
+share/doc/qt2/html/designer/figures/label.png
+share/doc/qt2/html/designer/figures/layout.png
+share/doc/qt2/html/designer/figures/layouttutstep1.png
+share/doc/qt2/html/designer/figures/layouttutstep10.png
+share/doc/qt2/html/designer/figures/layouttutstep11.png
+share/doc/qt2/html/designer/figures/layouttutstep2.png
+share/doc/qt2/html/designer/figures/layouttutstep3.png
+share/doc/qt2/html/designer/figures/layouttutstep4.png
+share/doc/qt2/html/designer/figures/layouttutstep5.png
+share/doc/qt2/html/designer/figures/layouttutstep6.png
+share/doc/qt2/html/designer/figures/layouttutstep7.png
+share/doc/qt2/html/designer/figures/layouttutstep9.png
+share/doc/qt2/html/designer/figures/lcdnumber.png
+share/doc/qt2/html/designer/figures/left.png
+share/doc/qt2/html/designer/figures/line.png
+share/doc/qt2/html/designer/figures/lineedit.png
+share/doc/qt2/html/designer/figures/listbox.png
+share/doc/qt2/html/designer/figures/listview.png
+share/doc/qt2/html/designer/figures/load.png
+share/doc/qt2/html/designer/figures/multilineedit.png
+share/doc/qt2/html/designer/figures/newform.png
+share/doc/qt2/html/designer/figures/newformdialog.png
+share/doc/qt2/html/designer/figures/objecthierarchy.png
+share/doc/qt2/html/designer/figures/onecheckbox.png
+share/doc/qt2/html/designer/figures/ordertool.png
+share/doc/qt2/html/designer/figures/paletteeditor.png
+share/doc/qt2/html/designer/figures/pixlabel.png
+share/doc/qt2/html/designer/figures/pizza1screenshot.png
+share/doc/qt2/html/designer/figures/pointer.png
+share/doc/qt2/html/designer/figures/preferences.png
+share/doc/qt2/html/designer/figures/print.png
+share/doc/qt2/html/designer/figures/progress.png
+share/doc/qt2/html/designer/figures/pushbutton.png
+share/doc/qt2/html/designer/figures/qtlogo.png
+share/doc/qt2/html/designer/figures/radiobutton.png
+share/doc/qt2/html/designer/figures/redo.png
+share/doc/qt2/html/designer/figures/right.png
+share/doc/qt2/html/designer/figures/slider.png
+share/doc/qt2/html/designer/figures/slots.png
+share/doc/qt2/html/designer/figures/spacer.png
+share/doc/qt2/html/designer/figures/spinbox.png
+share/doc/qt2/html/designer/figures/startup.png
+share/doc/qt2/html/designer/figures/taborderform.png
+share/doc/qt2/html/designer/figures/tabwidget.png
+share/doc/qt2/html/designer/figures/testmode.png
+share/doc/qt2/html/designer/figures/textbrowser.png
+share/doc/qt2/html/designer/figures/textview.png
+share/doc/qt2/html/designer/figures/title.png
+share/doc/qt2/html/designer/figures/toolbutton.png
+share/doc/qt2/html/designer/figures/topicchooser.png
+share/doc/qt2/html/designer/figures/undo.png
+share/doc/qt2/html/designer/figures/vlayout.png
+share/doc/qt2/html/designer/figures/whatsthis.png
+share/doc/qt2/html/designer/part1index.html
+share/doc/qt2/html/designer/part2index.html
+share/doc/qt2/html/designer/preface.html
+share/qt2/designer/templates/Configuration_Dialog.ui
+share/qt2/designer/templates/Dialog_with_Buttons_(Bottom).ui
+share/qt2/designer/templates/Dialog_with_Buttons_(Right).ui
+share/qt2/designer/templates/Tab-Dialog.ui
+@dirrm share/doc/qt2/html/designer/figures
+@dirrm share/doc/qt2/html/designer/arrows
+@dirrm share/doc/qt2/html/designer
+@dirrm share/qt2/designer/templates
+@dirrm share/qt2/designer
+@unexec /sbin/rm -rf %D/share/doc/qt2/html 2>/dev/null || true
+@unexec /sbin/rm -rf %D/share/doc/qt2 2>/dev/null || true