aboutsummaryrefslogtreecommitdiff
path: root/devel/qt4-designer/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-05-01 15:14:48 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2007-05-01 15:14:48 +0000
commitc2719a1924136463efddc6103027bb026483084e (patch)
treed7f3c6497115a54824b91329ba3414018f514740 /devel/qt4-designer/Makefile
parent46b30935e07d32449f4870302d424f29749b042f (diff)
downloadports-c2719a1924136463efddc6103027bb026483084e.tar.gz
ports-c2719a1924136463efddc6103027bb026483084e.zip
Fix/remove bogus paths pointing to the build directory from pkgconfig files,
libtool archives and dot-prl files. PR: ports/112228 Submitted by: Koji Yokota <yokota@res.otaru-uc.ac.jp>
Notes
Notes: svn path=/head/; revision=191292
Diffstat (limited to 'devel/qt4-designer/Makefile')
-rw-r--r--devel/qt4-designer/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/devel/qt4-designer/Makefile b/devel/qt4-designer/Makefile
index 50efbb4a4278..e4b4a3f05feb 100644
--- a/devel/qt4-designer/Makefile
+++ b/devel/qt4-designer/Makefile
@@ -8,7 +8,7 @@
PORTNAME= designer
PORTVERSION= 4.2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= devel
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -78,4 +78,11 @@ pre-configure:
${LN} -sf ${LOCALBASE}/bin/uic-qt4 ${WRKSRC}/../../bin/uic
${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/../../bin/rcc
+post-configure:
+ ${REINPLACE_CMD} -e 's|.*$$(QMAKE).*||g' ${WRKSRC}/src/uitools/Makefile
+ ${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
+ -E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
+ -E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
+ ${WRKSRC}/../../lib/*Qt*
+
.include <bsd.port.post.mk>