aboutsummaryrefslogtreecommitdiff
path: root/devel/qt4-designer
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-04-19 17:08:04 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2007-04-19 17:08:04 +0000
commit7aeef3e5194acb6b59e88472be78b4d7f2a7014f (patch)
tree616dfe53e60011f08ba0fd9e44d23086ed7704a2 /devel/qt4-designer
parent70b438b4348e8e5786613051e3c8e890dd2d18f9 (diff)
downloadports-7aeef3e5194acb6b59e88472be78b4d7f2a7014f.tar.gz
ports-7aeef3e5194acb6b59e88472be78b4d7f2a7014f.zip
Rename all binaries in qt4 which conflict with binaries installed by
qt33 to ($binary)-qt4 and adjust dependencies accordingly. This avoids conflicts once X11BASE has been changed to /usr/local and incidentally makes the naming scheme of the qt4 executables in ports equal to that of the Fedora Core and Debian packages.
Notes
Notes: svn path=/head/; revision=190368
Diffstat (limited to 'devel/qt4-designer')
-rw-r--r--devel/qt4-designer/Makefile11
-rw-r--r--devel/qt4-designer/pkg-plist4
2 files changed, 8 insertions, 7 deletions
diff --git a/devel/qt4-designer/Makefile b/devel/qt4-designer/Makefile
index e2abe8225553..50efbb4a4278 100644
--- a/devel/qt4-designer/Makefile
+++ b/devel/qt4-designer/Makefile
@@ -8,7 +8,7 @@
PORTNAME= designer
PORTVERSION= 4.2.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES?= devel
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -18,10 +18,10 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt ui editor
-BUILD_DEPENDS= moc4:${PORTSDIR}/devel/qt4-moc \
+BUILD_DEPENDS= moc-qt4:${PORTSDIR}/devel/qt4-moc \
qmake-qt4:${PORTSDIR}/devel/qmake4 \
rcc:${PORTSDIR}/devel/qt4-rcc \
- uic4:${PORTSDIR}/devel/qt4-uic
+ uic-qt4:${PORTSDIR}/devel/qt4-uic
LIB_DEPENDS= QtAssistantClient:${PORTSDIR}/devel/qt4-libqtassistantclient \
Qt3Support:${PORTSDIR}/devel/qt4-qt3support \
QtCore:${PORTSDIR}/devel/qt4-corelib \
@@ -64,6 +64,7 @@ CONFIGURE_WRKSRC=${WRKSRC}/../../
pre-configure:
${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/bin|g' \
+ -e 's|^TARGET.*|TARGET=designer-qt4|g' \
${WRKSRC}/src/designer/${PORTNAME}.pro
${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib/plugins|g' \
${WRKSRC}/src/plugins/plugins.pri
@@ -73,8 +74,8 @@ pre-configure:
${WRKSRC}/src/lib/lib.pro ${WRKSRC}/src/components/lib/lib.pro
${MKDIR} ${WRKSRC}/../../mkspecs
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc4 ${WRKSRC}/../../bin/moc
- ${LN} -sf ${LOCALBASE}/bin/uic4 ${WRKSRC}/../../bin/uic
+ ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../bin/moc
+ ${LN} -sf ${LOCALBASE}/bin/uic-qt4 ${WRKSRC}/../../bin/uic
${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/../../bin/rcc
.include <bsd.port.post.mk>
diff --git a/devel/qt4-designer/pkg-plist b/devel/qt4-designer/pkg-plist
index 0ef0b8dec4d0..ea84579a1a87 100644
--- a/devel/qt4-designer/pkg-plist
+++ b/devel/qt4-designer/pkg-plist
@@ -1,5 +1,5 @@
-bin/designer
-bin/designer.debug
+bin/designer-qt4
+bin/designer-qt4.debug
include/QtDesigner/QAbstractExtensionFactory
include/QtDesigner/QAbstractExtensionManager
include/QtDesigner/QAbstractFormBuilder