aboutsummaryrefslogtreecommitdiff
path: root/devel/qt4-designer
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-08-02 22:37:40 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2007-08-02 22:37:40 +0000
commite332496be5f6fa4fa10c72920241b6910a69ca00 (patch)
tree7c1e4ee6690abd492b16853205c1bf65c308e4fb /devel/qt4-designer
parenta89bbaf869b99b813eb1a147e18884857d7e5495 (diff)
downloadports-e332496be5f6fa4fa10c72920241b6910a69ca00.tar.gz
ports-e332496be5f6fa4fa10c72920241b6910a69ca00.zip
- bsd.qt.mk:
QT_COMPONENTS can now be depended on at runtime or buildtime only by specifiying them as <component>_build or <component>_run, respectively. Specifying <component> without any suffix will depend on the component at both build- and runtime just like before. - Convert Qt core ports to use the new dependency switches. - Add a patch to corelib to fix Qt4 on ARM, submitted by: Björn König <bkoenig@alpha-tierchen.de>
Notes
Notes: svn path=/head/; revision=196993
Diffstat (limited to 'devel/qt4-designer')
-rw-r--r--devel/qt4-designer/Makefile4
-rw-r--r--devel/qt4-designer/pkg-plist8
2 files changed, 6 insertions, 6 deletions
diff --git a/devel/qt4-designer/Makefile b/devel/qt4-designer/Makefile
index f1db40c8dad3..bfa83eefeb33 100644
--- a/devel/qt4-designer/Makefile
+++ b/devel/qt4-designer/Makefile
@@ -19,8 +19,8 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt ui editor
USE_QT_VER= 4
-QT_COMPONENTS= qmake moc rcc uic assistantclient qt3support corelib gui network\
- script sql xml
+QT_COMPONENTS= qmake_build moc_build rcc_build uic_build assistantclient \
+ qt3support corelib gui network script sql xml
QT_NONSTANDARD= yes
QT_DIST= yes
diff --git a/devel/qt4-designer/pkg-plist b/devel/qt4-designer/pkg-plist
index 5441f3ec4714..42629782fa43 100644
--- a/devel/qt4-designer/pkg-plist
+++ b/devel/qt4-designer/pkg-plist
@@ -1,5 +1,5 @@
bin/designer-qt4
-bin/designer-qt4.debug
+%%DEBUG%%bin/designer-qt4.debug
include/QtDesigner/QAbstractExtensionFactory
include/QtDesigner/QAbstractExtensionManager
include/QtDesigner/QAbstractFormBuilder
@@ -87,17 +87,17 @@ lib/libQtDesigner.so
lib/libQtDesigner.so.4
lib/libQtDesigner.so.4.3
lib/libQtDesigner.so.4.3.0
-lib/libQtDesigner.so.4.3.0.debug
+%%DEBUG%%lib/libQtDesigner.so.4.3.0.debug
lib/libQtDesignerComponents.prl
lib/libQtDesignerComponents.so
lib/libQtDesignerComponents.so.4
lib/libQtDesignerComponents.so.4.3
lib/libQtDesignerComponents.so.4.3.0
-lib/libQtDesignerComponents.so.4.3.0.debug
+%%DEBUG%%lib/libQtDesignerComponents.so.4.3.0.debug
lib/libQtUiTools.a
lib/libQtUiTools.prl
lib/plugins/libqt3supportwidgets.so
-lib/plugins/libqt3supportwidgets.so.debug
+%%DEBUG%%lib/plugins/libqt3supportwidgets.so.debug
libdata/pkgconfig/QtUiTools.pc
@dirrm include/QtUiTools
@dirrm include/QtDesigner