aboutsummaryrefslogtreecommitdiff
path: root/devel/raknet
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-10-28 10:47:20 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-10-28 10:47:20 +0000
commitb22c68298b7199b8734ac6e8ab3efa6489a527ec (patch)
tree3ed085ad691330e50278b67077086f815ba37653 /devel/raknet
parent5e5a14427f1911afc1849fa52486f7369c36875b (diff)
downloadports-b22c68298b7199b8734ac6e8ab3efa6489a527ec.tar.gz
ports-b22c68298b7199b8734ac6e8ab3efa6489a527ec.zip
A free networking API that provides reliable UDP and high level networking
constructs. Although RakNet can be used for any networked application, it was developed specifically for rapid development of online games and the addition of multiplayer to single player games. WWW: http://www.rakkarsoft.com/ PR: ports/87304 Submitted by: Andrew I Baznikin <dikiy@scn.ru>
Notes
Notes: svn path=/head/; revision=146565
Diffstat (limited to 'devel/raknet')
-rw-r--r--devel/raknet/Makefile56
-rw-r--r--devel/raknet/distinfo2
-rw-r--r--devel/raknet/pkg-descr6
-rw-r--r--devel/raknet/pkg-plist62
4 files changed, 126 insertions, 0 deletions
diff --git a/devel/raknet/Makefile b/devel/raknet/Makefile
new file mode 100644
index 000000000000..f127c115422c
--- /dev/null
+++ b/devel/raknet/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: raknet
+# Date created: 11 october 2005
+# Whom: dikiy
+
+# $FreeBSD$
+
+PORTNAME= raknet
+PORTVERSION= 2.0.13
+CATEGORIES= devel net
+MASTER_SITES= http://www.rakkarsoft.com/raknet/downloads/
+DISTNAME= RakNet
+
+MAINTAINER= dikiy@scn.ru
+COMMENT= Networking API that provides reliable UDP prmary for online games
+
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}
+
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${FIND} ${WRKSRC} -name CVS -delete
+ @${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|g" -e "s|-lpthread|${PTHREAD_LIBS}|" -e "s|-fPIC|-fPIC ${CFLAGS}|" ${WRKSRC}/makefile.defs
+ @${REINPLACE_CMD} -e "s|rm -f|#rm -f|g" -e "s|ln -s|${LN} -sf|" ${WRKSRC}/Makefile
+ @for _F in `${FIND} ${WRKSRC} \
+ -iregex '[^ ]*/makefile.*' -or \
+ -iregex "[^ ]*/*.cpp" -or \
+ -iregex "[^ ]*/*.h"`; do \
+ ${AWK} 'gsub( /\r/, "" )' $${_F} > $${_F}.awk.tmp; \
+ ${MV} $${_F}.awk.tmp $${_F}; \
+ done
+.if ${OSVERSION} < 500000
+ @${REINPLACE_CMD} -e "s|stdint.h|inttypes.h|" ${WRKSRC}/Include/BitStream.h
+ @${RM} ${WRKSRC}/Include/BitStream.h.bak
+.endif
+ @${MKDIR} ${WRKSRC}/Lib/linux
+ @${LN} -s ${WRKSRC}/Lib ${WRKSRC}/lib
+
+post-install:
+ ${LN} -sf ${PREFIX}/lib/libraknet.so.2.0.13 ${PREFIX}/lib/libraknet.so.0
+ ${LN} -sf ${PREFIX}/lib/librakvoice.so.2.0.13 ${PREFIX}/lib/librakvoice.so.0
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}/DOxygen
+ @cd ${WRKDIR}/Help && ${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/{} \;
+ @cd ${WRKDIR}/Help && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/raknet/distinfo b/devel/raknet/distinfo
new file mode 100644
index 000000000000..1f0e3853cd2f
--- /dev/null
+++ b/devel/raknet/distinfo
@@ -0,0 +1,2 @@
+MD5 (RakNet.zip) = 12bb14695909bf7622903048dc4ce56e
+Size (RakNet.zip) = 8125494
diff --git a/devel/raknet/pkg-descr b/devel/raknet/pkg-descr
new file mode 100644
index 000000000000..85fcbae54440
--- /dev/null
+++ b/devel/raknet/pkg-descr
@@ -0,0 +1,6 @@
+A free networking API that provides reliable UDP and high level networking
+constructs. Although RakNet can be used for any networked application, it
+was developed specifically for rapid development of online games and the
+addition of multiplayer to single player games.
+
+WWW: http://www.rakkarsoft.com/
diff --git a/devel/raknet/pkg-plist b/devel/raknet/pkg-plist
new file mode 100644
index 000000000000..56c7d2196ac1
--- /dev/null
+++ b/devel/raknet/pkg-plist
@@ -0,0 +1,62 @@
+include/raknet/AES128.h
+include/raknet/ArrayList.h
+include/raknet/AsynchronousFileIO.h
+include/raknet/Autopatcher/Autopatcher.h
+include/raknet/Autopatcher/DownloadableFileDescriptor.h
+include/raknet/BigTypes.h
+include/raknet/BinarySearchTree.h
+include/raknet/BitStream.h
+include/raknet/CheckSum.h
+include/raknet/ClientContextStruct.h
+include/raknet/DataBlockEncryptor.h
+include/raknet/DistributedNetworkObject.h
+include/raknet/DistributedNetworkObjectHeader.h
+include/raknet/DistributedNetworkObjectManager.h
+include/raknet/DistributedNetworkObjectStub.h
+include/raknet/EncodeClassName.h
+include/raknet/ExtendedOverlappedPool.h
+include/raknet/GetTime.h
+include/raknet/HuffmanEncodingTree.h
+include/raknet/HuffmanEncodingTreeFactory.h
+include/raknet/HuffmanEncodingTreeNode.h
+include/raknet/InternalPacket.h
+include/raknet/InternalPacketPool.h
+include/raknet/LinkedList.h
+include/raknet/MTUSize.h
+include/raknet/Multiplayer.h
+include/raknet/NetworkObject.h
+include/raknet/NetworkTypes.h
+include/raknet/PacketEnumerations.h
+include/raknet/PacketPool.h
+include/raknet/PacketPriority.h
+include/raknet/Queue.h
+include/raknet/QueueLinkedList.h
+include/raknet/RPCNode.h
+include/raknet/RSACrypt.h
+include/raknet/RakClient.h
+include/raknet/RakClientInterface.h
+include/raknet/RakNetStatistics.h
+include/raknet/RakNetworkFactory.h
+include/raknet/RakPeer.h
+include/raknet/RakPeerInterface.h
+include/raknet/RakServer.h
+include/raknet/RakServerInterface.h
+include/raknet/RakVoice/RakVoice.h
+include/raknet/RakVoice/RakVoiceFactory.h
+include/raknet/RakVoice/RakVoiceInterface.h
+include/raknet/Rand.h
+include/raknet/ReliabilityLayer.h
+include/raknet/SHA1.h
+include/raknet/SimpleMutex.h
+include/raknet/SocketLayer.h
+include/raknet/StringCompressor.h
+include/raknet/Types.h
+lib/libraknet.so
+lib/libraknet.so.0
+lib/libraknet.so.2.0.13
+lib/librakvoice.so
+lib/librakvoice.so.0
+lib/librakvoice.so.2.0.13
+@dirrm include/raknet/RakVoice
+@dirrm include/raknet/Autopatcher
+@dirrm include/raknet