aboutsummaryrefslogtreecommitdiff
path: root/devel/readline
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-07-22 07:17:14 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-07-22 07:17:14 +0000
commit2417959a47e64408078365b01ec7e9448c793e7e (patch)
treecf27974ca01c077ce38705346c63509e0fca82b9 /devel/readline
parent45126112845a552e34ad922e78dfe4bddbe8b39c (diff)
downloadports-2417959a47e64408078365b01ec7e9448c793e7e.tar.gz
ports-2417959a47e64408078365b01ec7e9448c793e7e.zip
- Fix segfault reported in PR ports/61297 through almost-vendor-patch:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=98229 - Bump PORTREVISION PR: ports/69352 Submitted by: Frank J. Laszlo (maintainer), Dan Langille (testing)
Notes
Notes: svn path=/head/; revision=114407
Diffstat (limited to 'devel/readline')
-rw-r--r--devel/readline/Makefile1
-rw-r--r--devel/readline/files/patch-aa16
2 files changed, 17 insertions, 0 deletions
diff --git a/devel/readline/Makefile b/devel/readline/Makefile
index 501e9516ba96..d355889f4cd8 100644
--- a/devel/readline/Makefile
+++ b/devel/readline/Makefile
@@ -7,6 +7,7 @@
PORTNAME= readline
PORTVERSION= 4.3
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ftp://ftp.cwru.edu/pub/bash/
diff --git a/devel/readline/files/patch-aa b/devel/readline/files/patch-aa
new file mode 100644
index 000000000000..e47b8813ff5d
--- /dev/null
+++ b/devel/readline/files/patch-aa
@@ -0,0 +1,16 @@
+*** ../readline-4.3/bind.c Thu Jan 24 11:15:52 2002
+--- bind.c Wed Jul 31 09:11:18 2002
+***************
+*** 312,316 ****
+ and the function bound to `a' to be executed when the user
+ types `abx', leaving `bx' in the input queue. */
+! if (k.function /* && k.type == ISFUNC */)
+ {
+ map[ANYOTHERKEY] = k;
+--- 312,316 ----
+ and the function bound to `a' to be executed when the user
+ types `abx', leaving `bx' in the input queue. */
+! if (k.function && ((k.type == ISFUNC && k.function != rl_do_lowercase_version) || k.type == ISMACR))
+ {
+ map[ANYOTHERKEY] = k;
+