aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-gnustep/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-10-12 19:58:33 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-10-12 19:58:33 +0000
commit247c44563f9b2f0ce81b96b460fc33c3315991cd (patch)
treed5e414c63f5d34537bdfe15f0d1392b2923bd871 /devel/ruby-gnustep/Makefile
parent339ecfa601738c8c0e805c793f72e152f4fb9f91 (diff)
downloadports-247c44563f9b2f0ce81b96b460fc33c3315991cd.tar.gz
ports-247c44563f9b2f0ce81b96b460fc33c3315991cd.zip
Update to 0.2.1.
Notes
Notes: svn path=/head/; revision=48717
Diffstat (limited to 'devel/ruby-gnustep/Makefile')
-rw-r--r--devel/ruby-gnustep/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/devel/ruby-gnustep/Makefile b/devel/ruby-gnustep/Makefile
index 7d03a60c3596..0e3aa15f9ba5 100644
--- a/devel/ruby-gnustep/Makefile
+++ b/devel/ruby-gnustep/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnustep
-PORTVERSION= 0.2.0
+PORTVERSION= 0.2.1
CATEGORIES= devel ruby
MASTER_SITES= ftp://ftp.gnustep.org/pub/gnustep/libs/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -16,6 +16,11 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
+BUILD_DEPENDS= ${GNUSTEP_PREFIX}/System/Makefiles/GNUstep.sh:${PORTSDIR}/devel/gnustep-make \
+ ${SYSLIBDIR}/libobjc.so:${PORTSDIR}/lang/gnustep-objc \
+ ${COMBOLIBDIR}/libgnustep-base.so:${PORTSDIR}/lang/gnustep-base \
+ ${COMBOLIBDIR}/libgnustep-gui.so:${PORTSDIR}/x11-toolkits/gnustep-gui \
+ ${XGPSBUNDLEDIR}/libgnustep-xgps:${PORTSDIR}/x11-toolkits/gnustep-xgps
RUN_DEPENDS= ${GNUSTEP_PREFIX}/System/Makefiles/GNUstep.sh:${PORTSDIR}/devel/gnustep-make \
${SYSLIBDIR}/libobjc.so:${PORTSDIR}/lang/gnustep-objc \
${COMBOLIBDIR}/libgnustep-base.so:${PORTSDIR}/lang/gnustep-base \
@@ -51,6 +56,9 @@ MAKE_ENV= GNUSTEP_LOCAL_ROOT=${GNUSTEP_LOCAL_ROOT} \
PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L}
NO_FILTER_SHLIBS= yes
+post-extract:
+ find ${WRKSRC}/ -type f -name '.cvsignore' -delete
+
post-patch:
${RUBY} -i~ -pe 'gsub(/-lpthread/, "-pthread")' ${WRKSRC}/Source/${MAKEFILE}
find ${WRKSRC}/ -type f | xargs ${RUBY} -i -pe 'gsub(/ ruby -/, " ${RUBY} -")'