aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-inline
diff options
context:
space:
mode:
authorSean Chittenden <seanc@FreeBSD.org>2003-01-31 05:57:06 +0000
committerSean Chittenden <seanc@FreeBSD.org>2003-01-31 05:57:06 +0000
commit94c388aebb9151e050ffa11d2edfe14aeb28060e (patch)
treed5ebca6f109063666509ffe9af52b53c33edd497 /devel/ruby-inline
parentf78bea0816cf54b9f86127b1f8e2d37fe6039fec (diff)
downloadports-94c388aebb9151e050ffa11d2edfe14aeb28060e.tar.gz
ports-94c388aebb9151e050ffa11d2edfe14aeb28060e.zip
Add Perl's Inline::C counterpart for Ruby, named oddly enough: Inline::C
Notes
Notes: svn path=/head/; revision=74328
Diffstat (limited to 'devel/ruby-inline')
-rw-r--r--devel/ruby-inline/Makefile36
-rw-r--r--devel/ruby-inline/distinfo1
-rw-r--r--devel/ruby-inline/pkg-comment1
-rw-r--r--devel/ruby-inline/pkg-descr11
-rw-r--r--devel/ruby-inline/pkg-plist7
5 files changed, 56 insertions, 0 deletions
diff --git a/devel/ruby-inline/Makefile b/devel/ruby-inline/Makefile
new file mode 100644
index 000000000000..9970e51cb54e
--- /dev/null
+++ b/devel/ruby-inline/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: ruby-inline
+# Date created: 2003-01-30
+# Whom: Sean Chittenden <seanc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= inline
+PORTVERSION= 2.2.0
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ruby${PORTNAME}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= RubyInline-${PORTVERSION}
+DIST_SUBDIR= devel ruby
+
+MAINTAINER= seanc@FreeBSD.org
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+DOCS= README.txt
+EXAMPLES= example.rb tutorial/example1.rb tutorial/example2.rb
+
+post-install:
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}
+.endfor
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-inline/distinfo b/devel/ruby-inline/distinfo
new file mode 100644
index 000000000000..68a309035ec7
--- /dev/null
+++ b/devel/ruby-inline/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/RubyInline-2.2.0.tar.gz) = f2c8184b7c0511723bfb94c8fe42ceb2
diff --git a/devel/ruby-inline/pkg-comment b/devel/ruby-inline/pkg-comment
new file mode 100644
index 000000000000..f3c86c8a0d00
--- /dev/null
+++ b/devel/ruby-inline/pkg-comment
@@ -0,0 +1 @@
+Inline::C allows you to embed C/Ruby directly in ruby scripts
diff --git a/devel/ruby-inline/pkg-descr b/devel/ruby-inline/pkg-descr
new file mode 100644
index 000000000000..78257e6966b6
--- /dev/null
+++ b/devel/ruby-inline/pkg-descr
@@ -0,0 +1,11 @@
+Inline::C allows for quick and use of inlined C code in Ruby scripts.
+This library automatically:
+
+* provides rudimentary automatic conversion between Ruby and C basic
+ types: (unsigned)? (char|int|long|char *)
+* provides compilation of inline code
+* only recompiles if the C code has changed
+* can easily provide speedups in excess of 25x for tight loops when
+ objects are being recycled too quickly.
+
+WWW: http://sourceforge.net/projects/rubyinline
diff --git a/devel/ruby-inline/pkg-plist b/devel/ruby-inline/pkg-plist
new file mode 100644
index 000000000000..42a5570d1a21
--- /dev/null
+++ b/devel/ruby-inline/pkg-plist
@@ -0,0 +1,7 @@
+%%RUBY_SITELIBDIR%%/inline.rb
+%%RUBY_MODDOCDIR%%/README.txt
+@dirrm %%RUBY_MODDOCDIR%%
+%%RUBY_MODEXAMPLESDIR%%/example.rb
+%%RUBY_MODEXAMPLESDIR%%/example1.rb
+%%RUBY_MODEXAMPLESDIR%%/example2.rb
+@dirrm %%RUBY_MODEXAMPLESDIR%%