aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-sdl/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-03-26 16:47:08 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-03-26 16:47:08 +0000
commitc178b6f17cb88cca28fd34437a227ce03178b05c (patch)
treedeb13349e5c8972cd5b36e0d46c55d4823cfc75c /devel/ruby-sdl/Makefile
parent4dfb242cdbcd98d52f7b26b132295d8333bf8817 (diff)
downloadports-c178b6f17cb88cca28fd34437a227ce03178b05c.tar.gz
ports-c178b6f17cb88cca28fd34437a227ce03178b05c.zip
Add ruby-sdl, a Ruby extension library to use SDL library. Currently
3D features are unsupported. SGE support will be enabled after SGE is ported.
Notes
Notes: svn path=/head/; revision=40401
Diffstat (limited to 'devel/ruby-sdl/Makefile')
-rw-r--r--devel/ruby-sdl/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/ruby-sdl/Makefile b/devel/ruby-sdl/Makefile
new file mode 100644
index 000000000000..a1d67870f231
--- /dev/null
+++ b/devel/ruby-sdl/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: Ruby/SDL
+# Date created: 27 Mar 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdl
+PORTVERSION= 0.3
+CATEGORIES= devel graphics audio ruby
+MASTER_SITES= http://www.kmc.kyoto-u.ac.jp/~ohai/rubysdl/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= SDL-1.1.3:${PORTSDIR}/devel/sdl-devel \
+ SDL_image.10:${PORTSDIR}/graphics/sdl_image \
+ SDL_ttf.2:${PORTSDIR}/graphics/sdl_ttf \
+ SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+CONFIGURE_ARGS= --with-sdl-config="sdl11-config"
+INSTALL_TARGET= site-install
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}/ja
+ ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_DOCDIR}/${PORTNAME}/ja/
+.endif
+
+.include <bsd.port.mk>