aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-deeptest/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-04-08 19:40:13 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-04-08 19:40:13 +0000
commit16993800684ba41a1ec3e1fa9d77af387d9ccc49 (patch)
treec0c3451285c4a8754ad9f3554eee4ab41268247d /devel/rubygem-deeptest/Makefile
parent02aceb55557ac179cde83fe7743314009b061c7d (diff)
downloadports-16993800684ba41a1ec3e1fa9d77af387d9ccc49.tar.gz
ports-16993800684ba41a1ec3e1fa9d77af387d9ccc49.zip
DeepTest enables tests to run in parallel using multiple processes. Processes
may spawned locally to take advantage of multiple processors on a single machine or distributed across many machines to take advantage of distributed processing. Sponsored by: RideCharge Inc.
Notes
Notes: svn path=/head/; revision=231897
Diffstat (limited to 'devel/rubygem-deeptest/Makefile')
-rw-r--r--devel/rubygem-deeptest/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/devel/rubygem-deeptest/Makefile b/devel/rubygem-deeptest/Makefile
new file mode 100644
index 000000000000..36211aa817e4
--- /dev/null
+++ b/devel/rubygem-deeptest/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: rubygem-deeptest
+# Date created: 7 April 2009
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= deep_test
+PORTVERSION= 1.2.2
+CATEGORIES= devel rubygems
+MASTER_SITES= RF
+MASTER_SITE_SUBDIR= deep-test
+
+MAINTAINER= pgollucci@FreeBSD.org
+COMMENT= Enable tests to run in parallel using multiple processes
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+PLIST_FILES= bin/deep_test
+
+.include <bsd.port.mk>