aboutsummaryrefslogtreecommitdiff
path: root/devel/sdl_sge
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
commit29747f458a1eb2ce23b4594b09d0256dd62760b8 (patch)
tree1b71ba5d9ffdd308b6c18130f7c116f5bab5dc12 /devel/sdl_sge
parent7aad84f808b93baa6a7077ce0b47573b9c4c79a0 (diff)
downloadports-29747f458a1eb2ce23b4594b09d0256dd62760b8.tar.gz
ports-29747f458a1eb2ce23b4594b09d0256dd62760b8.zip
Chase the GNOME X11BASE to LOCALBASE move, and fix the build with the
new freetype2 where needed. Submitted by: mezz, ahze, pav, and many others Approved by: portmgr (implicit, kris)
Notes
Notes: svn path=/head/; revision=175261
Diffstat (limited to 'devel/sdl_sge')
-rw-r--r--devel/sdl_sge/Makefile2
-rw-r--r--devel/sdl_sge/files/patch-sge030809-sge_tt_text.cpp19
2 files changed, 15 insertions, 6 deletions
diff --git a/devel/sdl_sge/Makefile b/devel/sdl_sge/Makefile
index aec069a8d0aa..f2673b557e36 100644
--- a/devel/sdl_sge/Makefile
+++ b/devel/sdl_sge/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sge
PORTVERSION= 0.030809
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel graphics
MASTER_SITES= http://www.etek.chalmers.se/~e8cal1/sge/files/ \
http://www.digitalfanatics.org/cal/sge/files/
diff --git a/devel/sdl_sge/files/patch-sge030809-sge_tt_text.cpp b/devel/sdl_sge/files/patch-sge030809-sge_tt_text.cpp
index 44571a375c9f..83cff497cf45 100644
--- a/devel/sdl_sge/files/patch-sge030809-sge_tt_text.cpp
+++ b/devel/sdl_sge/files/patch-sge030809-sge_tt_text.cpp
@@ -1,17 +1,26 @@
-diff -ur sge030809_orig/sge_tt_text.cpp sge030809/sge_tt_text.cpp
---- sge030809_orig/sge_tt_text.cpp Fri Aug 8 14:48:08 2003
-+++ sge_tt_text.cpp Sun Jul 30 20:49:29 2006
-@@ -36,9 +36,10 @@
+--- sge_tt_text.cpp.orig Fri Aug 8 08:48:08 2003
++++ sge_tt_text.cpp Wed Oct 4 11:43:47 2006
+@@ -36,10 +36,10 @@
#include "sge_textpp.h"
#ifndef _SGE_NOTTF
-#include <freetype/freetype.h>
-#include <freetype/ftoutln.h>
-#include <freetype/ttnameid.h>
+-#include <freetype/internal/ftobjs.h>
+#include <ft2build.h>
+#include FT_FREETYPE_H
+#include FT_OUTLINE_H
+#include FT_TRUETYPE_IDS_H
- #include <freetype/internal/ftobjs.h>
/* The structure used to hold glyph information (cached) */
+ struct glyph {
+@@ -294,7 +294,7 @@
+ }
+ memset(stream, 0, sizeof(*stream));
+
+- stream->memory = _sge_library->memory;
++ stream->memory = NULL;
+ stream->read = RWread;
+ stream->descriptor.pointer = src;
+ stream->pos = (unsigned long)position;