aboutsummaryrefslogtreecommitdiff
path: root/devel/sdl_sge
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2006-08-07 07:02:42 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2006-08-07 07:02:42 +0000
commit290f6233936d7ad0c9d7a892ac53a821ba4fd2b8 (patch)
tree2e4daeacf650f5414eb9291c4a16d0c070a1ba83 /devel/sdl_sge
parentdd838bc33707917a973b5c50f9d9d5e7d313c2ad (diff)
downloadports-290f6233936d7ad0c9d7a892ac53a821ba4fd2b8.tar.gz
ports-290f6233936d7ad0c9d7a892ac53a821ba4fd2b8.zip
Add sge 0.030809, a graphic library for the Simple DirectMedia Layer
(SDL). PR: ports/101364 Submitted by: Jona Joachim <walkingshadow at grummel.net>
Notes
Notes: svn path=/head/; revision=169911
Diffstat (limited to 'devel/sdl_sge')
-rw-r--r--devel/sdl_sge/Makefile65
-rw-r--r--devel/sdl_sge/distinfo3
-rw-r--r--devel/sdl_sge/files/patch-Makefile29
-rw-r--r--devel/sdl_sge/files/patch-Makefile.conf63
-rw-r--r--devel/sdl_sge/files/patch-sge030809-sge_tt_text.cpp17
-rw-r--r--devel/sdl_sge/pkg-descr14
-rw-r--r--devel/sdl_sge/pkg-plist64
7 files changed, 255 insertions, 0 deletions
diff --git a/devel/sdl_sge/Makefile b/devel/sdl_sge/Makefile
new file mode 100644
index 000000000000..be21b6ba7707
--- /dev/null
+++ b/devel/sdl_sge/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: SGE
+# Date created: 30 July 2006
+# Whom: Jona Joachim <walkingshadow@grummel.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sge
+PORTVERSION= 0.030809
+CATEGORIES= devel graphics
+MASTER_SITES= http://www.etek.chalmers.se/~e8cal1/sge/files/ \
+ http://www.digitalfanatics.org/cal/sge/files/
+DISTNAME= ${PORTNAME}030809
+
+MAINTAINER= walkingshadow@grummel.net
+COMMENT= A graphic library for the Simple DirectMedia Layer (SDL)
+
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+NO_FILTER_SHLIBS= yes
+
+OPTIONS= SDL_IMAGE "Enable support for SDL_IMAGE" On \
+ FREETYPE "Enable FreeType support" On \
+ DOCS "Install documentation" Off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_FREETYPE)
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+.endif
+
+.if defined(WITHOUT_SDL_IMAGE)
+USE_SDL= sdl
+.else
+USE_SDL= image
+.endif
+
+.if !defined(WITH_DOCS)
+NOPORTDOCS= yes
+.endif
+
+post-patch:
+.if defined(WITHOUT_SDL_IMAGE)
+ @${REINPLACE_CMD} -e 's|#USE_IMG = n|USE_IMG = n|g' ${WRKSRC}/Makefile.conf
+.else
+ @${REINPLACE_CMD} -e 's|#USE_IMG = n|USE_IMG = y|g' ${WRKSRC}/Makefile.conf
+.endif
+.if defined(WITHOUT_FREETYPE)
+ @${REINPLACE_CMD} -e 's|#USE_FT = n|USE_FT = n|g' ${WRKSRC}/Makefile.conf
+.else
+ @${REINPLACE_CMD} -e 's|#USE_FT = n|USE_FT = y|g' ${WRKSRC}/Makefile.conf
+.endif
+ @${REINPLACE_CMD} -e 's|PREFIX =PREFIX|PREFIX =${PREFIX}|g' ${WRKSRC}/Makefile.conf
+ @${REINPLACE_CMD} -e 's|PREFIX_H =PREFIX_H|PREFIX_H =${PREFIX}/include/SDL11|g' ${WRKSRC}/Makefile.conf
+ @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|g' ${WRKSRC}/Makefile.conf
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/docs/* ${DOCSDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_MAN} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/sdl_sge/distinfo b/devel/sdl_sge/distinfo
new file mode 100644
index 000000000000..82f6b2e9cd41
--- /dev/null
+++ b/devel/sdl_sge/distinfo
@@ -0,0 +1,3 @@
+MD5 (sge030809.tar.gz) = a76975665b6a2bf189130fa2c8821caf
+SHA256 (sge030809.tar.gz) = 25cfbe59ab99647254e69d25984707045492c2a5d1b15f27d999d0284a7110fc
+SIZE (sge030809.tar.gz) = 251698
diff --git a/devel/sdl_sge/files/patch-Makefile b/devel/sdl_sge/files/patch-Makefile
new file mode 100644
index 000000000000..9089803403f0
--- /dev/null
+++ b/devel/sdl_sge/files/patch-Makefile
@@ -0,0 +1,29 @@
+--- work/sge030809/Makefile Tue Aug 12 00:40:41 2003
++++ Makefile Fri Aug 4 15:28:10 2006
+@@ -12,16 +12,11 @@
+
+ all: config $(OBJECTS)
+ @ar rsc libSGE.a $(OBJECTS)
++ $(CXX) $(CFLAGS) -Wl,-soname,libSGE.so.$(API_VER) -fpic -fPIC -shared -o libSGE.so $(OBJECTS) $(LIBS)
+
+ $(OBJECTS): %.o:%.cpp %.h #Each object depends on thier .cpp and .h file
+ $(CXX) $(CFLAGS) -c $<
+
+-shared: all
+- $(CXX) $(CFLAGS) -Wl,-soname,libSGE.so.$(API_VER) -fpic -fPIC -shared -o libSGE.so $(OBJECTS) $(LIBS)
+-
+-shared-strip: shared
+- @strip libSGE.so
+-
+ # Building a dll... I have no idea how to do this, but it should be something like below.
+ dll: config $(OBJECTS)
+ dlltool --output-def SGE.def $(OBJECTS)
+@@ -70,7 +65,7 @@
+ @echo ""
+ endif
+
+-install: shared
++install:
+ @mkdir -p $(PREFIX_H)
+ install -c -m 644 sge*.h $(PREFIX_H)
+ @mkdir -p $(PREFIX)/lib
diff --git a/devel/sdl_sge/files/patch-Makefile.conf b/devel/sdl_sge/files/patch-Makefile.conf
new file mode 100644
index 000000000000..cbe111883a44
--- /dev/null
+++ b/devel/sdl_sge/files/patch-Makefile.conf
@@ -0,0 +1,63 @@
+--- work/sge030809/Makefile.conf Tue Aug 12 00:43:35 2003
++++ Makefile.conf Fri Aug 4 15:20:41 2006
+@@ -7,11 +7,6 @@
+ #USE_IMG = n
+ #QUIET = y
+
+-
+-# Compilers (C and C++)
+-CC=gcc
+-CXX=g++
+-
+ # Make sure sdl-config is available
+ HAVE_SDL =$(shell if (sdl-config --version) < /dev/null > /dev/null 2>&1; then echo "y"; else echo "n"; fi;)
+ ifeq ($(HAVE_SDL),n)
+@@ -19,45 +14,24 @@
+ endif
+
+ # Where should SGE be installed?
+-PREFIX =$(shell sdl-config --prefix)
++PREFIX =PREFIX
+
+ # Where should the headerfiles be installed?
+-PREFIX_H =$(shell sdl-config --prefix)/include/SDL
++PREFIX_H =PREFIX_H
+
+ # Flags passed to the compiler
+-CFLAGS =-Wall -O3 -ffast-math
++CFLAGS +=-Wall -O3 -ffast-math
+ SGE_CFLAGS =$(shell sdl-config --cflags)
+-# Uncomment to make some more optimizations
+-#CFLAGS =-Wall -O9 -ffast-math -march=i686
+-
+
+ # Libs config
+ SGE_LIBS =$(shell sdl-config --libs) -lstdc++
+
+-
+-# Is freetype-config available?
+-HAVE_FT =$(shell if (freetype-config --version) < /dev/null > /dev/null 2>&1; then echo "y"; else echo "n"; fi;)
+-ifeq ($(HAVE_FT),n)
+- USE_FT = n
+-endif
+-
+ ifneq ($(USE_FT),n)
+ USE_FT = y
+ SGE_LIBS +=$(shell freetype-config --libs)
+ FT_CFLAGS =$(shell freetype-config --cflags)
+ endif
+
+-
+-# Is SDL_image available?
+-HAVE_IMG =$(shell if test -e "`sdl-config --prefix`/include/SDL/SDL_image.h" >/dev/null 2>&1; then echo "y"; else echo "n"; fi;)
+-
+-ifneq ($(USE_IMG),y)
+- ifneq ($(USE_IMG),n)
+- USE_IMG =$(HAVE_IMG)
+- endif
+-endif
+-
+ ifeq ($(USE_IMG),y)
+ SGE_LIBS +=-lSDL_image
+ endif
+-
diff --git a/devel/sdl_sge/files/patch-sge030809-sge_tt_text.cpp b/devel/sdl_sge/files/patch-sge030809-sge_tt_text.cpp
new file mode 100644
index 000000000000..44571a375c9f
--- /dev/null
+++ b/devel/sdl_sge/files/patch-sge030809-sge_tt_text.cpp
@@ -0,0 +1,17 @@
+diff -ur sge030809_orig/sge_tt_text.cpp sge030809/sge_tt_text.cpp
+--- sge030809_orig/sge_tt_text.cpp Fri Aug 8 14:48:08 2003
++++ sge_tt_text.cpp Sun Jul 30 20:49:29 2006
+@@ -36,9 +36,10 @@
+ #include "sge_textpp.h"
+
+ #ifndef _SGE_NOTTF
+-#include <freetype/freetype.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/ttnameid.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
++#include FT_OUTLINE_H
++#include FT_TRUETYPE_IDS_H
+ #include <freetype/internal/ftobjs.h>
+
+ /* The structure used to hold glyph information (cached) */
diff --git a/devel/sdl_sge/pkg-descr b/devel/sdl_sge/pkg-descr
new file mode 100644
index 000000000000..a4b2e117d237
--- /dev/null
+++ b/devel/sdl_sge/pkg-descr
@@ -0,0 +1,14 @@
+SGE is a graphic library for the Simple DirectMedia Layer (SDL) library.
+Some of SGE:s features are:
+ -Pixel operations
+ -Clipping
+ -Lines, circles and other figures (with antialiasing and alpha blending)
+ -Rotation and scaling of surfaces
+ -Palette functions
+ -TrueType/Bitmap/SFont font functions
+ -Basic 2D collision detection
+ -Sprite classes
+ -Basic texture mapping
+ -Filled and gourand shaded polygons (with antialiasing or alpha blending)
+
+WWW: http://www.etek.chalmers.se/~e8cal1/sge/
diff --git a/devel/sdl_sge/pkg-plist b/devel/sdl_sge/pkg-plist
new file mode 100644
index 000000000000..43f4391742c4
--- /dev/null
+++ b/devel/sdl_sge/pkg-plist
@@ -0,0 +1,64 @@
+include/SDL11/sge.h
+include/SDL11/sge_blib.h
+include/SDL11/sge_bm_text.h
+include/SDL11/sge_collision.h
+include/SDL11/sge_config.h
+include/SDL11/sge_internal.h
+include/SDL11/sge_misc.h
+include/SDL11/sge_primitives.h
+include/SDL11/sge_rotation.h
+include/SDL11/sge_shape.h
+include/SDL11/sge_surface.h
+include/SDL11/sge_textpp.h
+include/SDL11/sge_tt_text.h
+lib/libSGE.a
+lib/libSGE.so
+lib/libSGE.so.0
+lib/libSGE.so.0.030809
+%%PORTDOCS%%%%DOCSDIR%%/blib.html
+%%PORTDOCS%%%%DOCSDIR%%/bmf.html
+%%PORTDOCS%%%%DOCSDIR%%/collision.html
+%%PORTDOCS%%%%DOCSDIR%%/color.html
+%%PORTDOCS%%%%DOCSDIR%%/figures.html
+%%PORTDOCS%%%%DOCSDIR%%/guide.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/intro.html
+%%PORTDOCS%%%%DOCSDIR%%/macros.html
+%%PORTDOCS%%%%DOCSDIR%%/misc.html
+%%PORTDOCS%%%%DOCSDIR%%/pixels.html
+%%PORTDOCS%%%%DOCSDIR%%/rotate.html
+%%PORTDOCS%%%%DOCSDIR%%/shape.html
+%%PORTDOCS%%%%DOCSDIR%%/surface.html
+%%PORTDOCS%%%%DOCSDIR%%/text_classes.html
+%%PORTDOCS%%%%DOCSDIR%%/thanks.html
+%%PORTDOCS%%%%DOCSDIR%%/toc.html
+%%PORTDOCS%%%%DOCSDIR%%/ttf-input.html
+%%PORTDOCS%%%%DOCSDIR%%/ttf-output.html
+%%PORTDOCS%%%%DOCSDIR%%/ttf.html
+%%PORTDOCS%%%%EXAMPLESDIR%%/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/alpha.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/basics.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/basics_c.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/bitmapfont.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/blib.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/blitting.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/collision.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/fire.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/font.bmp
+%%PORTDOCS%%%%EXAMPLESDIR%%/font.ttf
+%%PORTDOCS%%%%EXAMPLESDIR%%/input.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/inputdeluxe.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/poly.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/rotate.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/sfont.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/sfont.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/smiley.bmp
+%%PORTDOCS%%%%EXAMPLESDIR%%/speedtest.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/sprite.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/sprite2.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/ttf_readme
+%%PORTDOCS%%%%EXAMPLESDIR%%/tux.bmp
+@dirrmtry include/SDL11
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%