aboutsummaryrefslogtreecommitdiff
path: root/devel/sfslite/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 00:41:11 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 00:41:11 +0000
commitec7c5b0142aeb3539337db2d501d7b5ecf5e7284 (patch)
tree8468e5b0da1375397af63a69b7076d0b05b24887 /devel/sfslite/Makefile
parente74f1f2ba2a728af887a83b377b13746054b76e5 (diff)
downloadports-ec7c5b0142aeb3539337db2d501d7b5ecf5e7284.tar.gz
ports-ec7c5b0142aeb3539337db2d501d7b5ecf5e7284.zip
Remove always-false/true conditions based on OSVERSION 500000
Notes
Notes: svn path=/head/; revision=200770
Diffstat (limited to 'devel/sfslite/Makefile')
-rw-r--r--devel/sfslite/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/devel/sfslite/Makefile b/devel/sfslite/Makefile
index 9f6ed0376240..dedaa0ed1667 100644
--- a/devel/sfslite/Makefile
+++ b/devel/sfslite/Makefile
@@ -13,6 +13,10 @@ MASTER_SITES= http://dist.okws.org/dist/
MAINTAINER= ports@okws.org
COMMENT= Standard version of the sfslite library
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+
+CONFIGURE_ARGS= --with-gmp=${LOCALBASE}
+
GNU_CONFIGURE= yes
USE_GMAKE= yes
#
@@ -20,15 +24,6 @@ USE_GMAKE= yes
#
USE_BISON= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 500000
-LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
-CONFIGURE_ARGS+=--with-gmp=${LOCALBASE}
-.else
-CONFIGURE_ARGS+=--with-gmp=/usr
-.endif
-
#
# Map X.Y.Z.Q => X.Y
#
@@ -68,4 +63,4 @@ PKG_INSTALL?= pkg-install
pre-install:
PKG_PREFIX=${PREFIX} ${SH} ${PKG_INSTALL} ${PKGNAME} PRE-INSTALL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>