aboutsummaryrefslogtreecommitdiff
path: root/devel/simulavr
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2004-03-12 21:10:58 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2004-03-12 21:10:58 +0000
commitb95a6324cc26254431f20673798044a9054eeb0d (patch)
tree56f5e790db4416a7eea8c020d84ef46fcf405592 /devel/simulavr
parentd9cac68a9eddc2ddbbf11fdcc06865409d9609f4 (diff)
downloadports-b95a6324cc26254431f20673798044a9054eeb0d.tar.gz
ports-b95a6324cc26254431f20673798044a9054eeb0d.zip
Remove `inline' from a function gcc 2.95 (in FreeBSD 4.x) warns that
it cannot inline it. This caused the port build in FreeBSD 4.x to break due to -Werror. Submitted by: Theodore A. Roth <troth@openavr.org>
Notes
Notes: svn path=/head/; revision=103816
Diffstat (limited to 'devel/simulavr')
-rw-r--r--devel/simulavr/Makefile1
-rw-r--r--devel/simulavr/files/patch-sim-no-vcd-inline38
2 files changed, 39 insertions, 0 deletions
diff --git a/devel/simulavr/Makefile b/devel/simulavr/Makefile
index a59c55484a2f..12e71b26b1d8 100644
--- a/devel/simulavr/Makefile
+++ b/devel/simulavr/Makefile
@@ -7,6 +7,7 @@
PORTNAME= simulavr
PORTVERSION= 0.1.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/devel/simulavr/files/patch-sim-no-vcd-inline b/devel/simulavr/files/patch-sim-no-vcd-inline
new file mode 100644
index 000000000000..cd62e62206e6
--- /dev/null
+++ b/devel/simulavr/files/patch-sim-no-vcd-inline
@@ -0,0 +1,38 @@
+2004-03-11 Theodore A. Roth <troth@openavr.org>
+
+ * src/disp-vcd/vcd.c:
+ * src/disp-vcd/vcd.h:
+ Don't inline vcd_set_clock.
+
+Index: src/disp-vcd/vcd.c
+===================================================================
+RCS file: /cvsroot/simulavr/simulavr/src/disp-vcd/vcd.c,v
+retrieving revision 1.3
+diff -u -p -p -r1.3 vcd.c
+--- src/disp-vcd/vcd.c 1 Dec 2003 05:48:35 -0000 1.3
++++ src/disp-vcd/vcd.c 11 Mar 2004 18:56:24 -0000
+@@ -696,7 +696,7 @@ vcd_write_pc (int pc)
+
+ /* Set the current time. */
+
+-inline int
++int
+ vcd_set_clock (unsigned int c)
+ {
+ clk = c;
+Index: src/disp-vcd/vcd.h
+===================================================================
+RCS file: /cvsroot/simulavr/simulavr/src/disp-vcd/vcd.h,v
+retrieving revision 1.2
+diff -u -p -p -r1.2 vcd.h
+--- src/disp-vcd/vcd.h 17 Nov 2002 00:29:20 -0000 1.2
++++ src/disp-vcd/vcd.h 11 Mar 2004 18:56:24 -0000
+@@ -47,7 +47,7 @@ int vcd_trace_pc( void );
+ /* Interface for disp.c */
+ int vcd_write_header( void );
+
+-inline int vcd_set_clock( unsigned int c );
++int vcd_set_clock( unsigned int c );
+ int vcd_write_clock( void );
+
+ int vcd_bind_io_reg_shortcut( char *io_reg_name, int io_reg_addr );