aboutsummaryrefslogtreecommitdiff
path: root/devel/spatialindex
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-20 13:20:47 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-20 13:20:47 +0000
commit3ab06a3b26bc4c281d30fa675466f3d65a02cf40 (patch)
treea9e59358be0125c4471e75cdf4a469a86a0b40e4 /devel/spatialindex
parent94dc678c5feb8de72225b8fcd244c59c85a85b6c (diff)
downloadports-3ab06a3b26bc4c281d30fa675466f3d65a02cf40.tar.gz
ports-3ab06a3b26bc4c281d30fa675466f3d65a02cf40.zip
This package provides a general framework for developing spatial indices.
Currently it defines generic interfaces, provides simple main memory and disk based storage managers and a robust implementation of an R*-tree, an MVR-tree and a TPR-tree. Supported Features: * Generic main memory and disk based storage managers. * R*-tree index (also supports linear and quadratic splitting). * MVR-tree index (a.k.a. PPR-tree). * TPR-tree index. * Advanced query capabilities, using Strategy and Visitor patterns. * Arbitrary shaped range queries, by defining generic geometry interfaces. * Large parameterization capabilities, including dimensionality, fill factor, node capacity, etc. * STR packing / bulk loading. WWW: http://trac.gispython.org/projects/SpatialIndex/wiki PR: ports/124628 Submitted by: Wen Heping <wenheping at gmail.com>
Notes
Notes: svn path=/head/; revision=215346
Diffstat (limited to 'devel/spatialindex')
-rw-r--r--devel/spatialindex/Makefile22
-rw-r--r--devel/spatialindex/distinfo3
-rw-r--r--devel/spatialindex/pkg-descr17
-rw-r--r--devel/spatialindex/pkg-plist23
4 files changed, 65 insertions, 0 deletions
diff --git a/devel/spatialindex/Makefile b/devel/spatialindex/Makefile
new file mode 100644
index 000000000000..2ce3ea603994
--- /dev/null
+++ b/devel/spatialindex/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: spatialindex
+# Date created: 15 June 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+# $FreeBSD$
+
+PORTNAME= spatialindex
+PORTVERSION= 1.3.2
+CATEGORIES= devel
+MASTER_SITES= http://www.edu-linux.org/down/
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A General Framework for Developing Spatial Indices
+
+USE_AUTOTOOLS= libtool:15:env
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|\(objformat=\).*|\1elf|' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/devel/spatialindex/distinfo b/devel/spatialindex/distinfo
new file mode 100644
index 000000000000..c4e6e9f546a0
--- /dev/null
+++ b/devel/spatialindex/distinfo
@@ -0,0 +1,3 @@
+MD5 (spatialindex-1.3.2.tar.gz) = 648058d64837779cda5c91f2f3dea74f
+SHA256 (spatialindex-1.3.2.tar.gz) = 4532f91db1a96fbab696620a28361b3beb2c50d1177115dc7288fcef317f2de1
+SIZE (spatialindex-1.3.2.tar.gz) = 467645
diff --git a/devel/spatialindex/pkg-descr b/devel/spatialindex/pkg-descr
new file mode 100644
index 000000000000..d00ed63cf21f
--- /dev/null
+++ b/devel/spatialindex/pkg-descr
@@ -0,0 +1,17 @@
+This package provides a general framework for developing spatial indices.
+Currently it defines generic interfaces, provides simple main memory and
+disk based storage managers and a robust implementation of an R*-tree, an
+MVR-tree and a TPR-tree.
+
+Supported Features:
+ * Generic main memory and disk based storage managers.
+ * R*-tree index (also supports linear and quadratic splitting).
+ * MVR-tree index (a.k.a. PPR-tree).
+ * TPR-tree index.
+ * Advanced query capabilities, using Strategy and Visitor patterns.
+ * Arbitrary shaped range queries, by defining generic geometry interfaces.
+ * Large parameterization capabilities, including dimensionality,
+ fill factor, node capacity, etc.
+ * STR packing / bulk loading.
+
+WWW: http://trac.gispython.org/projects/SpatialIndex/wiki
diff --git a/devel/spatialindex/pkg-plist b/devel/spatialindex/pkg-plist
new file mode 100644
index 000000000000..dbd587686fa8
--- /dev/null
+++ b/devel/spatialindex/pkg-plist
@@ -0,0 +1,23 @@
+include/spatialindex/LineSegment.h
+include/spatialindex/MVRTree.h
+include/spatialindex/MovingPoint.h
+include/spatialindex/MovingRegion.h
+include/spatialindex/Point.h
+include/spatialindex/RTree.h
+include/spatialindex/Region.h
+include/spatialindex/SpatialIndex.h
+include/spatialindex/TPRTree.h
+include/spatialindex/TimePoint.h
+include/spatialindex/TimeRegion.h
+include/spatialindex/tools/PointerPool.h
+include/spatialindex/tools/PoolPointer.h
+include/spatialindex/tools/SmartPointer.h
+include/spatialindex/tools/TemporaryFile.h
+include/spatialindex/tools/Tools.h
+include/spatialindex/tools/rand48.h
+lib/libspatialindex.a
+lib/libspatialindex.la
+lib/libspatialindex.so
+lib/libspatialindex.so.1
+@dirrm include/spatialindex/tools
+@dirrm include/spatialindex