aboutsummaryrefslogtreecommitdiff
path: root/devel/spirit
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-04 10:36:13 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-04 10:36:13 +0000
commit7a7a0b1a561df04ca79d36c7b3b8bc659dc38612 (patch)
treee999b22cc47a64be50f62cecf36a138fe3be57c9 /devel/spirit
parent047dea54fe3a915bcb9ba02d6bf401c0ece82085 (diff)
downloadports-7a7a0b1a561df04ca79d36c7b3b8bc659dc38612.tar.gz
ports-7a7a0b1a561df04ca79d36c7b3b8bc659dc38612.zip
add spirit
An object oriented recursive descent parser generator framework
Notes
Notes: svn path=/head/; revision=49563
Diffstat (limited to 'devel/spirit')
-rw-r--r--devel/spirit/Makefile19
-rw-r--r--devel/spirit/distinfo1
-rw-r--r--devel/spirit/files/patch-libs::doc::Makefile.in11
-rw-r--r--devel/spirit/files/patch-libs::doc::theme::Makefile.in11
-rw-r--r--devel/spirit/pkg-comment1
-rw-r--r--devel/spirit/pkg-descr15
-rw-r--r--devel/spirit/pkg-plist73
7 files changed, 131 insertions, 0 deletions
diff --git a/devel/spirit/Makefile b/devel/spirit/Makefile
new file mode 100644
index 000000000000..bdc19eb6257f
--- /dev/null
+++ b/devel/spirit/Makefile
@@ -0,0 +1,19 @@
+# ex:ts=8
+# New ports collection makefile for: spirit
+# Date created: Nov 4, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= spirit
+PORTVERSION= 1.2.2
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/spirit/distinfo b/devel/spirit/distinfo
new file mode 100644
index 000000000000..3b2ba23aa31a
--- /dev/null
+++ b/devel/spirit/distinfo
@@ -0,0 +1 @@
+MD5 (spirit-1.2.2.tar.gz) = 3d9e3f8cf60e3f534050ad598e215422
diff --git a/devel/spirit/files/patch-libs::doc::Makefile.in b/devel/spirit/files/patch-libs::doc::Makefile.in
new file mode 100644
index 000000000000..f2d7a1e44885
--- /dev/null
+++ b/devel/spirit/files/patch-libs::doc::Makefile.in
@@ -0,0 +1,11 @@
+--- libs/doc/Makefile.in.orig Sun Nov 4 18:11:20 2001
++++ libs/doc/Makefile.in Sun Nov 4 18:11:29 2001
+@@ -64,7 +64,7 @@
+
+ SUBDIRS = theme
+
+-htmldir = $(prefix)/doc/spirit
++htmldir = $(prefix)/share/doc/spirit
+
+ EXTRA_DIST = annotations.html character_sets.html debugging.html directives.html error_handling.html future_directions.html index.html introduction.html iterators_and_parsing.html loops.html numerics.html operators.html parametric_parsers.html primitives.html reference_wrappers.html references.html semantic_actions.html specialized_actions.html symbols.html the_multi_pass.html the_parser.html the_rule.html the_scanner.html wrap_up.html
+
diff --git a/devel/spirit/files/patch-libs::doc::theme::Makefile.in b/devel/spirit/files/patch-libs::doc::theme::Makefile.in
new file mode 100644
index 000000000000..c685e3ef5fb3
--- /dev/null
+++ b/devel/spirit/files/patch-libs::doc::theme::Makefile.in
@@ -0,0 +1,11 @@
+--- libs/doc/theme/Makefile.in.orig Sun Nov 4 18:19:47 2001
++++ libs/doc/theme/Makefile.in Sun Nov 4 18:20:04 2001
+@@ -62,7 +62,7 @@
+ PACKAGE = @PACKAGE@
+ VERSION = @VERSION@
+
+-htmldir = $(prefix)/doc/spirit/theme
++htmldir = $(prefix)/share/doc/spirit/theme
+
+ EXTRA_DIST = bkd.gif bulb.gif bullet.gif gradient.jpg l_arr.gif lens.gif note.gif r_arr.gif spirit_header.jpg u_arr.gif style.css
+
diff --git a/devel/spirit/pkg-comment b/devel/spirit/pkg-comment
new file mode 100644
index 000000000000..efd8d6bfb89b
--- /dev/null
+++ b/devel/spirit/pkg-comment
@@ -0,0 +1 @@
+An object oriented recursive descent parser generator framework
diff --git a/devel/spirit/pkg-descr b/devel/spirit/pkg-descr
new file mode 100644
index 000000000000..35bdb4b904f2
--- /dev/null
+++ b/devel/spirit/pkg-descr
@@ -0,0 +1,15 @@
+Spirit is an object oriented recursive descent parser generator framework
+implemented using template meta-programming techniques. Expression templates
+allow us to approximate the syntax of Extended Backus Normal Form (EBNF)
+completely in C++. Parser objects are composed through operator overloading
+and the result is a backtracking LL(inf) parser that is capable of parsing
+rather ambiguous grammars.
+
+The Spirit framework enables a target grammar to be written exclusively in
+C++. Inline EBNF grammar specifications can mix freely with other C++ code
+and, thanks to the generative power of C++ templates, are immediately
+executable. In retrospect, conventional compiler-compilers or parser-
+generators have to perform an additional translation step from the source
+EBNF code to C or C++ code.
+
+WWW: http://spirit.sourceforge.net/
diff --git a/devel/spirit/pkg-plist b/devel/spirit/pkg-plist
new file mode 100644
index 000000000000..28b70d666593
--- /dev/null
+++ b/devel/spirit/pkg-plist
@@ -0,0 +1,73 @@
+include/spirit/boost/config.hpp
+include/spirit/boost/detail_limits.hpp
+include/spirit/boost/limits.hpp
+include/spirit/boost/multi_pass.hpp
+include/spirit/boost/spirit/actions.hpp
+include/spirit/boost/spirit/chset.hpp
+include/spirit/boost/spirit/composite.hpp
+include/spirit/boost/spirit/debug.hpp
+include/spirit/boost/spirit/directives.hpp
+include/spirit/boost/spirit/exceptions.hpp
+include/spirit/boost/spirit/impl/actions.ipp
+include/spirit/boost/spirit/impl/chset.ipp
+include/spirit/boost/spirit/impl/directives.ipp
+include/spirit/boost/spirit/impl/exceptions.ipp
+include/spirit/boost/spirit/impl/iterators.ipp
+include/spirit/boost/spirit/impl/loops.ipp
+include/spirit/boost/spirit/impl/numerics.ipp
+include/spirit/boost/spirit/impl/operators.ipp
+include/spirit/boost/spirit/impl/parser.ipp
+include/spirit/boost/spirit/impl/primitives.ipp
+include/spirit/boost/spirit/impl/rule.ipp
+include/spirit/boost/spirit/impl/symbols.ipp
+include/spirit/boost/spirit/iterators.hpp
+include/spirit/boost/spirit/loops.hpp
+include/spirit/boost/spirit/numerics.hpp
+include/spirit/boost/spirit/operators.hpp
+include/spirit/boost/spirit/parser.hpp
+include/spirit/boost/spirit/primitives.hpp
+include/spirit/boost/spirit/rule.hpp
+include/spirit/boost/spirit/spirit.hpp
+include/spirit/boost/spirit/spirit_fwd.hpp
+include/spirit/boost/spirit/symbols.hpp
+@dirrm include/spirit/boost/spirit/impl
+@dirrm include/spirit/boost/spirit
+@dirrm include/spirit/boost
+@dirrm include/spirit
+share/doc/spirit/annotations.html
+share/doc/spirit/character_sets.html
+share/doc/spirit/debugging.html
+share/doc/spirit/directives.html
+share/doc/spirit/error_handling.html
+share/doc/spirit/future_directions.html
+share/doc/spirit/index.html
+share/doc/spirit/introduction.html
+share/doc/spirit/iterators_and_parsing.html
+share/doc/spirit/loops.html
+share/doc/spirit/numerics.html
+share/doc/spirit/operators.html
+share/doc/spirit/parametric_parsers.html
+share/doc/spirit/primitives.html
+share/doc/spirit/reference_wrappers.html
+share/doc/spirit/references.html
+share/doc/spirit/semantic_actions.html
+share/doc/spirit/specialized_actions.html
+share/doc/spirit/symbols.html
+share/doc/spirit/the_multi_pass.html
+share/doc/spirit/the_parser.html
+share/doc/spirit/the_rule.html
+share/doc/spirit/the_scanner.html
+share/doc/spirit/theme/bkd.gif
+share/doc/spirit/theme/bulb.gif
+share/doc/spirit/theme/bullet.gif
+share/doc/spirit/theme/gradient.jpg
+share/doc/spirit/theme/l_arr.gif
+share/doc/spirit/theme/lens.gif
+share/doc/spirit/theme/note.gif
+share/doc/spirit/theme/r_arr.gif
+share/doc/spirit/theme/spirit_header.jpg
+share/doc/spirit/theme/style.css
+share/doc/spirit/theme/u_arr.gif
+share/doc/spirit/wrap_up.html
+@dirrm share/doc/spirit/theme
+@dirrm share/doc/spirit