aboutsummaryrefslogtreecommitdiff
path: root/devel/subversion16/Makefile.common
diff options
context:
space:
mode:
authorLev A. Serebryakov <lev@FreeBSD.org>2008-07-08 09:25:16 +0000
committerLev A. Serebryakov <lev@FreeBSD.org>2008-07-08 09:25:16 +0000
commitf2a96f40176f8c8ecc3ff737467a76b46448cea9 (patch)
treee8251d5bead13bbc41eab360cf2cffe0dc4e4e49 /devel/subversion16/Makefile.common
parent62e1e21b6fd42c4f6a9e5ffc80fce772875a6fb6 (diff)
downloadports-f2a96f40176f8c8ecc3ff737467a76b46448cea9.tar.gz
ports-f2a96f40176f8c8ecc3ff737467a76b46448cea9.zip
Fix building of bindings in BATCH mode (without options file at all):
invert checks such way, that default config without OPTIONS at all is equivalent to default config, specified via OPTIONS.
Notes
Notes: svn path=/head/; revision=216516
Diffstat (limited to 'devel/subversion16/Makefile.common')
-rw-r--r--devel/subversion16/Makefile.common8
1 files changed, 5 insertions, 3 deletions
diff --git a/devel/subversion16/Makefile.common b/devel/subversion16/Makefile.common
index 8f1f53c36432..85d74367cd1c 100644
--- a/devel/subversion16/Makefile.common
+++ b/devel/subversion16/Makefile.common
@@ -6,7 +6,7 @@
PORTNAME= subversion
PORTVERSION= 1.5.0
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES+= devel
MASTER_SITES= http://subversion.tigris.org/downloads/:main \
http://svnbook.red-bean.com/en/1.4/:book
@@ -31,7 +31,8 @@ OPTIONS=
CONFIGURE_ARGS+= --without-swig
-.if defined(WITH_NEON)
+# Default is "on"
+.if !defined(WITHOUT_NEON)
LIB_DEPENDS+= neon.28:${PORTSDIR}/www/neon28
CONFIGURE_ARGS+= --with-neon=${LOCALBASE}
PLIST_SUB+= NEON=""
@@ -57,7 +58,8 @@ CONFIGURE_ARGS+= --without-sasl
PLIST_SUB+= SASL="@comment "
.endif
-.if defined(WITH_BDB)
+# Default us "on"
+.if !defined(WITHOUT_BDB)
PLIST_SUB+= BDB=""
.else
CONFIGURE_ARGS+= --without-berkeley-db