aboutsummaryrefslogtreecommitdiff
path: root/devel/subversion
diff options
context:
space:
mode:
authorBruce A. Mah <bmah@FreeBSD.org>2003-06-10 20:04:42 +0000
committerBruce A. Mah <bmah@FreeBSD.org>2003-06-10 20:04:42 +0000
commit6a4808de7f8c34a23fddf12e8c3ed09b97c61d56 (patch)
tree1f9d74cbf7d4a113820b5b7b3ad593e3dd0a354a /devel/subversion
parent64f0cabd72e7bf10d1ddce186956ea241c8d8d1e (diff)
downloadports-6a4808de7f8c34a23fddf12e8c3ed09b97c61d56.tar.gz
ports-6a4808de7f8c34a23fddf12e8c3ed09b97c61d56.zip
Port update that:
1. Eliminates a bogus dependency on the libtool port, as pointed out on dev@subversion.tigris.org. 2. Turns off swig binding via configure options, rather than post-configure Makefile hacks. This will make it easier to enable swig bindings in the future, if someone wants to tackle this. 3. Installs a number of the text files from the top level of the subversion distribution into ${PREFIX}/share/doc/subversion. PORTREVISION bump to document this. Approved by: rodrigc@attbi.com (MAINTAINER)
Notes
Notes: svn path=/head/; revision=82712
Diffstat (limited to 'devel/subversion')
-rw-r--r--devel/subversion/Makefile13
-rw-r--r--devel/subversion/pkg-plist9
2 files changed, 15 insertions, 7 deletions
diff --git a/devel/subversion/Makefile b/devel/subversion/Makefile
index 5404d5a5c113..ac3c387d472a 100644
--- a/devel/subversion/Makefile
+++ b/devel/subversion/Makefile
@@ -6,7 +6,7 @@
PORTNAME= subversion
PORTVERSION= 0.23.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://subversion.tigris.org/files/documents/15/4218/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -21,7 +21,6 @@ LIB_DEPENDS= db4:${PORTSDIR}/databases/db4 \
apr-0.9:${PORTSDIR}/devel/apr
INSTALLS_SHLIB= yes
-USE_LIBTOOL= yes
WRKSRC= ${WRKDIR}/subversion-${PORTVERSION}
GNU_CONFIGURE= yes
@@ -31,7 +30,8 @@ CONFIGURE_ARGS= --with-ssl \
--with-neon=${LOCALBASE} \
--with-berkeley-db=${LOCALBASE}/include/db4:${LOCALBASE}/lib \
--with-apr=${LOCALBASE} \
- --with-apr-util=${LOCALBASE}
+ --with-apr-util=${LOCALBASE} \
+ --with-swig=no
MAN1= svn.1 svnadmin.1
MANCOMPRESSED= no
@@ -63,10 +63,6 @@ post-extract:
@${RM} -r ${WRKSRC}/apr
@${RM} -r ${WRKSRC}/apr-util
-post-configure:
- @${REINPLACE_CMD} 's/install-swig-py-lib//g' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} 's/swig-py-lib//g' ${WRKSRC}/Makefile
-
.if defined(WITH_MOD_DAV_SVN)
pre-install:
${APXS} -e -S LIBEXECDIR=${PREFIX}/libexec/apache2 -a -n dav libexec/apache2/mod_dav.so
@@ -78,6 +74,9 @@ post-install:
cd ${WRKSRC}/doc/book; \
${MAKE} INSTALL_DIR=${DOCSDIR} \
install-book-html install-book-pdf install-book-ps
+ for f in BUGS CHANGES COMMITTERS COPYING HACKING IDEAS INSTALL PORTING README; do \
+ ${INSTALL_DATA} ${WRKSRC}/$$f ${DOCSDIR}; \
+ done
.endif
post-deinstall:
diff --git a/devel/subversion/pkg-plist b/devel/subversion/pkg-plist
index 42650224b487..ce52f64ea0c0 100644
--- a/devel/subversion/pkg-plist
+++ b/devel/subversion/pkg-plist
@@ -112,4 +112,13 @@ lib/libsvn_wc-1.so.0
%%PORTDOCS%%share/doc/subversion/book/book.ps
%%PORTDOCS%%share/doc/subversion/book/styles.css
%%PORTDOCS%%@dirrm share/doc/subversion/book
+%%PORTDOCS%%share/doc/subversion/BUGS
+%%PORTDOCS%%share/doc/subversion/CHANGES
+%%PORTDOCS%%share/doc/subversion/COMMITTERS
+%%PORTDOCS%%share/doc/subversion/COPYING
+%%PORTDOCS%%share/doc/subversion/HACKING
+%%PORTDOCS%%share/doc/subversion/IDEAS
+%%PORTDOCS%%share/doc/subversion/INSTALL
+%%PORTDOCS%%share/doc/subversion/PORTING
+%%PORTDOCS%%share/doc/subversion/README
%%PORTDOCS%%@dirrm share/doc/subversion