aboutsummaryrefslogtreecommitdiff
path: root/devel/subversive/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2008-09-07 10:36:44 +0000
committerAlex Dupre <ale@FreeBSD.org>2008-09-07 10:36:44 +0000
commitd2080b2f1f0022d1e64cc2fd30582ce61f9c1e95 (patch)
treeab73a6265850ee24a4a21296b007faa74518c8f5 /devel/subversive/Makefile
parent4e978cf89d02da9690a3b030adee1fc1a61613e7 (diff)
downloadports-d2080b2f1f0022d1e64cc2fd30582ce61f9c1e95.tar.gz
ports-d2080b2f1f0022d1e64cc2fd30582ce61f9c1e95.zip
Update to 0.7.3 release for eclipse 3.3+.
Notes
Notes: svn path=/head/; revision=220111
Diffstat (limited to 'devel/subversive/Makefile')
-rw-r--r--devel/subversive/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/devel/subversive/Makefile b/devel/subversive/Makefile
index bf34cbbad82c..d438805635f3 100644
--- a/devel/subversive/Makefile
+++ b/devel/subversive/Makefile
@@ -6,24 +6,31 @@
#
PORTNAME= subversive
-DISTVERSION= 1.1.9.02
-PORTREVISION= 1
+PORTVERSION= 0.7.3
+PORTEPOCH= 1
CATEGORIES= devel java
-MASTER_SITES= http://www.polarion.org/projects/subversive/download/1.1/builds/
-DISTNAME= Subversive_${DISTVERSION}-LocalUpdateSite
+MASTER_SITES= ${MASTER_SITE_ECLIPSE:S,%SUBDIR%,technology/subversive/0.7/builds,:S,$,:core,} \
+ http://www.polarion.org/projects/subversive/download/eclipse/2.0/update-site/plugins/:connectors
+DISTNAME= Subversive-incubation-${PORTVERSION}.I20080814-1500
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:core ${SVNKITJAR}:connectors
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ale@FreeBSD.org
COMMENT= An Eclipse plug-in that provides Subversion support
RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
+SVNKITJAR= org.polarion.eclipse.team.svn.connector.svnkit15_2.0.3.I20080814-1500.jar
NO_BUILD= yes
NO_WRKSUBDIR= yes
USE_ZIP= yes
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
JAVA_OS= native
+post-extract:
+ @${CP} ${_DISTDIR}/${SVNKITJAR} ${WRKSRC}/plugins
+
do-install:
@${MKDIR} ${PREFIX}/eclipse
@${CP} -r ${WRKSRC}/plugins ${PREFIX}/eclipse