aboutsummaryrefslogtreecommitdiff
path: root/devel/swig13/Makefile
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>2005-09-24 16:32:55 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>2005-09-24 16:32:55 +0000
commit4117fa433a536ad79431ce57e31c05f3528ca01f (patch)
treeadbe896e36d06355715f89ea74e0bbb6fedb08c2 /devel/swig13/Makefile
parent93802ea7372300615e28e8e81de7ee6fc183abcf (diff)
downloadports-4117fa433a536ad79431ce57e31c05f3528ca01f.tar.gz
ports-4117fa433a536ad79431ce57e31c05f3528ca01f.zip
- Install examples into ${EXAMPLESDIR}.
- Install documentation into ${DOCSDIR} honoring NOPORTDOCS. - Sort "pkg-plist". Approved by: Soeren Straarup <xride@x12.dk> [MAINTAINER]
Notes
Notes: svn path=/head/; revision=143491
Diffstat (limited to 'devel/swig13/Makefile')
-rw-r--r--devel/swig13/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/devel/swig13/Makefile b/devel/swig13/Makefile
index 7c2aab603790..634fd172e2a0 100644
--- a/devel/swig13/Makefile
+++ b/devel/swig13/Makefile
@@ -7,7 +7,7 @@
PORTNAME= swig
PORTVERSION= 1.3.25
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -125,5 +125,17 @@ post-configure:
post-install:
${LN} -f ${PREFIX}/bin/swig ${PREFIX}/bin/swig${VER}
+ ${MKDIR} ${EXAMPLESDIR}/${PORTVERSION}
+ cd ${WRKSRC}/Examples && ${FIND} . -type d \
+ -exec ${INSTALL} -d ${EXAMPLESDIR}/${PORTVERSION}/{} \;
+ cd ${WRKSRC}/Examples && ${FIND} . -type f \
+ -exec ${INSTALL_DATA} {} ${EXAMPLESDIR}/${PORTVERSION}/{} \;
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/${PORTVERSION}
+ cd ${WRKSRC}/Doc && ${FIND} . -type d \
+ -exec ${INSTALL} -d ${DOCSDIR}/${PORTVERSION}/{} \;
+ cd ${WRKSRC}/Doc && ${FIND} . -type f \
+ -exec ${INSTALL_DATA} {} ${DOCSDIR}/${PORTVERSION}/{} \;
+.endif
.include <bsd.port.post.mk>