aboutsummaryrefslogtreecommitdiff
path: root/devel/tcl-trf
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2003-12-13 17:12:13 +0000
committerMikhail Teterin <mi@FreeBSD.org>2003-12-13 17:12:13 +0000
commitf289e5d8c1f72829d573342c9f7ea3dbc7daa158 (patch)
tree04171de2d9d27e1949b64b21ff1111b5e7373f77 /devel/tcl-trf
parent228bbbe6024cc2352d370fb06b0539ca2df9e0fd (diff)
downloadports-f289e5d8c1f72829d573342c9f7ea3dbc7daa158.tar.gz
ports-f289e5d8c1f72829d573342c9f7ea3dbc7daa158.zip
Parametrize the version number to unbreak packaging -- we switched
the default to Tcl-8.4, but the version in pkg-plist was hardcoded as 8.3 Prodded by: kris
Notes
Notes: svn path=/head/; revision=95740
Diffstat (limited to 'devel/tcl-trf')
-rw-r--r--devel/tcl-trf/Makefile3
-rw-r--r--devel/tcl-trf/pkg-plist2
2 files changed, 3 insertions, 2 deletions
diff --git a/devel/tcl-trf/Makefile b/devel/tcl-trf/Makefile
index 7aa6b2e25395..f8b06a5aaad8 100644
--- a/devel/tcl-trf/Makefile
+++ b/devel/tcl-trf/Makefile
@@ -67,4 +67,5 @@ post-install:
SHLIB_NAME= libTrf2.so.1
SHLIB_LINK= ${SHLIB_NAME:C/\.so\..*/.so/}
-PLIST_SUB+= SHLIB_NAME=${SHLIB_NAME} SHLIB_LINK=${SHLIB_LINK}
+PLIST_SUB+= SHLIB_NAME=${SHLIB_NAME} SHLIB_LINK=${SHLIB_LINK} \
+ TCL_DVER=${TCL_VER:C/\.//}
diff --git a/devel/tcl-trf/pkg-plist b/devel/tcl-trf/pkg-plist
index 958a4c03ae6e..3a01af5a178a 100644
--- a/devel/tcl-trf/pkg-plist
+++ b/devel/tcl-trf/pkg-plist
@@ -1,6 +1,6 @@
lib/%%SHLIB_NAME%%
lib/%%SHLIB_LINK%%
-lib/libTrfstub83.a
+lib/libTrfstub%%TCL_DVER%%.a
lib/Trf/pkgIndex.tcl
include/trfDecls.h
include/transform.h