aboutsummaryrefslogtreecommitdiff
path: root/devel/tclxml
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-06-25 02:19:51 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-06-25 02:19:51 +0000
commitb6dbbfe76598ebeb01cd5dfa11d1879771cb6c2c (patch)
tree6ebfc1ca15eed7a95ffdd53be7680a83f1484aed /devel/tclxml
parent5f2eba1251d03abdfc5929b540b2a0d9e39ddc34 (diff)
downloadports-b6dbbfe76598ebeb01cd5dfa11d1879771cb6c2c.tar.gz
ports-b6dbbfe76598ebeb01cd5dfa11d1879771cb6c2c.zip
- Add docs and configure to respect NOPORTDOCS
PR: ports/124126 Submitted by: David Yeske <dyeske@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=215745
Diffstat (limited to 'devel/tclxml')
-rw-r--r--devel/tclxml/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/devel/tclxml/Makefile b/devel/tclxml/Makefile
index 1b8983d07bc5..a854724de8ed 100644
--- a/devel/tclxml/Makefile
+++ b/devel/tclxml/Makefile
@@ -16,6 +16,9 @@ COMMENT= API for parsing XML documents using Tcl
RUN_DEPENDS?= dtplite:${PORTSDIR}/devel/tcllib
+PORTDOCS= README.html html.xsl nroff.xsl tclxml.html tclxml.xml \
+ README.xml man.macros tcldoc-1.0.dtd tclxml.n txt.xsl
+
USE_TCL= 82+
GNU_CONFIGURE= yes
USE_LDCONFIG?= ${PREFIX}/lib/Tclxml${PORTVERSION}
@@ -25,4 +28,13 @@ PLIST= ${PKGDIR}${PKGNAMESUFFIX}/pkg-plist
PATCHDIR= ${PKGDIR}${PKGNAMESUFFIX}/files/
PLIST_SUB= VER=${PORTVERSION}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+pre-install:
+
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d ${DOCSDIR}
+ @cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>