aboutsummaryrefslogtreecommitdiff
path: root/devel/thunar-vcs-plugin
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-10-19 13:55:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-10-19 13:55:28 +0000
commitfbbd6f882eb3257b5c19169cb2eaec0d43b5370e (patch)
tree6a062d95f44d195f07896b54170274788ad323ed /devel/thunar-vcs-plugin
parent2f241ed96bad59ae9d4e1d8e62bc28b61f28e97a (diff)
downloadports-fbbd6f882eb3257b5c19169cb2eaec0d43b5370e.tar.gz
ports-fbbd6f882eb3257b5c19169cb2eaec0d43b5370e.zip
The Thunar SVN Plugin adds Subversion actions to the context menu of thunar.
The current features are: Most of the svn action: add, blame, checkout, cleanup, commit, copy, delete, export, import, lock, log, move, properties, relocate, resolved, revert, status, switch, unlock, update. Subversion info in file properties dialog. WWW: http://goodies.xfce.org/projects/thunar-plugins/thunar-svn-plugin PR: ports/128117 Submitted by: Sergey V. Dyatko <sergey.dyatko at gmail.com>
Notes
Notes: svn path=/head/; revision=221773
Diffstat (limited to 'devel/thunar-vcs-plugin')
-rw-r--r--devel/thunar-vcs-plugin/Makefile26
-rw-r--r--devel/thunar-vcs-plugin/distinfo3
-rw-r--r--devel/thunar-vcs-plugin/files/patch-Makefile.in11
-rw-r--r--devel/thunar-vcs-plugin/pkg-descr9
-rw-r--r--devel/thunar-vcs-plugin/pkg-plist16
5 files changed, 65 insertions, 0 deletions
diff --git a/devel/thunar-vcs-plugin/Makefile b/devel/thunar-vcs-plugin/Makefile
new file mode 100644
index 000000000000..d19add32ecd5
--- /dev/null
+++ b/devel/thunar-vcs-plugin/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: thunar-svn-plugin
+# Date created: 2008-10-15
+# Whom: Sergey V. Dyatko <sergey.dyatko@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= thunar-svn-plugin
+PORTVERSION= 0.0.2
+CATEGORIES= devel xfce
+MASTER_SITES= http://goodies.xfce.org/releases/thunar-svn-plugin/
+DIST_SUBDIR= xfce4
+
+MAINTAINER= sergey.dyatko@gmail.com
+COMMENT= Subversion plugin for Thunar
+
+LIB_DEPENDS= svn_client-1:${PORTSDIR}/devel/subversion
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gtk20
+USE_XFCE= configenv libexo thunar
+
+.include <bsd.port.mk>
diff --git a/devel/thunar-vcs-plugin/distinfo b/devel/thunar-vcs-plugin/distinfo
new file mode 100644
index 000000000000..02f91be4a2ae
--- /dev/null
+++ b/devel/thunar-vcs-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (xfce4/thunar-svn-plugin-0.0.2.tar.bz2) = 7f79902213778655b862d2ebcbb73334
+SHA256 (xfce4/thunar-svn-plugin-0.0.2.tar.bz2) = abdc5f5417fbf10d4c3b1e863937bbf65a1827dcf132b3a43919e2ef502e5981
+SIZE (xfce4/thunar-svn-plugin-0.0.2.tar.bz2) = 345286
diff --git a/devel/thunar-vcs-plugin/files/patch-Makefile.in b/devel/thunar-vcs-plugin/files/patch-Makefile.in
new file mode 100644
index 000000000000..75baa071b1d2
--- /dev/null
+++ b/devel/thunar-vcs-plugin/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- thunar-svn-plugin/Makefile.in.orig 2008-10-15 11:57:39.000000000 +0300
++++ thunar-svn-plugin/Makefile.in 2008-10-15 11:55:46.000000000 +0300
+@@ -140,7 +140,7 @@
+ INTLLIBS = @INTLLIBS@
+ LDFLAGS = @LDFLAGS@
+ LIBOBJS = @LIBOBJS@
+-LIBS = @LIBS@
++LIBS = @LIBS@ -L/usr/local/lib
+ LIBTOOL = @LIBTOOL@
+ LN_S = @LN_S@
+ LTLIBOBJS = @LTLIBOBJS@
diff --git a/devel/thunar-vcs-plugin/pkg-descr b/devel/thunar-vcs-plugin/pkg-descr
new file mode 100644
index 000000000000..b0af1fa18401
--- /dev/null
+++ b/devel/thunar-vcs-plugin/pkg-descr
@@ -0,0 +1,9 @@
+The Thunar SVN Plugin adds Subversion actions to the context menu of thunar.
+
+The current features are:
+Most of the svn action: add, blame, checkout, cleanup, commit, copy, delete,
+export, import, lock, log, move, properties, relocate, resolved, revert, status,
+switch, unlock, update.
+Subversion info in file properties dialog.
+
+WWW: http://goodies.xfce.org/projects/thunar-plugins/thunar-svn-plugin
diff --git a/devel/thunar-vcs-plugin/pkg-plist b/devel/thunar-vcs-plugin/pkg-plist
new file mode 100644
index 000000000000..9940bee51b82
--- /dev/null
+++ b/devel/thunar-vcs-plugin/pkg-plist
@@ -0,0 +1,16 @@
+lib/thunarx-1/thunar-svn-plugin.la
+lib/thunarx-1/thunar-svn-plugin.so
+libexec/tsp-svn-helper
+share/icons/hicolor/24x24/apps/subversion.png
+share/icons/hicolor/48x48/apps/subversion.png
+share/locale/cs/LC_MESSAGES/thunar-svn-plugin.mo
+share/locale/en_GB/LC_MESSAGES/thunar-svn-plugin.mo
+share/locale/fr/LC_MESSAGES/thunar-svn-plugin.mo
+share/locale/hu/LC_MESSAGES/thunar-svn-plugin.mo
+share/locale/lv/LC_MESSAGES/thunar-svn-plugin.mo
+share/locale/nl/LC_MESSAGES/thunar-svn-plugin.mo
+share/locale/pt_BR/LC_MESSAGES/thunar-svn-plugin.mo
+share/locale/ur/LC_MESSAGES/thunar-svn-plugin.mo
+@dirrmtry share/locale/ur/LC_MESSAGES
+@dirrmtry share/locale/ur
+@dirrmtry lib/thunarx-1