aboutsummaryrefslogtreecommitdiff
path: root/devel/tmake
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-03-25 21:10:13 +0000
committerWill Andrews <will@FreeBSD.org>2000-03-25 21:10:13 +0000
commitc2b3d7e609aecca3299f3acae6a69753b1ccdfa2 (patch)
tree3c1e9cb953fcb7e990d9e68697475fa872312afe /devel/tmake
parent00114700d01225f61a482bc37bde43f2587f9c24 (diff)
downloadports-c2b3d7e609aecca3299f3acae6a69753b1ccdfa2.tar.gz
ports-c2b3d7e609aecca3299f3acae6a69753b1ccdfa2.zip
Add Troll Tech's tmake utility, which will be used by my upcoming twinlib
port, and perhaps others in the future. Activate tmake in devel/Makefile. Also made a COMMENT nit. PR: 17265 Submitted by: Roland Jesse <jesse@cs.uni-magdeburg.de>
Notes
Notes: svn path=/head/; revision=27047
Diffstat (limited to 'devel/tmake')
-rw-r--r--devel/tmake/Makefile32
-rw-r--r--devel/tmake/distinfo1
-rw-r--r--devel/tmake/pkg-comment1
-rw-r--r--devel/tmake/pkg-descr10
-rw-r--r--devel/tmake/pkg-plist193
5 files changed, 237 insertions, 0 deletions
diff --git a/devel/tmake/Makefile b/devel/tmake/Makefile
new file mode 100644
index 000000000000..74693a62c7da
--- /dev/null
+++ b/devel/tmake/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: tmake
+# Version required: 1.3
+# Date created: 8 March 2000
+# Whom: jesse@cs.uni-magdeburg.de
+#
+# $FreeBSD$
+#
+
+DISTNAME= tmake-1.3
+CATEGORIES= devel perl5
+MASTER_SITES= ftp://ftp.troll.no/freebies/tmake/
+
+MAINTAINER= jesse@cs.uni-magdeburg.de
+
+USE_PERL5= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/tmake
+TMAKE_BIN= progen tmake
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/tmake
+ @cd ${WRKSRC}/lib; tar cf - * | (cd ${PREFIX}/share/tmake && tar xf -)
+.for f in ${TMAKE_BIN}
+ @${INSTALL_SCRIPT} ${WRKSRC}/bin/${f} ${PREFIX}/bin
+.endfor
+
+post-install:
+ @${ECHO} "Make sure to set your TMAKEPATH environment variable"
+ @${ECHO} "to ${PREFIX}/share/tmake/freebsd-g++."
+ @${ECHO}
+
+.include <bsd.port.mk>
diff --git a/devel/tmake/distinfo b/devel/tmake/distinfo
new file mode 100644
index 000000000000..e61e30c04f43
--- /dev/null
+++ b/devel/tmake/distinfo
@@ -0,0 +1 @@
+MD5 (tmake-1.3.tar.gz) = afb94874a0ec92861740d4b54bc3b4e7
diff --git a/devel/tmake/pkg-comment b/devel/tmake/pkg-comment
new file mode 100644
index 000000000000..88ff46ab7785
--- /dev/null
+++ b/devel/tmake/pkg-comment
@@ -0,0 +1 @@
+Extremely portable perl-based make utility
diff --git a/devel/tmake/pkg-descr b/devel/tmake/pkg-descr
new file mode 100644
index 000000000000..8aeea38eed22
--- /dev/null
+++ b/devel/tmake/pkg-descr
@@ -0,0 +1,10 @@
+This is a port of tmake, the tool from Troll Tech to create and
+maintain makefiles for software projects. It is especially useful if
+you develop for more than one platform or use more than one
+compiler. tmake automates and streamlines this process and lets you
+spend your valuable time on writing code, not makefiles.
+
+WWW: http://www.troll.no/freebies/tmake.html
+
+- Roland
+jesse@cs.uni-magdeburg.de
diff --git a/devel/tmake/pkg-plist b/devel/tmake/pkg-plist
new file mode 100644
index 000000000000..65e151500f4d
--- /dev/null
+++ b/devel/tmake/pkg-plist
@@ -0,0 +1,193 @@
+bin/progen
+bin/tmake
+share/tmake/aix-g++/subdirs.t
+share/tmake/aix-g++/app.t
+share/tmake/aix-g++/lib.t
+share/tmake/aix-g++/tmake.conf
+share/tmake/aix-xlc/subdirs.t
+share/tmake/aix-xlc/app.t
+share/tmake/aix-xlc/lib.t
+share/tmake/aix-xlc/tmake.conf
+share/tmake/bsdi-g++/subdirs.t
+share/tmake/bsdi-g++/app.t
+share/tmake/bsdi-g++/lib.t
+share/tmake/bsdi-g++/tmake.conf
+share/tmake/dgux-g++/subdirs.t
+share/tmake/dgux-g++/app.t
+share/tmake/dgux-g++/lib.t
+share/tmake/dgux-g++/tmake.conf
+share/tmake/freebsd-g++/subdirs.t
+share/tmake/freebsd-g++/app.t
+share/tmake/freebsd-g++/lib.t
+share/tmake/freebsd-g++/tmake.conf
+share/tmake/gnu-g++/subdirs.t
+share/tmake/gnu-g++/app.t
+share/tmake/gnu-g++/lib.t
+share/tmake/gnu-g++/tmake.conf
+share/tmake/hpux-acc/subdirs.t
+share/tmake/hpux-acc/app.t
+share/tmake/hpux-acc/lib.t
+share/tmake/hpux-acc/tmake.conf
+share/tmake/hpux-cc/subdirs.t
+share/tmake/hpux-cc/app.t
+share/tmake/hpux-cc/lib.t
+share/tmake/hpux-cc/tmake.conf
+share/tmake/hpux-g++/subdirs.t
+share/tmake/hpux-g++/app.t
+share/tmake/hpux-g++/lib.t
+share/tmake/hpux-g++/tmake.conf
+share/tmake/irix-64/subdirs.t
+share/tmake/irix-64/app.t
+share/tmake/irix-64/lib.t
+share/tmake/irix-64/tmake.conf
+share/tmake/irix-dcc/subdirs.t
+share/tmake/irix-dcc/app.t
+share/tmake/irix-dcc/lib.t
+share/tmake/irix-dcc/tmake.conf
+share/tmake/irix-g++/subdirs.t
+share/tmake/irix-g++/app.t
+share/tmake/irix-g++/lib.t
+share/tmake/irix-g++/tmake.conf
+share/tmake/irix-n32/subdirs.t
+share/tmake/irix-n32/app.t
+share/tmake/irix-n32/lib.t
+share/tmake/irix-n32/tmake.conf
+share/tmake/irix-o32/subdirs.t
+share/tmake/irix-o32/app.t
+share/tmake/irix-o32/lib.t
+share/tmake/irix-o32/tmake.conf
+share/tmake/linux-g++/subdirs.t
+share/tmake/linux-g++/app.t
+share/tmake/linux-g++/lib.t
+share/tmake/linux-g++/tmake.conf
+share/tmake/netbsd-g++/subdirs.t
+share/tmake/netbsd-g++/app.t
+share/tmake/netbsd-g++/lib.t
+share/tmake/netbsd-g++/tmake.conf
+share/tmake/openbsd-g++/subdirs.t
+share/tmake/openbsd-g++/app.t
+share/tmake/openbsd-g++/lib.t
+share/tmake/openbsd-g++/tmake.conf
+share/tmake/osf1-cxx/subdirs.t
+share/tmake/osf1-cxx/app.t
+share/tmake/osf1-cxx/lib.t
+share/tmake/osf1-cxx/tmake.conf
+share/tmake/osf1-g++/subdirs.t
+share/tmake/osf1-g++/app.t
+share/tmake/osf1-g++/lib.t
+share/tmake/osf1-g++/tmake.conf
+share/tmake/qnx-g++/subdirs.t
+share/tmake/qnx-g++/app.t
+share/tmake/qnx-g++/lib.t
+share/tmake/qnx-g++/tmake.conf
+share/tmake/sco-g++/subdirs.t
+share/tmake/sco-g++/app.t
+share/tmake/sco-g++/lib.t
+share/tmake/sco-g++/tmake.conf
+share/tmake/solaris-cc/subdirs.t
+share/tmake/solaris-cc/app.t
+share/tmake/solaris-cc/lib.t
+share/tmake/solaris-cc/tmake.conf
+share/tmake/solaris-cc-gcc/subdirs.t
+share/tmake/solaris-cc-gcc/app.t
+share/tmake/solaris-cc-gcc/lib.t
+share/tmake/solaris-cc-gcc/tmake.conf
+share/tmake/solaris-g++/subdirs.t
+share/tmake/solaris-g++/app.t
+share/tmake/solaris-g++/lib.t
+share/tmake/solaris-g++/tmake.conf
+share/tmake/sunos-g++/subdirs.t
+share/tmake/sunos-g++/app.t
+share/tmake/sunos-g++/lib.t
+share/tmake/sunos-g++/tmake.conf
+share/tmake/ultrix-g++/subdirs.t
+share/tmake/ultrix-g++/app.t
+share/tmake/ultrix-g++/lib.t
+share/tmake/ultrix-g++/tmake.conf
+share/tmake/unix/generic.t
+share/tmake/unix/app.t
+share/tmake/unix/subdirs.t
+share/tmake/unix/lib.t
+share/tmake/unixware-g++/subdirs.t
+share/tmake/unixware-g++/app.t
+share/tmake/unixware-g++/lib.t
+share/tmake/unixware-g++/tmake.conf
+share/tmake/unixware7-cc/subdirs.t
+share/tmake/unixware7-cc/app.t
+share/tmake/unixware7-cc/lib.t
+share/tmake/unixware7-cc/tmake.conf
+share/tmake/unixware7-g++/subdirs.t
+share/tmake/unixware7-g++/app.t
+share/tmake/unixware7-g++/lib.t
+share/tmake/unixware7-g++/tmake.conf
+share/tmake/win32/subdirs.t
+share/tmake/win32-borland/generic.t
+share/tmake/win32-borland/app.t
+share/tmake/win32-borland/subdirs.t
+share/tmake/win32-borland/lib.t
+share/tmake/win32-borland/tmake.conf
+share/tmake/win32-g++/generic.t
+share/tmake/win32-g++/app.t
+share/tmake/win32-g++/subdirs.t
+share/tmake/win32-g++/lib.t
+share/tmake/win32-g++/tmake.conf
+share/tmake/win32-msvc/generic.t
+share/tmake/win32-msvc/app.t
+share/tmake/win32-msvc/subdirs.t
+share/tmake/win32-msvc/lib.t
+share/tmake/win32-msvc/tmake.conf
+share/tmake/win32-msvc/vcapp.t
+share/tmake/win32-msvc/vclib.t
+share/tmake/win32-symantec/generic.t
+share/tmake/win32-symantec/app.t
+share/tmake/win32-symantec/subdirs.t
+share/tmake/win32-symantec/lib.t
+share/tmake/win32-symantec/tmake.conf
+share/tmake/win32-visage/generic.t
+share/tmake/win32-visage/app.t
+share/tmake/win32-visage/subdirs.t
+share/tmake/win32-visage/lib.t
+share/tmake/win32-visage/tmake.conf
+share/tmake/win32-watcom/generic.t
+share/tmake/win32-watcom/app.t
+share/tmake/win32-watcom/subdirs.t
+share/tmake/win32-watcom/lib.t
+share/tmake/win32-watcom/tmake.conf
+@dirrm share/tmake/aix-g++
+@dirrm share/tmake/aix-xlc
+@dirrm share/tmake/bsdi-g++
+@dirrm share/tmake/dgux-g++
+@dirrm share/tmake/freebsd-g++
+@dirrm share/tmake/gnu-g++
+@dirrm share/tmake/hpux-acc
+@dirrm share/tmake/hpux-cc
+@dirrm share/tmake/hpux-g++
+@dirrm share/tmake/irix-64
+@dirrm share/tmake/irix-dcc
+@dirrm share/tmake/irix-g++
+@dirrm share/tmake/irix-n32
+@dirrm share/tmake/irix-o32
+@dirrm share/tmake/linux-g++
+@dirrm share/tmake/netbsd-g++
+@dirrm share/tmake/openbsd-g++
+@dirrm share/tmake/osf1-cxx
+@dirrm share/tmake/osf1-g++
+@dirrm share/tmake/qnx-g++
+@dirrm share/tmake/sco-g++
+@dirrm share/tmake/solaris-cc
+@dirrm share/tmake/solaris-cc-gcc
+@dirrm share/tmake/solaris-g++
+@dirrm share/tmake/sunos-g++
+@dirrm share/tmake/ultrix-g++
+@dirrm share/tmake/unix
+@dirrm share/tmake/unixware-g++
+@dirrm share/tmake/unixware7-cc
+@dirrm share/tmake/unixware7-g++
+@dirrm share/tmake/win32
+@dirrm share/tmake/win32-borland
+@dirrm share/tmake/win32-g++
+@dirrm share/tmake/win32-msvc
+@dirrm share/tmake/win32-symantec
+@dirrm share/tmake/win32-visage
+@dirrm share/tmake/win32-watcom
+@dirrm share/tmake