aboutsummaryrefslogtreecommitdiff
path: root/devel/ucpp
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-02-15 17:44:55 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-02-15 17:44:55 +0000
commit8db93d42d249beabdf49845275f3af3c529040da (patch)
treec21879e994d4323c04cf1a5e7360d84df4f6b9e6 /devel/ucpp
parent6475524e69ff0b1015f7d6249977def111837209 (diff)
downloadports-8db93d42d249beabdf49845275f3af3c529040da.tar.gz
ports-8db93d42d249beabdf49845275f3af3c529040da.zip
add ucpp, a C preprocessor and lexer
Notes
Notes: svn path=/head/; revision=38381
Diffstat (limited to 'devel/ucpp')
-rw-r--r--devel/ucpp/Makefile25
-rw-r--r--devel/ucpp/distinfo1
-rw-r--r--devel/ucpp/files/patch-Makefile21
-rw-r--r--devel/ucpp/pkg-comment1
-rw-r--r--devel/ucpp/pkg-descr9
-rw-r--r--devel/ucpp/pkg-plist1
6 files changed, 58 insertions, 0 deletions
diff --git a/devel/ucpp/Makefile b/devel/ucpp/Makefile
new file mode 100644
index 000000000000..c8e331d2d6ea
--- /dev/null
+++ b/devel/ucpp/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# New ports collection makefile for: ucpp
+# Date created: Feb 16, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ucpp
+PORTVERSION= 1.0
+CATEGORIES= devel
+MASTER_SITES= http://www.di.ens.fr/~pornin/ucpp/
+
+MAINTAINER= ijliao@FreeBSD.org
+
+MAN1= ucpp.1
+
+post-patch:
+ @${PERL} -pi -e "s|%%CFLAGS%%|${CFLAGS}|g" ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/devel/ucpp/distinfo b/devel/ucpp/distinfo
new file mode 100644
index 000000000000..78afc2450a2f
--- /dev/null
+++ b/devel/ucpp/distinfo
@@ -0,0 +1 @@
+MD5 (ucpp-1.0.tar.gz) = d7175898b614170c8712d24dc3044f8a
diff --git a/devel/ucpp/files/patch-Makefile b/devel/ucpp/files/patch-Makefile
new file mode 100644
index 000000000000..da10f2bbcf21
--- /dev/null
+++ b/devel/ucpp/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.orig Fri Feb 16 01:30:03 2001
++++ Makefile Fri Feb 16 01:35:14 2001
+@@ -52,14 +52,14 @@
+ #FLAGS = -O -m -DMEM_CHECK
+
+ # for gcc
+-#CC = gcc
++CC = gcc
+ #FLAGS = -g -Wall -ansi -pedantic -DAUDIT
+-#FLAGS = -O3 -Wall -ansi -pedantic -DMEM_CHECK
++FLAGS = %%CFLAGS%% -DMEM_CHECK
+
+ # for the Compaq C compiler on Alpha/Linux
+-CC = ccc
++#CC = ccc
+ #FLAGS = -w0 -g -DAUDIT
+-FLAGS = -w0 -fast -DMEM_CHECK
++#FLAGS = -w0 -fast -DMEM_CHECK
+
+ # for the Sun Workshop C Compiler
+ #CC = cc
diff --git a/devel/ucpp/pkg-comment b/devel/ucpp/pkg-comment
new file mode 100644
index 000000000000..2fb1aea90963
--- /dev/null
+++ b/devel/ucpp/pkg-comment
@@ -0,0 +1 @@
+A C preprocessor and lexer
diff --git a/devel/ucpp/pkg-descr b/devel/ucpp/pkg-descr
new file mode 100644
index 000000000000..69afa5998fe6
--- /dev/null
+++ b/devel/ucpp/pkg-descr
@@ -0,0 +1,9 @@
+ucpp is a C preprocessor and lexer. It has the following goals:
+
+ - Strict conformance to the C99 standard (with switches to
+ disable some extensions and mimic C90 behaviour)
+ - Low memory consumption
+ - Possibility to use the code as a lexer (that outputs tokens
+ directly)
+
+WWW: http://www.di.ens.fr/~pornin/ucpp/
diff --git a/devel/ucpp/pkg-plist b/devel/ucpp/pkg-plist
new file mode 100644
index 000000000000..dcdf7b0c3515
--- /dev/null
+++ b/devel/ucpp/pkg-plist
@@ -0,0 +1 @@
+bin/ucpp