aboutsummaryrefslogtreecommitdiff
path: root/devel/veepee
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2002-11-14 13:07:04 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2002-11-14 13:07:04 +0000
commit84a51750db441ff5ed4ba9e3b75a54765ca8b983 (patch)
tree8b9fc5ae8e05958ea49a9a64e90fac78397bc7ee /devel/veepee
parent5981e38f4ce3953d3766f99b40e72139b7e80edf (diff)
downloadports-84a51750db441ff5ed4ba9e3b75a54765ca8b983.tar.gz
ports-84a51750db441ff5ed4ba9e3b75a54765ca8b983.zip
Make devel/veepee building again.
Noticed on: bento
Notes
Notes: svn path=/head/; revision=70115
Diffstat (limited to 'devel/veepee')
-rw-r--r--devel/veepee/Makefile8
-rw-r--r--devel/veepee/files/patch-ab13
2 files changed, 15 insertions, 6 deletions
diff --git a/devel/veepee/Makefile b/devel/veepee/Makefile
index 7e98949881ad..1adfadc041f7 100644
--- a/devel/veepee/Makefile
+++ b/devel/veepee/Makefile
@@ -14,8 +14,6 @@ DISTNAME= VeePee-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
-BROKEN= "Does not build"
-
LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
USE_GNOMENG= yes
@@ -23,6 +21,7 @@ USE_GNOME= gnomelibs
USE_XLIB= yes
USE_PYTHON= yes
USE_LIBTOOL= yes
+USE_REINPLACE= yes
CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS} ${PYTHON_LIBS}"
CONFIGURE_ARGS= --with-gd-includes=${LOCALBASE}/include/gd \
--disable-kde
@@ -31,11 +30,12 @@ PYTHON_LIBS+= -lssl -lcrypto
.endif
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure
post-configure:
- @${PERL} -pi -e 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
+ @${REINPLACE_CMD} -e \
+ 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
${WRKSRC}/libtool
post-install:
diff --git a/devel/veepee/files/patch-ab b/devel/veepee/files/patch-ab
index 238662104f5a..43cdf45a3a18 100644
--- a/devel/veepee/files/patch-ab
+++ b/devel/veepee/files/patch-ab
@@ -1,5 +1,14 @@
---- configure.orig Sat Oct 21 18:09:50 2000
-+++ configure Sat Oct 21 18:11:01 2000
+--- configure.orig Fri Nov 15 00:03:54 2002
++++ configure Fri Nov 15 00:04:22 2002
+@@ -2764,7 +2764,7 @@
+ then
+ if test -f $vp_pyconfigdir/Makefile
+ then
+- with_extra_libs=`grep '^LIBS.*=' $vp_pyconfigdir/Makefile | sed 's/.*=//'`
++ with_extra_libs=`grep '^LIBS*=' $vp_pyconfigdir/Makefile | sed 's/.*=//'`
+ fi
+ fi
+
@@ -2777,7 +2777,7 @@
VP_GDLDFLAGS="-L$vp_gd_libdir"
VP_PYMODDIR=$vp_python_moddir