aboutsummaryrefslogtreecommitdiff
path: root/devel/websvn/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-25 20:41:27 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-25 20:41:27 +0000
commit3527016a40d00174d070ce8bf345f2458e2a380a (patch)
tree3566989984a3b20a5322bc981567ed79fcbb0bf8 /devel/websvn/Makefile
parent788d7a54196fcc76a54291236757eef2bae18e34 (diff)
downloadports-3527016a40d00174d070ce8bf345f2458e2a380a.tar.gz
ports-3527016a40d00174d070ce8bf345f2458e2a380a.zip
WebSVN offers a view onto your subversion repositories that's been designed
to reflect the Subversion methodology. You can view the log of any file or directory and see a list of all the files changed, added or deleted in any given revision. You can also view the differences between 2 versions of a file so as to see exactly what was changed in a particular revision. WWW: http://websvn.tigris.org/ PR: ports/66530 Submitted by: Yuan-Chung Hsiao <ychsiao@ychsiao.idv.tw>
Notes
Notes: svn path=/head/; revision=110006
Diffstat (limited to 'devel/websvn/Makefile')
-rw-r--r--devel/websvn/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/websvn/Makefile b/devel/websvn/Makefile
new file mode 100644
index 000000000000..6cc460a457d6
--- /dev/null
+++ b/devel/websvn/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: websvn
+# Date created: 11 May 2004
+# Whom: Yuan-Chung Hsiao (ychsiao@ychsiao.idv.tw)
+#
+# $FreeBSD$
+#
+
+PORTNAME= websvn
+PORTVERSION= 1.38
+CATEGORIES= devel www
+MASTER_SITES= http://websvn.tigris.org/files/documents/1380/10659/
+DISTNAME= WebSVN
+
+MAINTAINER= ychsiao@ychsiao.idv.tw
+COMMENT= Subversion repository web frontend
+
+USE_PHP= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/WebSVN
+
+WEBSVNDIR?= www/data/WebSVN
+
+PLIST_SUB+= WEBSVNDIR=${WEBSVNDIR}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${WEBSVNDIR}
+ ${CP} -R ${WRKSRC}/* ${PREFIX}/${WEBSVNDIR}
+ ${CHOWN} www:www ${PREFIX}/${WEBSVNDIR}
+
+.include <bsd.port.mk>