aboutsummaryrefslogtreecommitdiff
path: root/devel/zthread
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-04-29 12:19:45 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-04-29 12:19:45 +0000
commitcf4b3150c102acb9929888c8ff08339d3e976724 (patch)
treea3cc1c7e6b819da6b831f22a9311057675b04c10 /devel/zthread
parent8a276428d516547ee5827e81aae4f7b38c5bcaa2 (diff)
downloadports-cf4b3150c102acb9929888c8ff08339d3e976724.tar.gz
ports-cf4b3150c102acb9929888c8ff08339d3e976724.zip
- Update to 2.3.2
PR: ports/96344 Submitted by: Shaun Amott <shaun@inerd.com>
Notes
Notes: svn path=/head/; revision=160750
Diffstat (limited to 'devel/zthread')
-rw-r--r--devel/zthread/Makefile20
-rw-r--r--devel/zthread/distinfo6
-rw-r--r--devel/zthread/pkg-plist48
3 files changed, 57 insertions, 17 deletions
diff --git a/devel/zthread/Makefile b/devel/zthread/Makefile
index 6c15bc3f6a51..e67c92fbdf3e 100644
--- a/devel/zthread/Makefile
+++ b/devel/zthread/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= zthread
-PORTVERSION= 2.3.1
-PORTREVISION= 1
+PORTVERSION= 2.3.2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -23,9 +22,7 @@ MAKE_ARGS+= INSTALL_PROGRAM="${INSTALL_SCRIPT}"
MAKE_ENV+= SED=sed # req'd for LIBTOOL?!
INSTALLS_SHLIB= yes
-.if !defined(NOPORTDOCS)
-PORTDOCS= *
-.endif
+PORTDOCS= AUTHORS ChangeLog NEWS README TODO
.include <bsd.port.pre.mk>
@@ -36,16 +33,13 @@ USE_GCC= 3.3+
post-extract:
@${FIND} ${WRKSRC} -name CVS -type d -delete
+post-patch:
+ @${FIND} ${WRKSRC} \( -name '*.orig' -or -name '*.swp' \) -delete
+
post-install:
- @${FIND} ${PREFIX}/include/zthread -type f | \
- ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
- @${ECHO_CMD} "@dirrm include/zthread" >> ${TMPPLIST}
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}/html
-.for docfile in AUTHORS ChangeLog NEWS README TODO
- ${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
-.endfor
- ${CP} -R ${WRKSRC}/doc/html/ ${DOCSDIR}/html
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
.include <bsd.port.post.mk>
diff --git a/devel/zthread/distinfo b/devel/zthread/distinfo
index f2b78c453dd4..523f19f78b38 100644
--- a/devel/zthread/distinfo
+++ b/devel/zthread/distinfo
@@ -1,3 +1,3 @@
-MD5 (ZThread-2.3.1.tar.gz) = 21c3075808b04949bec419010b0d188c
-SHA256 (ZThread-2.3.1.tar.gz) = 726eaa358ddce23e75eb3c24668ef334159b6a953e80bff0a2d1b8f7bca86f00
-SIZE (ZThread-2.3.1.tar.gz) = 427364
+MD5 (ZThread-2.3.2.tar.gz) = f2782d19b8ed6f1ff2ab8824dd4ba48e
+SHA256 (ZThread-2.3.2.tar.gz) = 950908b7473ac10abb046bd1d75acb5934344e302db38c2225b7a90bd1eda854
+SIZE (ZThread-2.3.2.tar.gz) = 412527
diff --git a/devel/zthread/pkg-plist b/devel/zthread/pkg-plist
index 5dd877c5d7ca..bb3ee570ba16 100644
--- a/devel/zthread/pkg-plist
+++ b/devel/zthread/pkg-plist
@@ -1,7 +1,53 @@
bin/zthread-config
lib/libZThread-2.3.so
-lib/libZThread-2.3.so.1
+lib/libZThread-2.3.so.2
lib/libZThread.la
lib/libZThread.so
share/aclocal/pthread.m4
share/aclocal/zthread.m4
+include/zthread/AtomicCount.h
+include/zthread/BiasedReadWriteLock.h
+include/zthread/BlockingQueue.h
+include/zthread/BoundedQueue.h
+include/zthread/Cancelable.h
+include/zthread/ClassLockable.h
+include/zthread/ConcurrentExecutor.h
+include/zthread/Condition.h
+include/zthread/Config.h
+include/zthread/CountedPtr.h
+include/zthread/CountingSemaphore.h
+include/zthread/Exceptions.h
+include/zthread/Executor.h
+include/zthread/FairReadWriteLock.h
+include/zthread/FastMutex.h
+include/zthread/FastRecursiveMutex.h
+include/zthread/Guard.h
+include/zthread/GuardedClass.h
+include/zthread/Lockable.h
+include/zthread/Mutex.h
+include/zthread/LockedQueue.h
+include/zthread/MonitoredQueue.h
+include/zthread/NonCopyable.h
+include/zthread/PoolExecutor.h
+include/zthread/Priority.h
+include/zthread/PriorityCondition.h
+include/zthread/PriorityInheritanceMutex.h
+include/zthread/PriorityMutex.h
+include/zthread/PrioritySemaphore.h
+include/zthread/Queue.h
+include/zthread/ReadWriteLock.h
+include/zthread/RecursiveMutex.h
+include/zthread/Runnable.h
+include/zthread/Semaphore.h
+include/zthread/Singleton.h
+include/zthread/SynchronousExecutor.h
+include/zthread/Task.h
+include/zthread/Thread.h
+include/zthread/ThreadLocal.h
+include/zthread/ThreadLocalImpl.h
+include/zthread/ThreadedExecutor.h
+include/zthread/Time.h
+include/zthread/Waitable.h
+include/zthread/ZThread.h
+include/zthread/Barrier.h
+@dirrm include/zthread