aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-03-19 02:33:23 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-03-19 02:33:23 +0000
commita4d2565ccba5efa58ca32d7f2b463f5dc4a044c2 (patch)
tree547545a8f5644cfc1812851f3b767e0dd77c4ddc /devel
parentfd71a26ec53022f723fb6043ac8360d839c97d5c (diff)
downloadports-a4d2565ccba5efa58ca32d7f2b463f5dc4a044c2.tar.gz
ports-a4d2565ccba5efa58ca32d7f2b463f5dc4a044c2.zip
reimport ocaml-camomile 0.4.2
A comprehensive Unicode library for objective caml language
Notes
Notes: svn path=/head/; revision=104572
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ocaml-camomile/Makefile38
-rw-r--r--devel/ocaml-camomile/distinfo2
-rw-r--r--devel/ocaml-camomile/pkg-descr4
-rw-r--r--devel/ocaml-camomile/pkg-install9
5 files changed, 54 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1e5886d9684c..b18a92355023 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -510,6 +510,7 @@
SUBDIR += noweb
SUBDIR += nspr
SUBDIR += oaf
+ SUBDIR += ocaml-camomile
SUBDIR += ocaml-classes
SUBDIR += ocaml-findlib
SUBDIR += ocaml-pcre
diff --git a/devel/ocaml-camomile/Makefile b/devel/ocaml-camomile/Makefile
new file mode 100644
index 000000000000..3ccab9713553
--- /dev/null
+++ b/devel/ocaml-camomile/Makefile
@@ -0,0 +1,38 @@
+# ex:ts=8
+# Ports collection makefile for: camomile
+# Date created: Mar 17, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= camomile
+PORTVERSION= 0.4.2
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A comprehensive Unicode library for objective caml language
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
+ ocamlfind:${PORTSDIR}/devel/ocaml-findlib
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+PKGDEINSTALL= ${PKGINSTALL}
+
+post-install:
+ @${FIND} ${PREFIX}/lib/ocaml/site-lib/${PORTNAME} -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${ECHO_CMD} "@dirrm lib/ocaml/site-lib/${PORTNAME}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec ocamlfind remove ${PORTNAME} 2>/dev/null || true" >> ${TMPPLIST}
+ @${FIND} ${DATADIR} -type f | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${DATADIR} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/devel/ocaml-camomile/distinfo b/devel/ocaml-camomile/distinfo
new file mode 100644
index 000000000000..82c36b85a252
--- /dev/null
+++ b/devel/ocaml-camomile/distinfo
@@ -0,0 +1,2 @@
+MD5 (camomile-0.4.2.tar.bz2) = 8a548a5b8774a313221b7a9ac85f9ee7
+SIZE (camomile-0.4.2.tar.bz2) = 2120067
diff --git a/devel/ocaml-camomile/pkg-descr b/devel/ocaml-camomile/pkg-descr
new file mode 100644
index 000000000000..163f0042194a
--- /dev/null
+++ b/devel/ocaml-camomile/pkg-descr
@@ -0,0 +1,4 @@
+Camomile is a comprehensive Unicode library for objective caml language.
+The library is currently designed to conform Unicode Standard 3.2.
+
+WWW: http://camomile.sourceforge.net/
diff --git a/devel/ocaml-camomile/pkg-install b/devel/ocaml-camomile/pkg-install
new file mode 100644
index 000000000000..6ff19f476711
--- /dev/null
+++ b/devel/ocaml-camomile/pkg-install
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+if [ "$2" = "POST-INSTALL" ]; then
+ echo "${PKG_PREFIX}/lib/ocaml/site-lib/camomile" >> ${PKG_PREFIX}/lib/ocaml/ld.conf
+elif [ "$2" = "DEINSTALL" ]; then
+ mv ${PKG_PREFIX}/lib/ocaml/ld.conf ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp
+ grep -v camomile ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp > ${PKG_PREFIX}/lib/ocaml/ld.conf
+ rm -f ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp
+fi